aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/unison/Makefile4
-rw-r--r--net/unison/distinfo16
-rw-r--r--net/unison/files/patch-aa34
-rw-r--r--net/unison/files/patch-pty.c27
-rw-r--r--net/unison/pkg-message2
-rw-r--r--net/unison232/Makefile4
-rw-r--r--net/unison232/distinfo16
-rw-r--r--net/unison232/files/patch-aa34
-rw-r--r--net/unison232/files/patch-pty.c27
-rw-r--r--net/unison232/pkg-message2
10 files changed, 96 insertions, 70 deletions
diff --git a/net/unison/Makefile b/net/unison/Makefile
index 3e74de040f44..770156cb781b 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= unison
-PORTVERSION= 2.10.2
+PORTVERSION= 2.13.16
CATEGORIES= net
-MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/beta-test/${DIST_SUBDIR}/
+MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/stable/
DISTFILES= ${EXTRACT_ONLY} ${EXTRA_DOCS}
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
diff --git a/net/unison/distinfo b/net/unison/distinfo
index 994c5869f514..addd6cb4abb8 100644
--- a/net/unison/distinfo
+++ b/net/unison/distinfo
@@ -1,8 +1,8 @@
-MD5 (unison-2.10.2/unison-2.10.2.tar.gz) = a93cf03d4221ab6bab8b758b0325a9d5
-SIZE (unison-2.10.2/unison-2.10.2.tar.gz) = 458032
-MD5 (unison-2.10.2/unison-2.10.2-manual.html) = 46cac2b5b84e821d39cc5a100dd97e7a
-SIZE (unison-2.10.2/unison-2.10.2-manual.html) = 190911
-MD5 (unison-2.10.2/unison-2.10.2-manual.pdf) = 7e6b018d758b786d7cf5752413c08168
-SIZE (unison-2.10.2/unison-2.10.2-manual.pdf) = 354402
-MD5 (unison-2.10.2/unison-2.10.2-manual.ps) = 89cc36cf06d688f163a924fc8c1a47f9
-SIZE (unison-2.10.2/unison-2.10.2-manual.ps) = 490966
+MD5 (unison-2.13.16/unison-2.13.16.tar.gz) = a79bf5f4ebf2a1eaf15b1ac97f827374
+SIZE (unison-2.13.16/unison-2.13.16.tar.gz) = 393266
+MD5 (unison-2.13.16/unison-2.13.16-manual.html) = 2b39e52ec3893a112b28b7b0a294d941
+SIZE (unison-2.13.16/unison-2.13.16-manual.html) = 196162
+MD5 (unison-2.13.16/unison-2.13.16-manual.pdf) = e7684d401d6f5ee194b9e631cc022dd6
+SIZE (unison-2.13.16/unison-2.13.16-manual.pdf) = 436229
+MD5 (unison-2.13.16/unison-2.13.16-manual.ps) = 49cd0eef6cc98a1af7fed38313ccab42
+SIZE (unison-2.13.16/unison-2.13.16-manual.ps) = 414346
diff --git a/net/unison/files/patch-aa b/net/unison/files/patch-aa
index a14c18bfa972..483f1bab2391 100644
--- a/net/unison/files/patch-aa
+++ b/net/unison/files/patch-aa
@@ -1,27 +1,31 @@
---- Makefile.orig Tue Aug 28 16:27:01 2001
-+++ Makefile Wed Aug 29 09:15:09 2001
-@@ -62,12 +62,12 @@
+--- Makefile.orig Sat Aug 27 15:49:56 2005
++++ Makefile Sat Aug 27 15:51:55 2005
+@@ -68,15 +68,15 @@
######################################################################
# Installation
-INSTALLDIR = $(HOME)/bin/
+INSTALLDIR = ${PREFIX}/bin/
- install: $(NAME)$(EXEC_EXT)
+ # This has two names because on OSX the file INSTALL shadows the target 'install'!
+ install: doinstall
+
+ doinstall: $(NAME)$(EXEC_EXT)
- -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
+- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)
+- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(MAJORVERSION)$(EXEC_EXT)
+# -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)
-- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(VERSION)$(EXEC_EXT)
-+# cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(VERSION)$(EXEC_EXT)
- @# If we're running at Penn, install a public version too
- if [ -d /plclub/bin ]; then cp $(NAME)$(EXEC_EXT) /plclub/bin/$(NAME)-$(VERSION)$(EXEC_EXT); fi
++ ${BSD_INSTALL_PROGRAM} $(NAME)$(EXEC_EXT) $(INSTALLDIR)
++# cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(MAJORVERSION)$(EXEC_EXT)
+
+
+ ######################################################################
+@@ -353,7 +353,7 @@
+ .PHONY: tags
-@@ -231,7 +231,7 @@
tags:
- -$(ETAGS) *.ml *.mli *.txt
+- -$(ETAGS) *.mli */*.mli *.ml */*.ml *.m */*.m *.c */*.c *.txt
++ -$(ETAGS) *.mli */*.mli *.ml */*.ml */*.m *.c */*.c *.txt
--all:: TAGS
-+#all:: TAGS
+ all:: TAGS
- TAGS:
- $(MAKE) tags
diff --git a/net/unison/files/patch-pty.c b/net/unison/files/patch-pty.c
index 833ac9b05ed4..2066ff98bdcd 100644
--- a/net/unison/files/patch-pty.c
+++ b/net/unison/files/patch-pty.c
@@ -1,13 +1,22 @@
---- pty.c.orig Sun Jan 23 19:55:28 2005
-+++ pty.c Sun Jan 23 19:56:28 2005
-@@ -32,6 +32,10 @@
- #ifdef __APPLE__
- #include <util.h> // openpty
+--- pty.c.orig Mon May 30 15:15:43 2005
++++ pty.c Sat Aug 27 15:47:55 2005
+@@ -21,6 +21,7 @@
#endif
-+#ifdef __FreeBSD__
-+#include <sys/types.h>
-+#include <libutil.h>
-+#endif
+ #ifdef __FreeBSD__
++#include <sys/types.h>
+ #include <libutil.h>
+ #define HAS_OPENPTY 1
+ #endif
+@@ -40,9 +41,10 @@
/* c_openpty: unit -> (int * Unix.file_descr) */
CAMLprim value c_openpty() {
+ int master,slave;
++ value pair;
+ if (openpty(&master,&slave,NULL,NULL,NULL) < 0)
+ uerror("openpty", (value) 0);
+- value pair = alloc_tuple(2);
++ pair = alloc_tuple(2);
+ Store_field(pair,0,Val_int(master));
+ Store_field(pair,1,Val_int(slave));
+ return pair;
diff --git a/net/unison/pkg-message b/net/unison/pkg-message
index 61c81306e650..c7cedb69cfdc 100644
--- a/net/unison/pkg-message
+++ b/net/unison/pkg-message
@@ -1,7 +1,7 @@
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ATTENTION:
-1) Unison archive format has changed since 2.9.20. The old archive
+1) Unison archive format has changed since 2.10.2. The old archive
won't be deleted automatically in case you want to downgrade it.
2) Merge functionality has seriously changed. Check the manual.
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index 3e74de040f44..770156cb781b 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= unison
-PORTVERSION= 2.10.2
+PORTVERSION= 2.13.16
CATEGORIES= net
-MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/beta-test/${DIST_SUBDIR}/
+MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/stable/
DISTFILES= ${EXTRACT_ONLY} ${EXTRA_DOCS}
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
diff --git a/net/unison232/distinfo b/net/unison232/distinfo
index 994c5869f514..addd6cb4abb8 100644
--- a/net/unison232/distinfo
+++ b/net/unison232/distinfo
@@ -1,8 +1,8 @@
-MD5 (unison-2.10.2/unison-2.10.2.tar.gz) = a93cf03d4221ab6bab8b758b0325a9d5
-SIZE (unison-2.10.2/unison-2.10.2.tar.gz) = 458032
-MD5 (unison-2.10.2/unison-2.10.2-manual.html) = 46cac2b5b84e821d39cc5a100dd97e7a
-SIZE (unison-2.10.2/unison-2.10.2-manual.html) = 190911
-MD5 (unison-2.10.2/unison-2.10.2-manual.pdf) = 7e6b018d758b786d7cf5752413c08168
-SIZE (unison-2.10.2/unison-2.10.2-manual.pdf) = 354402
-MD5 (unison-2.10.2/unison-2.10.2-manual.ps) = 89cc36cf06d688f163a924fc8c1a47f9
-SIZE (unison-2.10.2/unison-2.10.2-manual.ps) = 490966
+MD5 (unison-2.13.16/unison-2.13.16.tar.gz) = a79bf5f4ebf2a1eaf15b1ac97f827374
+SIZE (unison-2.13.16/unison-2.13.16.tar.gz) = 393266
+MD5 (unison-2.13.16/unison-2.13.16-manual.html) = 2b39e52ec3893a112b28b7b0a294d941
+SIZE (unison-2.13.16/unison-2.13.16-manual.html) = 196162
+MD5 (unison-2.13.16/unison-2.13.16-manual.pdf) = e7684d401d6f5ee194b9e631cc022dd6
+SIZE (unison-2.13.16/unison-2.13.16-manual.pdf) = 436229
+MD5 (unison-2.13.16/unison-2.13.16-manual.ps) = 49cd0eef6cc98a1af7fed38313ccab42
+SIZE (unison-2.13.16/unison-2.13.16-manual.ps) = 414346
diff --git a/net/unison232/files/patch-aa b/net/unison232/files/patch-aa
index a14c18bfa972..483f1bab2391 100644
--- a/net/unison232/files/patch-aa
+++ b/net/unison232/files/patch-aa
@@ -1,27 +1,31 @@
---- Makefile.orig Tue Aug 28 16:27:01 2001
-+++ Makefile Wed Aug 29 09:15:09 2001
-@@ -62,12 +62,12 @@
+--- Makefile.orig Sat Aug 27 15:49:56 2005
++++ Makefile Sat Aug 27 15:51:55 2005
+@@ -68,15 +68,15 @@
######################################################################
# Installation
-INSTALLDIR = $(HOME)/bin/
+INSTALLDIR = ${PREFIX}/bin/
- install: $(NAME)$(EXEC_EXT)
+ # This has two names because on OSX the file INSTALL shadows the target 'install'!
+ install: doinstall
+
+ doinstall: $(NAME)$(EXEC_EXT)
- -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
+- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)
+- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(MAJORVERSION)$(EXEC_EXT)
+# -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)
-- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(VERSION)$(EXEC_EXT)
-+# cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(VERSION)$(EXEC_EXT)
- @# If we're running at Penn, install a public version too
- if [ -d /plclub/bin ]; then cp $(NAME)$(EXEC_EXT) /plclub/bin/$(NAME)-$(VERSION)$(EXEC_EXT); fi
++ ${BSD_INSTALL_PROGRAM} $(NAME)$(EXEC_EXT) $(INSTALLDIR)
++# cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(MAJORVERSION)$(EXEC_EXT)
+
+
+ ######################################################################
+@@ -353,7 +353,7 @@
+ .PHONY: tags
-@@ -231,7 +231,7 @@
tags:
- -$(ETAGS) *.ml *.mli *.txt
+- -$(ETAGS) *.mli */*.mli *.ml */*.ml *.m */*.m *.c */*.c *.txt
++ -$(ETAGS) *.mli */*.mli *.ml */*.ml */*.m *.c */*.c *.txt
--all:: TAGS
-+#all:: TAGS
+ all:: TAGS
- TAGS:
- $(MAKE) tags
diff --git a/net/unison232/files/patch-pty.c b/net/unison232/files/patch-pty.c
index 833ac9b05ed4..2066ff98bdcd 100644
--- a/net/unison232/files/patch-pty.c
+++ b/net/unison232/files/patch-pty.c
@@ -1,13 +1,22 @@
---- pty.c.orig Sun Jan 23 19:55:28 2005
-+++ pty.c Sun Jan 23 19:56:28 2005
-@@ -32,6 +32,10 @@
- #ifdef __APPLE__
- #include <util.h> // openpty
+--- pty.c.orig Mon May 30 15:15:43 2005
++++ pty.c Sat Aug 27 15:47:55 2005
+@@ -21,6 +21,7 @@
#endif
-+#ifdef __FreeBSD__
-+#include <sys/types.h>
-+#include <libutil.h>
-+#endif
+ #ifdef __FreeBSD__
++#include <sys/types.h>
+ #include <libutil.h>
+ #define HAS_OPENPTY 1
+ #endif
+@@ -40,9 +41,10 @@
/* c_openpty: unit -> (int * Unix.file_descr) */
CAMLprim value c_openpty() {
+ int master,slave;
++ value pair;
+ if (openpty(&master,&slave,NULL,NULL,NULL) < 0)
+ uerror("openpty", (value) 0);
+- value pair = alloc_tuple(2);
++ pair = alloc_tuple(2);
+ Store_field(pair,0,Val_int(master));
+ Store_field(pair,1,Val_int(slave));
+ return pair;
diff --git a/net/unison232/pkg-message b/net/unison232/pkg-message
index 61c81306e650..c7cedb69cfdc 100644
--- a/net/unison232/pkg-message
+++ b/net/unison232/pkg-message
@@ -1,7 +1,7 @@
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ATTENTION:
-1) Unison archive format has changed since 2.9.20. The old archive
+1) Unison archive format has changed since 2.10.2. The old archive
won't be deleted automatically in case you want to downgrade it.
2) Merge functionality has seriously changed. Check the manual.