aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/sipxproxy/Makefile48
-rw-r--r--net/sipxproxy/distinfo3
-rw-r--r--net/sipxproxy/files/patch-bin_sipproxy.sh.in11
-rw-r--r--net/sipxproxy/files/patch-bin_sipxcallresolver.sh.in56
-rw-r--r--net/sipxproxy/files/patch-doc-Makefile.am11
-rw-r--r--net/sipxproxy/files/patch-doc-Makefile.in11
-rw-r--r--net/sipxproxy/files/pkg-deinstall.in19
-rw-r--r--net/sipxproxy/pkg-descr4
-rw-r--r--net/sipxproxy/pkg-plist20
-rw-r--r--net/sipxvxml/Makefile43
-rw-r--r--net/sipxvxml/distinfo3
-rw-r--r--net/sipxvxml/files/patch-doc-Makefile.am11
-rw-r--r--net/sipxvxml/files/patch-doc-Makefile.in11
-rw-r--r--net/sipxvxml/files/patch-include_wwwconf.h11
-rw-r--r--net/sipxvxml/files/patch-src_VXI_XMLChConverter.hpp11
-rw-r--r--net/sipxvxml/files/patch-src_client_Makefile.am12
-rw-r--r--net/sipxvxml/files/patch-src_client_Makefile.in12
-rw-r--r--net/sipxvxml/files/patch-src_inet_SBinetHttpStream.cpp10
-rw-r--r--net/sipxvxml/files/patch-src_log_SBlogOSUtils.cpp10
-rw-r--r--net/sipxvxml/files/patch-src_trd_OSBtrdPthreads.cpp11
-rw-r--r--net/sipxvxml/files/pkg-deinstall.in19
-rw-r--r--net/sipxvxml/pkg-descr4
-rw-r--r--net/sipxvxml/pkg-plist58
24 files changed, 410 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e5c227bbf1a3..f7bcb71286dd 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -753,6 +753,7 @@
SUBDIR += sipxproxy
SUBDIR += sipxpublisher
SUBDIR += sipxtacklib
+ SUBDIR += sipxvxml
SUBDIR += sixxs-aiccu
SUBDIR += sixxs-heartbeatd
SUBDIR += skstream
diff --git a/net/sipxproxy/Makefile b/net/sipxproxy/Makefile
new file mode 100644
index 000000000000..e18cded9fac0
--- /dev/null
+++ b/net/sipxproxy/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: sipxproxy
+# Date created: Jan 8, 2007
+# Whom: Michael Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipxproxy
+PORTVERSION= 3.6.0
+CATEGORIES= net
+MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= sipX server for handling SIP authorization and call records
+
+LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
+ sipXtack:${PORTSDIR}/net/sipxtacklib \
+ sipXcommserver:${PORTSDIR}/net/sipxcommserverlib \
+ pcre.0:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ psql:${PORTSDIR}/databases/postgresql81-client
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ gem:${PORTSDIR}/devel/ruby-gems \
+ rake:${PORTSDIR}/devel/rubygem-rake \
+ ginstall:${PORTSDIR}/sysutils/coreutils \
+ cppunit-config:${PORTSDIR}/devel/cppunit
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_RUBY= yes
+USE_AUTOTOOLS= autoconf:259:env automake:19:env
+GNU_CONFIGURE= yes
+LOCALSTATEDIR=${DESTDIR}/var
+CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
+ INSTALL=`which ginstall`
+CONFIGURE_ARGS+= --enable-sip-tls \
+ --prefix=${PREFIX} \
+ --localstatedir=${LOCALSTATEDIR}
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
+SUB_FILES= pkg-deinstall
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipxcallresolver.sh.in
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipproxy.sh.in
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipauthproxy.sh.in
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipxha-distrib.sh.in
+
+.include <bsd.port.mk>
diff --git a/net/sipxproxy/distinfo b/net/sipxproxy/distinfo
new file mode 100644
index 000000000000..5f7f6300ef5f
--- /dev/null
+++ b/net/sipxproxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (sipxproxy-3.6.0.tar.bz2) = 8d35667fa4188316e9b6ac0ae94dd920
+SHA256 (sipxproxy-3.6.0.tar.bz2) = a6591579070c4c113852753593e4f152577da5e5e399ed50d78efc667a24334f
+SIZE (sipxproxy-3.6.0.tar.bz2) = 372514
diff --git a/net/sipxproxy/files/patch-bin_sipproxy.sh.in b/net/sipxproxy/files/patch-bin_sipproxy.sh.in
new file mode 100644
index 000000000000..96770ad0cc7a
--- /dev/null
+++ b/net/sipxproxy/files/patch-bin_sipproxy.sh.in
@@ -0,0 +1,11 @@
+--- ./bin/sipproxy.sh.in.orig Mon Jan 1 19:19:25 2007
++++ ./bin/sipproxy.sh.in Mon Jan 1 19:30:05 2007
+@@ -57,7 +57,7 @@
+ #@bindir@/sipx-validate-xml @SIPX_CONFDIR@/forwardingrules.xml
+ #Status=$?
+
+- myHostname=`hostname -f | tr A-Z a-z`
++ myHostname=`hostname | tr A-Z a-z`
+ status=$?
+ Status=$((${Status}+${status}))
+
diff --git a/net/sipxproxy/files/patch-bin_sipxcallresolver.sh.in b/net/sipxproxy/files/patch-bin_sipxcallresolver.sh.in
new file mode 100644
index 000000000000..de371481d4c6
--- /dev/null
+++ b/net/sipxproxy/files/patch-bin_sipxcallresolver.sh.in
@@ -0,0 +1,56 @@
+--- ./bin/sipxcallresolver.sh.in.orig Mon Jan 1 15:29:43 2007
++++ ./bin/sipxcallresolver.sh.in Mon Jan 1 16:28:32 2007
+@@ -30,7 +30,7 @@
+ : ${LogDir:=@SIPX_LOGDIR@}
+ : ${TmpDir:=@SIPX_TMPDIR@}
+ : ${RunningUser:=@SIPXPBXUSER@}
+-: ${PgUser:=postgres}
++: ${PgUser:=pgsql}
+ : ${PgSchema:=@SIPX_CONFDIR@/cdr/schema.sql}
+ : ${DbVersion:=2}
+ : ${DbPatchDir:=@SIPX_CONFDIR@/cdr}
+@@ -178,7 +178,7 @@
+ # 2. running but not setup to communicate w/java or ${Psql} command
+ # 3. Database is not created
+ databaseCheck() {
+- if ! ${Psql} -l -U postgres | grep "${Database}" >/dev/null 2>&1
++ if ! ${Psql} -l -U pgsql | grep "${Database}" >/dev/null 2>&1
+ then
+ procs=`ps -C postmaster`
+ if ! expr match "$procs" '.*postmaster.*' >/dev/null; then
+@@ -190,15 +190,9 @@
+ fi
+ else
+ # Check postgres configuration
+- Service=`postgresService`
++ Service=postgresql
+ if test -z $PGDATA; then
+- # Debian/Gentoo
+- if test -d /var/lib/postgresql/data; then
+- PGDATA=/var/lib/postgresql/data
+- else
+- # Redhat
+- PGDATA=/var/lib/pgsql/data
+- fi
++ PGDATA=/usr/local/pgsql/data
+ fi
+ # Check for conf file
+ if [ -f $PGDATA/pg_hba.conf ]; then
+@@ -213,7 +207,7 @@
+ fi
+ else
+ # Check if psql command works at all
+- if ${Psql} -l -U postgres >/dev/null 2>&1; then
++ if ${Psql} -l -U pgsql >/dev/null 2>&1; then
+ if [ "$1" != "Silent" ]; then
+ echo
+ echo " Error: The SIPXCDR database does not exist. Run the sipxcallresolver.sh"
+@@ -415,7 +409,7 @@
+ # Check the database version. If it is wrong, then exit, because it's dangerous to
+ # run call resolver on top of the wrong database version.
+ databaseVersionCheck() {
+- dbver=`${Psql} -c "select max(vh.version) from version_history vh;" ${Database} postgres | sed -n 's/^\s*\([0-9][0-9]*\)\s*$/\1/p'`
++ dbver=`${Psql} -c "select max(vh.version) from version_history vh;" ${Database} pgsql | sed -n 's/^\s*\([0-9][0-9]*\)\s*$/\1/p'`
+ if [ "$dbver" = "" ]
+ then
+ echo " Error: could not get the database version."
diff --git a/net/sipxproxy/files/patch-doc-Makefile.am b/net/sipxproxy/files/patch-doc-Makefile.am
new file mode 100644
index 000000000000..c69f243adf86
--- /dev/null
+++ b/net/sipxproxy/files/patch-doc-Makefile.am
@@ -0,0 +1,11 @@
+--- doc/Makefile.am.orig Mon Jan 29 14:35:49 2007
++++ doc/Makefile.am Mon Jan 29 14:36:06 2007
+@@ -28,7 +28,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxproxy/files/patch-doc-Makefile.in b/net/sipxproxy/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..cc7935d720e6
--- /dev/null
+++ b/net/sipxproxy/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Mon Jan 29 14:35:56 2007
++++ doc/Makefile.in Mon Jan 29 14:36:17 2007
+@@ -481,7 +481,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxproxy/files/pkg-deinstall.in b/net/sipxproxy/files/pkg-deinstall.in
new file mode 100644
index 000000000000..44586360bbaa
--- /dev/null
+++ b/net/sipxproxy/files/pkg-deinstall.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin:/usr/bin:/usr/sbin
+
+LOCALSTATEDIR="%%LOCALSTATEDIR%%"
+
+post-deinstall() {
+ echo "WARNING: If you will *NOT* use this package anymore, please remove
+ the"
+ echo " following file manually:"
+ echo " ${LOCALSTATEDIR}/sipxdata/upgrade/sipxproxy-previous.tgz"
+ echo
+}
+
+case $2 in
+ POST-DEINSTALL)
+ post-deinstall
+ ;;
+esac
diff --git a/net/sipxproxy/pkg-descr b/net/sipxproxy/pkg-descr
new file mode 100644
index 000000000000..d3e7f1251e2a
--- /dev/null
+++ b/net/sipxproxy/pkg-descr
@@ -0,0 +1,4 @@
+sipXproxy is the authorization and call record server component of the
+sipX family.
+
+WWW: http://sipx-wiki.calivia.com/index.php/Main_Page
diff --git a/net/sipxproxy/pkg-plist b/net/sipxproxy/pkg-plist
new file mode 100644
index 000000000000..2e47ba2d2552
--- /dev/null
+++ b/net/sipxproxy/pkg-plist
@@ -0,0 +1,20 @@
+bin/sipauthproxy
+bin/sipauthproxy.sh
+bin/sipproxy
+bin/sipproxy.sh
+bin/sipxcallresolver.sh
+bin/sipxha-distrib.sh
+bin/sipxproxy-config
+etc/sipxpbx/authproxy-config.in
+etc/sipxpbx/authrules.xml.in
+etc/sipxpbx/callresolver-config.in
+etc/sipxpbx/cdr/refer_uri.sql
+etc/sipxpbx/cdr/schema.sql
+etc/sipxpbx/cdr/view_cdrs.sql
+etc/sipxpbx/forwardingrules.xml.in
+etc/sipxpbx/process.d/sipauthproxy.process.xml
+etc/sipxpbx/process.d/sipproxy.process.xml
+etc/sipxpbx/proxy-config.in
+@dirrm etc/sipxpbx/process.d
+@dirrm etc/sipxpbx/cdr
+@dirrm etc/sipxpbx
diff --git a/net/sipxvxml/Makefile b/net/sipxvxml/Makefile
new file mode 100644
index 000000000000..779225817b42
--- /dev/null
+++ b/net/sipxvxml/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: sipxvxml
+# Date created: Jan 8, 2007
+# Whom: Michael Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipxvxml
+PORTVERSION= 3.6.0
+CATEGORIES= net
+MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= sipX server for managing XML files
+
+BUILD_DEPENDS= ginstall:${PORTSDIR}/sysutils/coreutils
+LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
+ sipXtack:${PORTSDIR}/net/sipxtacklib \
+ sipXmedia:${PORTSDIR}/net/sipxmedialib \
+ sipXmediaProcessing:${PORTSDIR}/net/sipxmediaadapterlib \
+ sipXcall:${PORTSDIR}/net/sipxcalllib \
+ wwwssl:${PORTSDIR}/www/libwww \
+ xerces-c:${PORTSDIR}/textproc/xerces-c2 \
+ pcre.0:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:259:env automake:19:env
+GNU_CONFIGURE= yes
+LOCALSTATEDIR=${DESTDIR}/var
+CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
+ INSTALL=`which ginstall`
+CONFIGURE_ARGS+= --enable-sip-tls \
+ --prefix=${PREFIX} \
+ --localstatedir=${LOCALSTATEDIR}
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
+SUB_FILES= pkg-deinstall
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipXvxml.sh.in
+
+.include <bsd.port.mk>
diff --git a/net/sipxvxml/distinfo b/net/sipxvxml/distinfo
new file mode 100644
index 000000000000..9d31b3058f26
--- /dev/null
+++ b/net/sipxvxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (sipxvxml-3.6.0.tar.bz2) = 38384c68f5bb636015c7e7634a74ef49
+SHA256 (sipxvxml-3.6.0.tar.bz2) = 8572dda530b38619d47f10fab8f6c2a98c5c0e9d71caed21d689f20561f8d51d
+SIZE (sipxvxml-3.6.0.tar.bz2) = 982889
diff --git a/net/sipxvxml/files/patch-doc-Makefile.am b/net/sipxvxml/files/patch-doc-Makefile.am
new file mode 100644
index 000000000000..f4c7f32028e6
--- /dev/null
+++ b/net/sipxvxml/files/patch-doc-Makefile.am
@@ -0,0 +1,11 @@
+--- doc/Makefile.am.orig Tue Jan 30 12:45:17 2007
++++ doc/Makefile.am Tue Jan 30 12:46:02 2007
+@@ -28,7 +28,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxvxml/files/patch-doc-Makefile.in b/net/sipxvxml/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..540f7287ae71
--- /dev/null
+++ b/net/sipxvxml/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Tue Jan 30 12:45:22 2007
++++ doc/Makefile.in Tue Jan 30 12:46:13 2007
+@@ -486,7 +486,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxvxml/files/patch-include_wwwconf.h b/net/sipxvxml/files/patch-include_wwwconf.h
new file mode 100644
index 000000000000..ea859d7c3033
--- /dev/null
+++ b/net/sipxvxml/files/patch-include_wwwconf.h
@@ -0,0 +1,11 @@
+--- ./include/wwwconf.h.orig Fri Dec 29 10:57:47 2006
++++ ./include/wwwconf.h Fri Dec 29 10:58:09 2006
+@@ -348,7 +348,7 @@
+ #define HAVE_LIMITS_H 1
+
+ /* Define if you have the <malloc.h> header file. */
+-#define HAVE_MALLOC_H 1
++/* #undef HAVE_MALLOC_H */
+
+ /* Define if you have the <manifest.h> header file. */
+ /* #undef HAVE_MANIFEST_H */
diff --git a/net/sipxvxml/files/patch-src_VXI_XMLChConverter.hpp b/net/sipxvxml/files/patch-src_VXI_XMLChConverter.hpp
new file mode 100644
index 000000000000..12fb161989d0
--- /dev/null
+++ b/net/sipxvxml/files/patch-src_VXI_XMLChConverter.hpp
@@ -0,0 +1,11 @@
+--- ./src/VXI/XMLChConverter.hpp.orig Fri Dec 29 11:01:48 2006
++++ ./src/VXI/XMLChConverter.hpp Fri Dec 29 11:02:27 2006
+@@ -27,7 +27,7 @@
+ // provides an imperfect conversion from UTF-16 to UTF-32, ignoring all
+ // surrogate pairs.
+
+-#if defined(__linux__) || \
++#if defined(__linux__) || defined(__FreeBSD__) || \
+ defined(SOLARIS) || defined(__SVR4) || defined(UNIXWARE)
+ #define UTF16TO32
+
diff --git a/net/sipxvxml/files/patch-src_client_Makefile.am b/net/sipxvxml/files/patch-src_client_Makefile.am
new file mode 100644
index 000000000000..e2743f855548
--- /dev/null
+++ b/net/sipxvxml/files/patch-src_client_Makefile.am
@@ -0,0 +1,12 @@
+--- ./src/client/Makefile.am.orig Fri Dec 29 11:05:14 2006
++++ ./src/client/Makefile.am Fri Dec 29 11:05:50 2006
+@@ -39,7 +39,8 @@
+ @SIPXMEDIAADAPTER_LIBS@ \
+ @SIPXCALL_LIBS@ \
+ @LIBWWW_LIBS@ \
+- @XERCES_LIBS@
++ @XERCES_LIBS@ \
++ -lcompat
+
+ noinst_HEADERS = \
+ ivr/clientMain.h \
diff --git a/net/sipxvxml/files/patch-src_client_Makefile.in b/net/sipxvxml/files/patch-src_client_Makefile.in
new file mode 100644
index 000000000000..840d01b8a45f
--- /dev/null
+++ b/net/sipxvxml/files/patch-src_client_Makefile.in
@@ -0,0 +1,12 @@
+--- ./src/client/Makefile.in.orig Fri Dec 29 11:05:19 2006
++++ ./src/client/Makefile.in Fri Dec 29 11:06:14 2006
+@@ -306,7 +306,8 @@
+ @SIPXMEDIAADAPTER_LIBS@ \
+ @SIPXCALL_LIBS@ \
+ @LIBWWW_LIBS@ \
+- @XERCES_LIBS@
++ @XERCES_LIBS@ \
++ -lcompat
+
+ noinst_HEADERS = \
+ ivr/clientMain.h \
diff --git a/net/sipxvxml/files/patch-src_inet_SBinetHttpStream.cpp b/net/sipxvxml/files/patch-src_inet_SBinetHttpStream.cpp
new file mode 100644
index 000000000000..84f388cbc870
--- /dev/null
+++ b/net/sipxvxml/files/patch-src_inet_SBinetHttpStream.cpp
@@ -0,0 +1,10 @@
+--- ./src/inet/SBinetHttpStream.cpp.orig Fri Dec 29 10:58:52 2006
++++ ./src/inet/SBinetHttpStream.cpp Fri Dec 29 10:59:06 2006
+@@ -35,6 +35,7 @@
+ #include <windows.h>
+ #endif
+
++#include <sys/types.h>
+ #include <sys/timeb.h> // for _ftime( )/ftime( )
+ #include <assert.h>
+
diff --git a/net/sipxvxml/files/patch-src_log_SBlogOSUtils.cpp b/net/sipxvxml/files/patch-src_log_SBlogOSUtils.cpp
new file mode 100644
index 000000000000..f8a9062faf45
--- /dev/null
+++ b/net/sipxvxml/files/patch-src_log_SBlogOSUtils.cpp
@@ -0,0 +1,10 @@
+--- ./src/log/SBlogOSUtils.cpp.orig Fri Dec 29 10:50:07 2006
++++ ./src/log/SBlogOSUtils.cpp Fri Dec 29 10:50:26 2006
+@@ -37,6 +37,7 @@
+ #include <sys/times.h> // For times( )
+ #endif
+
++#include <sys/types.h>
+ #include <sys/timeb.h> // for ftime( )/_ftime( )
+ #include <sys/stat.h> // for stat( )
+
diff --git a/net/sipxvxml/files/patch-src_trd_OSBtrdPthreads.cpp b/net/sipxvxml/files/patch-src_trd_OSBtrdPthreads.cpp
new file mode 100644
index 000000000000..cf5b59c5f774
--- /dev/null
+++ b/net/sipxvxml/files/patch-src_trd_OSBtrdPthreads.cpp
@@ -0,0 +1,11 @@
+--- ./src/trd/OSBtrdPthreads.cpp.orig Fri Dec 29 10:46:31 2006
++++ ./src/trd/OSBtrdPthreads.cpp Fri Dec 29 10:48:57 2006
+@@ -497,7 +497,7 @@
+ if (thread == NULL)
+ return -1;
+
+- return thread->thread;
++ return (VXIlong)thread->thread;
+ }
+
+
diff --git a/net/sipxvxml/files/pkg-deinstall.in b/net/sipxvxml/files/pkg-deinstall.in
new file mode 100644
index 000000000000..de8521966d59
--- /dev/null
+++ b/net/sipxvxml/files/pkg-deinstall.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin:/usr/bin:/usr/sbin
+
+LOCALSTATEDIR="%%LOCALSTATEDIR%%"
+
+post-deinstall() {
+ echo "WARNING: If you will *NOT* use this package anymore, please remove
+ the"
+ echo " following file manually:"
+ echo " ${LOCALSTATEDIR}/sipxdata/upgrade/sipxvxml-previous.tgz"
+ echo
+}
+
+case $2 in
+ POST-DEINSTALL)
+ post-deinstall
+ ;;
+esac
diff --git a/net/sipxvxml/pkg-descr b/net/sipxvxml/pkg-descr
new file mode 100644
index 000000000000..d3e7f1251e2a
--- /dev/null
+++ b/net/sipxvxml/pkg-descr
@@ -0,0 +1,4 @@
+sipXproxy is the authorization and call record server component of the
+sipX family.
+
+WWW: http://sipx-wiki.calivia.com/index.php/Main_Page
diff --git a/net/sipxvxml/pkg-plist b/net/sipxvxml/pkg-plist
new file mode 100644
index 000000000000..5ac783dd58a2
--- /dev/null
+++ b/net/sipxvxml/pkg-plist
@@ -0,0 +1,58 @@
+bin/sipXvxml
+bin/sipXvxml.sh
+bin/sipxvxml-config
+etc/sipxpbx/mediaserver-config.in
+etc/sipxpbx/process.d/sipXvxml.process.xml
+include/src/fdlibm/fdlibm.h
+include/src/jsapi.h
+include/src/jsarena.h
+include/src/jsarray.h
+include/src/jsatom.h
+include/src/jsbit.h
+include/src/jsbool.h
+include/src/jsclist.h
+include/src/jscntxt.h
+include/src/jscompat.h
+include/src/jsconfig.h
+include/src/jscpucfg.h
+include/src/jsdate.h
+include/src/jsdbgapi.h
+include/src/jsdhash.h
+include/src/jsdtoa.h
+include/src/jsemit.h
+include/src/jsexn.h
+include/src/jsfile.h
+include/src/jsfun.h
+include/src/jsgc.h
+include/src/jshash.h
+include/src/jsinterp.h
+include/src/jslibmath.h
+include/src/jslock.h
+include/src/jslong.h
+include/src/jsmath.h
+include/src/jsnum.h
+include/src/jsobj.h
+include/src/jsopcode.h
+include/src/jsosdep.h
+include/src/jsotypes.h
+include/src/jsparse.h
+include/src/jsprf.h
+include/src/jsprvtd.h
+include/src/jspubtd.h
+include/src/jsregexp.h
+include/src/jsscan.h
+include/src/jsscope.h
+include/src/jsscript.h
+include/src/jsstddef.h
+include/src/jsstr.h
+include/src/jstypes.h
+include/src/jsutil.h
+include/src/jsxdrapi.h
+include/src/prmjtime.h
+include/src/resource.h
+@dirrm www/sipX/conf
+@dirrm www/sipX
+@dirrm include/src/fdlibm
+@dirrm include/src
+@dirrm etc/sipxpbx/process.d
+@dirrm etc/sipxpbx