aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/p5-Amazon-SQS-Simple/Makefile2
-rw-r--r--net/p5-EasyTCP/Makefile4
-rw-r--r--net/p5-Google-SAML-Request/Makefile2
-rw-r--r--net/p5-Net-BGP/Makefile6
-rw-r--r--net/p5-Net-Blogger/Makefile2
-rw-r--r--net/p5-Net-GrowlClient/Makefile7
-rw-r--r--net/p5-Net-Mosso-CloudFiles/Makefile4
-rw-r--r--net/p5-Net-Packet/Makefile5
-rw-r--r--net/p5-Net-SSH-Perl/Makefile3
-rw-r--r--net/p5-XML-Compile-SOAP-Daemon/Makefile2
-rw-r--r--net/shelldap/Makefile2
-rw-r--r--net/smbldap-tools/Makefile2
12 files changed, 17 insertions, 24 deletions
diff --git a/net/p5-Amazon-SQS-Simple/Makefile b/net/p5-Amazon-SQS-Simple/Makefile
index aef0cc0df4a5..d76f55b6f733 100644
--- a/net/p5-Amazon-SQS-Simple/Makefile
+++ b/net/p5-Amazon-SQS-Simple/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Amazon-SQS-Simple
PORTVERSION= 1.05
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN/../../authors/id/S/SW/SWHITAKER
PKGNAMEPREFIX= p5-
@@ -17,7 +18,6 @@ COMMENT= OO API for accessing the Amazon Simple Queue Service
BUILD_DEPENDS= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/net/p5-EasyTCP/Makefile b/net/p5-EasyTCP/Makefile
index 7641daea246e..5c565d281ec4 100644
--- a/net/p5-EasyTCP/Makefile
+++ b/net/p5-EasyTCP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= EasyTCP
PORTVERSION= 0.26
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Easily create TCP/IP clients and servers
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/Crypt/RSA.pm:${PORTSDIR}/security/p5-Crypt-RSA
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/RSA.pm:${PORTSDIR}/security/p5-Crypt-RSA
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Google-SAML-Request/Makefile b/net/p5-Google-SAML-Request/Makefile
index 44796aa8b0f0..15b2841ab437 100644
--- a/net/p5-Google-SAML-Request/Makefile
+++ b/net/p5-Google-SAML-Request/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Google-SAML-Request
PORTVERSION= 0.04
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,7 +16,6 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Create or parse Google\'s SAML requests
RUN_DEPENDS= p5-Compress-Zlib>0:${PORTSDIR}/archivers/p5-Compress-Zlib \
- p5-MIME-Base64>0:${PORTSDIR}/converters/p5-MIME-Base64 \
p5-TimeDate>0:${PORTSDIR}/devel/p5-TimeDate \
p5-URI>0:${PORTSDIR}/net/p5-URI \
p5-XML-Simple>0:${PORTSDIR}/textproc/p5-XML-Simple
diff --git a/net/p5-Net-BGP/Makefile b/net/p5-Net-BGP/Makefile
index b9b0a6016eba..7d174be6a24c 100644
--- a/net/p5-Net-BGP/Makefile
+++ b/net/p5-Net-BGP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-BGP
PORTVERSION= 0.13
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,11 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Border Gateway Protocol version 4 speaker/listener library
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- ${SITE_PERL}/TAP/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Net::BGP.3 Net::BGP::ASPath.3 Net::BGP::NLRI.3 \
diff --git a/net/p5-Net-Blogger/Makefile b/net/p5-Net-Blogger/Makefile
index b238ee6a75f5..c9848653fb94 100644
--- a/net/p5-Net-Blogger/Makefile
+++ b/net/p5-Net-Blogger/Makefile
@@ -8,6 +8,7 @@
PORTNAME= Net-Blogger
PORTVERSION= 1.02
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,7 +18,6 @@ COMMENT= An OOP-ish interface for accessing a weblog via the XML-RPC API
BUILD_DEPENDS= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/HTTP/Cookies.pm:${PORTSDIR}/www/p5-libwww \
p5-SOAP-Lite>0.55:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/net/p5-Net-GrowlClient/Makefile b/net/p5-Net-GrowlClient/Makefile
index b3f2f05856fd..1b85a762a39b 100644
--- a/net/p5-Net-GrowlClient/Makefile
+++ b/net/p5-Net-GrowlClient/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-GrowlClient
PORTVERSION= 0.02
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= Net
@@ -15,10 +16,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= markun@onohara.to
COMMENT= Perl implementation of Growl Network Notification Protocol
-BUILD_DEPENDS= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-RUN_DEPENDS= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+BUILD_DEPENDS= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+RUN_DEPENDS= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Mosso-CloudFiles/Makefile b/net/p5-Net-Mosso-CloudFiles/Makefile
index 33096258fe08..a1f3486fe21e 100644
--- a/net/p5-Net-Mosso-CloudFiles/Makefile
+++ b/net/p5-Net-Mosso-CloudFiles/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-Mosso-CloudFiles
PORTVERSION= 0.43
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Perl interface to the Mosso CloudFiles service
-RUN_DEPENDS= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-Digest-MD5-File>=0:${PORTSDIR}/security/p5-Digest-MD5-File \
+RUN_DEPENDS= p5-Digest-MD5-File>=0:${PORTSDIR}/security/p5-Digest-MD5-File \
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-MooseX-StrictConstructor>=0:${PORTSDIR}/devel/p5-MooseX-StrictConstructor \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
diff --git a/net/p5-Net-Packet/Makefile b/net/p5-Net-Packet/Makefile
index fc5efc67fd42..d8b9773dd995 100644
--- a/net/p5-Net-Packet/Makefile
+++ b/net/p5-Net-Packet/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-Packet
DISTVERSION= 3.26
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -20,9 +21,7 @@ BUILD_DEPENDS= p5-Bit-Vector>=6.4:${PORTSDIR}/math/p5-Bit-Vector \
p5-Net-Libdnet>=0.01:${PORTSDIR}/net/p5-Net-Libdnet \
p5-Net-Write>=1.00:${PORTSDIR}/net/p5-Net-Write \
p5-Net-Pcap>=0.14:${PORTSDIR}/net/p5-Net-Pcap \
- p5-Socket6>=0.19:${PORTSDIR}/net/p5-Socket6 \
- p5-Storable>=2.15:${PORTSDIR}/devel/p5-Storable \
- p5-Time-HiRes>=1.90,1:${PORTSDIR}/devel/p5-Time-HiRes
+ p5-Socket6>=0.19:${PORTSDIR}/net/p5-Socket6
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-SSH-Perl/Makefile b/net/p5-Net-SSH-Perl/Makefile
index 4cfc7aea8a2a..a929b69d09bc 100644
--- a/net/p5-Net-SSH-Perl/Makefile
+++ b/net/p5-Net-SSH-Perl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Net-SSH-Perl
PORTVERSION= 1.34
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,7 +17,6 @@ COMMENT= Perl5 module implements both the SSH1 and SSH2 protocols
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32 \
${SITE_PERL}/${PERL_ARCH}/Math/GMP.pm:${PORTSDIR}/math/p5-Math-GMP \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC \
${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
${SITE_PERL}/Crypt/DSA.pm:${PORTSDIR}/security/p5-Crypt-DSA \
diff --git a/net/p5-XML-Compile-SOAP-Daemon/Makefile b/net/p5-XML-Compile-SOAP-Daemon/Makefile
index 94e166da1db3..135a2f62a7a2 100644
--- a/net/p5-XML-Compile-SOAP-Daemon/Makefile
+++ b/net/p5-XML-Compile-SOAP-Daemon/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XML-Compile-SOAP-Daemon
PORTVERSION= 2.01
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,7 +16,6 @@ MAINTAINER= lth@FreeBSD.org
COMMENT= Base class for SOAP message servers
BUILD_DEPENDS= p5-Net-Server>=0.97:${PORTSDIR}/net/p5-Net-Server \
- p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes \
p5-libwww>=5.803:${PORTSDIR}/www/p5-libwww \
p5-Log-Report>=0.22:${PORTSDIR}/devel/p5-Log-Report \
p5-XML-Compile-SOAP>=2.02:${PORTSDIR}/net/p5-XML-Compile-SOAP \
diff --git a/net/shelldap/Makefile b/net/shelldap/Makefile
index aee4fa2dbce6..287de86d8a68 100644
--- a/net/shelldap/Makefile
+++ b/net/shelldap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= shelldap
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.martini.nu/misc/
@@ -15,7 +16,6 @@ COMMENT= A shell-like environment for LDAP
RUN_DEPENDS= ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
- ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Term/Shell.pm:${PORTSDIR}/devel/p5-Term-Shell \
${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
diff --git a/net/smbldap-tools/Makefile b/net/smbldap-tools/Makefile
index f291b02c8f8d..ef5dd2af3d86 100644
--- a/net/smbldap-tools/Makefile
+++ b/net/smbldap-tools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= smbldap-tools
PORTVERSION= 0.9.5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://download.gna.org/smbldap-tools/packages/ \
http://download.gna.org/smbldap-tools/packages/old-Idealx-release/
@@ -17,7 +18,6 @@ COMMENT= Samba-LDAP management and support tools
BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
${SITE_PERL}/Crypt/SmbHash.pm:${PORTSDIR}/security/p5-Crypt-SmbHash \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
${SITE_PERL}/${PERL_ARCH}/Unicode/Map8.pm:${PORTSDIR}/converters/p5-Unicode-MapUTF8
RUN_DEPENDS= ${BUILD_DEPENDS}