aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile2
-rw-r--r--net/hs-aws/Makefile24
-rw-r--r--net/hs-aws/distinfo2
-rw-r--r--net/hs-aws/pkg-descr4
-rw-r--r--net/hs-connection/Makefile7
-rw-r--r--net/hs-connection/distinfo4
-rw-r--r--net/hs-gsasl/Makefile3
-rw-r--r--net/hs-gsasl/distinfo4
-rw-r--r--net/hs-hoauth2/Makefile5
-rw-r--r--net/hs-hoauth2/distinfo4
-rw-r--r--net/hs-hostname/Makefile2
-rw-r--r--net/hs-iproute/Makefile3
-rw-r--r--net/hs-iproute/distinfo4
-rw-r--r--net/hs-maccatcher/Makefile2
-rw-r--r--net/hs-network-info/Makefile3
-rw-r--r--net/hs-network-info/distinfo4
-rw-r--r--net/hs-network-info/pkg-descr4
-rw-r--r--net/hs-network-multicast/Makefile3
-rw-r--r--net/hs-network-multicast/distinfo4
-rw-r--r--net/hs-network-protocol-xmpp/Makefile3
-rw-r--r--net/hs-network-protocol-xmpp/distinfo4
-rw-r--r--net/hs-network-uri/Makefile15
-rw-r--r--net/hs-network-uri/distinfo2
-rw-r--r--net/hs-network-uri/pkg-descr3
-rw-r--r--net/hs-network/Makefile5
-rw-r--r--net/hs-network/distinfo4
-rw-r--r--net/hs-pcap/Makefile2
-rw-r--r--net/hs-publicsuffixlist/Makefile2
-rw-r--r--net/hs-sendfile/Makefile2
-rw-r--r--net/hs-simple-sendfile/Makefile5
-rw-r--r--net/hs-simple-sendfile/distinfo4
-rw-r--r--net/hs-socks/Makefile2
32 files changed, 90 insertions, 51 deletions
diff --git a/net/Makefile b/net/Makefile
index 9c12bdc25ae2..f4a627086d34 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -204,6 +204,7 @@
SUBDIR += howl
SUBDIR += hping
SUBDIR += hping-devel
+ SUBDIR += hs-aws
SUBDIR += hs-connection
SUBDIR += hs-gsasl
SUBDIR += hs-hoauth2
@@ -214,6 +215,7 @@
SUBDIR += hs-network-info
SUBDIR += hs-network-multicast
SUBDIR += hs-network-protocol-xmpp
+ SUBDIR += hs-network-uri
SUBDIR += hs-pcap
SUBDIR += hs-publicsuffixlist
SUBDIR += hs-sendfile
diff --git a/net/hs-aws/Makefile b/net/hs-aws/Makefile
new file mode 100644
index 000000000000..71f44d33fdf7
--- /dev/null
+++ b/net/hs-aws/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= aws
+PORTVERSION= 0.12.1
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Amazon Web Services (AWS) for Haskell
+
+LICENSE= BSD3CLAUSE
+
+USE_CABAL= aeson>=0.6 attoparsec>=0.11 base16-bytestring \
+ base64-bytestring blaze-builder>=0.2.1.4 byteable \
+ case-insensitive>=0.2 cereal>=0.3 conduit>=1.1 \
+ conduit-extra>=1.1 cryptohash>=0.11 data-default>=0.5.3 \
+ http-conduit>=2.1 http-types>=0.7 lifted-base>=0.1 \
+ monad-control>=0.3 mtl network resourcet>=1.1 safe>=0.3 \
+ scientific>=0.3 tagged>=0.7 text>=0.11 unordered-containers>=0.2 \
+ utf8-string>=0.3 vector>=0.10 xml-conduit>=1.2
+
+FLAGS_DISABLE= examples
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-aws/distinfo b/net/hs-aws/distinfo
new file mode 100644
index 000000000000..92504fa4d92c
--- /dev/null
+++ b/net/hs-aws/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/aws-0.12.1.tar.gz) = 6c85bac359ea94d78f287b45c6e7e981dc260a1c029a7888ed752a1c0e64d32b
+SIZE (cabal/aws-0.12.1.tar.gz) = 90763
diff --git a/net/hs-aws/pkg-descr b/net/hs-aws/pkg-descr
new file mode 100644
index 000000000000..6611a710ce38
--- /dev/null
+++ b/net/hs-aws/pkg-descr
@@ -0,0 +1,4 @@
+Bindings for Amazon Web Services (AWS), with the aim of supporting all
+AWS services.
+
+WWW: http://github.com/aristidb/aws
diff --git a/net/hs-connection/Makefile b/net/hs-connection/Makefile
index 4d091352a710..55510b972653 100644
--- a/net/hs-connection/Makefile
+++ b/net/hs-connection/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= connection
-PORTVERSION= 0.2.3
-PORTREVISION= 1
+PORTVERSION= 0.2.5
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,8 +9,8 @@ COMMENT= Simple and easy network connections API
LICENSE= BSD3CLAUSE
-USE_CABAL= cprng-aes data-default-class network>=2.3 socks>=0.4 \
- tls>=1.2 x509>=1.4 x509-store>=1.4 x509-system>=1.4 \
+USE_CABAL= byteable data-default-class network>=2.3 socks>=0.4 \
+ tls>=1.3 x509>=1.5 x509-store>=1.5 x509-system>=1.5 \
x509-validation>=1.5
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/net/hs-connection/distinfo b/net/hs-connection/distinfo
index b8a65f4ee764..6c7a00b4df1d 100644
--- a/net/hs-connection/distinfo
+++ b/net/hs-connection/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/connection-0.2.3.tar.gz) = 4b6f62d66bebc38052e98f2b6798acdb79c9171b170d2e059aaa697d53b0b80a
-SIZE (cabal/connection-0.2.3.tar.gz) = 7621
+SHA256 (cabal/connection-0.2.5.tar.gz) = 8895d4427985202ac439b884deb4b5675ccba3d9498fce3687f1542b4ba21124
+SIZE (cabal/connection-0.2.5.tar.gz) = 7576
diff --git a/net/hs-gsasl/Makefile b/net/hs-gsasl/Makefile
index cffd993f64a2..3e86bf190cec 100644
--- a/net/hs-gsasl/Makefile
+++ b/net/hs-gsasl/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gsasl
-PORTVERSION= 0.3.5
-PORTREVISION= 1
+PORTVERSION= 0.3.6
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-gsasl/distinfo b/net/hs-gsasl/distinfo
index a131f7646ff7..eed538cf5f9b 100644
--- a/net/hs-gsasl/distinfo
+++ b/net/hs-gsasl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/gsasl-0.3.5.tar.gz) = a3aecd149b580e2afc0f3473e806e2245a0b649df6c8359540fa65af8dce279d
-SIZE (cabal/gsasl-0.3.5.tar.gz) = 20117
+SHA256 (cabal/gsasl-0.3.6.tar.gz) = 786036025e5d5649c029c1db23c395e1592c073a58848ae4afe4f2797de1f931
+SIZE (cabal/gsasl-0.3.6.tar.gz) = 20170
diff --git a/net/hs-hoauth2/Makefile b/net/hs-hoauth2/Makefile
index e13775f72f59..b2106bf3be04 100644
--- a/net/hs-hoauth2/Makefile
+++ b/net/hs-hoauth2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= hoauth2
-PORTVERSION= 0.4.3
+PORTVERSION= 0.4.8
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
@@ -9,8 +9,7 @@ COMMENT= Haskell OAuth2 authentication
LICENSE= BSD3CLAUSE
-USE_CABAL= aeson>=0.7 bytestring-show>=0.3.5 http-conduit>=2.0 \
- http-types>=0.8 monad-control>=0.3 mtl>=1 random text>=0.11
+USE_CABAL= aeson>=0.7 http-conduit>=2.0 http-types>=0.8 text>=0.11
FLAGS_DISABLE= test
diff --git a/net/hs-hoauth2/distinfo b/net/hs-hoauth2/distinfo
index 6814cecdecb3..ca1820dacddf 100644
--- a/net/hs-hoauth2/distinfo
+++ b/net/hs-hoauth2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/hoauth2-0.4.3.tar.gz) = 6f531f635c62cc7c42fb3e33193833adfdf789aafa2d2c754be2f23c609ab0e2
-SIZE (cabal/hoauth2-0.4.3.tar.gz) = 8480
+SHA256 (cabal/hoauth2-0.4.8.tar.gz) = 6e489820dee16b926225e58555032e32d345b234b5a798db6e5a1d63d2843093
+SIZE (cabal/hoauth2-0.4.8.tar.gz) = 8599
diff --git a/net/hs-hostname/Makefile b/net/hs-hostname/Makefile
index eac7de57d9c5..55bc6f9a60ac 100644
--- a/net/hs-hostname/Makefile
+++ b/net/hs-hostname/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hostname
PORTVERSION= 1.0
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-iproute/Makefile b/net/hs-iproute/Makefile
index 8c7b112f8528..d276318be63b 100644
--- a/net/hs-iproute/Makefile
+++ b/net/hs-iproute/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= iproute
-PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTVERSION= 1.5.0
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-iproute/distinfo b/net/hs-iproute/distinfo
index 0d63cbcabc6a..15154787516c 100644
--- a/net/hs-iproute/distinfo
+++ b/net/hs-iproute/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/iproute-1.3.1.tar.gz) = b73104d337f14e63e1ca84dd37405df28e7a7f7e714e83efd63cca80d1d66ad0
-SIZE (cabal/iproute-1.3.1.tar.gz) = 9897
+SHA256 (cabal/iproute-1.5.0.tar.gz) = e33b233c681be367162c342ebf3843ec2d858db49716ef52d96546bd3f6f2557
+SIZE (cabal/iproute-1.5.0.tar.gz) = 11570
diff --git a/net/hs-maccatcher/Makefile b/net/hs-maccatcher/Makefile
index 15d1b91796f6..971217b80cce 100644
--- a/net/hs-maccatcher/Makefile
+++ b/net/hs-maccatcher/Makefile
@@ -2,7 +2,7 @@
PORTNAME= maccatcher
PORTVERSION= 2.1.5
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network-info/Makefile b/net/hs-network-info/Makefile
index 8d469c388fd2..4797f1391686 100644
--- a/net/hs-network-info/Makefile
+++ b/net/hs-network-info/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= network-info
-PORTVERSION= 0.2.0.5
-PORTREVISION= 1
+PORTVERSION= 0.2.0.7
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network-info/distinfo b/net/hs-network-info/distinfo
index f0291a2020a4..6f30b63dacfb 100644
--- a/net/hs-network-info/distinfo
+++ b/net/hs-network-info/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/network-info-0.2.0.5.tar.gz) = 8ee37b7e3219d18395a3c9020a9be8cfa7c5390f2c4b0e54b5feea35e5b4fd3d
-SIZE (cabal/network-info-0.2.0.5.tar.gz) = 5988
+SHA256 (cabal/network-info-0.2.0.7.tar.gz) = ef36e2c3d60d120c91d07dfe1081c87b73d0917cee858fba42598f284301405d
+SIZE (cabal/network-info-0.2.0.7.tar.gz) = 6023
diff --git a/net/hs-network-info/pkg-descr b/net/hs-network-info/pkg-descr
index f1952a45c1a3..e2a6a9759553 100644
--- a/net/hs-network-info/pkg-descr
+++ b/net/hs-network-info/pkg-descr
@@ -1,8 +1,6 @@
This library provides simple read-only access to the local computer's
networking configuration. It is currently capable of getting a list of
all the network interfaces and their respective IPv4, IPv6 and MAC
-addresses. network-info has been tested and is known to work on Ubuntu
-10.10, FreeBSD 9.0, Mac OS X 10.6.4 and Windows XP/7. It probably works
-on other flavours of Linux, OS X, FreeBSD and Windows as well.
+addresses.
WWW: http://github.com/jystic/network-info
diff --git a/net/hs-network-multicast/Makefile b/net/hs-network-multicast/Makefile
index da7b76d5ab77..bce66f51037a 100644
--- a/net/hs-network-multicast/Makefile
+++ b/net/hs-network-multicast/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= network-multicast
-PORTVERSION= 0.0.11
-PORTREVISION= 1
+PORTVERSION= 0.1.0
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network-multicast/distinfo b/net/hs-network-multicast/distinfo
index 1c8fabe78227..7d9dd5ea1875 100644
--- a/net/hs-network-multicast/distinfo
+++ b/net/hs-network-multicast/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/network-multicast-0.0.11.tar.gz) = 65842175e53bb72164b7b1a448a3cc4bdf42df8d64089853ea54ccccd266fa39
-SIZE (cabal/network-multicast-0.0.11.tar.gz) = 2970
+SHA256 (cabal/network-multicast-0.1.0.tar.gz) = 18c2db0f8db5b9f4d3b65dbaa19ed77f4ebcf9c97e2d85657b6777f2b0e47a8a
+SIZE (cabal/network-multicast-0.1.0.tar.gz) = 3023
diff --git a/net/hs-network-protocol-xmpp/Makefile b/net/hs-network-protocol-xmpp/Makefile
index 5fad8f04cbc6..5de0c546f856 100644
--- a/net/hs-network-protocol-xmpp/Makefile
+++ b/net/hs-network-protocol-xmpp/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= network-protocol-xmpp
-PORTVERSION= 0.4.6
-PORTREVISION= 2
+PORTVERSION= 0.4.8
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-network-protocol-xmpp/distinfo b/net/hs-network-protocol-xmpp/distinfo
index 60fb116b3f2e..5b933efea04c 100644
--- a/net/hs-network-protocol-xmpp/distinfo
+++ b/net/hs-network-protocol-xmpp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/network-protocol-xmpp-0.4.6.tar.gz) = d6ec010deff24503e8f8fdb67cfd10ba84f19907c95bf1fca24dec10be74aa76
-SIZE (cabal/network-protocol-xmpp-0.4.6.tar.gz) = 24100
+SHA256 (cabal/network-protocol-xmpp-0.4.8.tar.gz) = ea7729e00452da11ed489a71f482e0aa082b0fb872eedca2e3722a05fd421e1e
+SIZE (cabal/network-protocol-xmpp-0.4.8.tar.gz) = 24289
diff --git a/net/hs-network-uri/Makefile b/net/hs-network-uri/Makefile
new file mode 100644
index 000000000000..d332dc2aa1f4
--- /dev/null
+++ b/net/hs-network-uri/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= network-uri
+PORTVERSION= 2.6.0.3
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= URI manipulation
+
+LICENSE= BSD3CLAUSE
+
+USE_CABAL= parsec>=3.0
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-network-uri/distinfo b/net/hs-network-uri/distinfo
new file mode 100644
index 000000000000..17a6a11ab8ab
--- /dev/null
+++ b/net/hs-network-uri/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/network-uri-2.6.0.3.tar.gz) = 0fc2cdff47ca77d826ebeb5cabe6ddac2333ca1504b2b629dd369399c5c28bdf
+SIZE (cabal/network-uri-2.6.0.3.tar.gz) = 26639
diff --git a/net/hs-network-uri/pkg-descr b/net/hs-network-uri/pkg-descr
new file mode 100644
index 000000000000..887de7f00388
--- /dev/null
+++ b/net/hs-network-uri/pkg-descr
@@ -0,0 +1,3 @@
+This package provides an URI manipulation inteface.
+
+WWW: https://github.com/haskell/network-uri
diff --git a/net/hs-network/Makefile b/net/hs-network/Makefile
index 95de119a1663..9488f8b51502 100644
--- a/net/hs-network/Makefile
+++ b/net/hs-network/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= network
-PORTVERSION= 2.4.2.3
-PORTREVISION= 1
+PORTVERSION= 2.6.2.1
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,7 +9,5 @@ COMMENT= Low-level networking interface
LICENSE= BSD3CLAUSE
-USE_CABAL= parsec>=3.0
-
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/net/hs-network/distinfo b/net/hs-network/distinfo
index f5340112bb53..06580ff16573 100644
--- a/net/hs-network/distinfo
+++ b/net/hs-network/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/network-2.4.2.3.tar.gz) = 801b9c652dae626bf4a96175162b1290e7fe7ff20d802d62434d5ae1d363c16d
-SIZE (cabal/network-2.4.2.3.tar.gz) = 141749
+SHA256 (cabal/network-2.6.2.1.tar.gz) = a3fda15c9bbe2c7274d97f40398c6cf8d1d3a9fe896fbf6531e1bfc849bb1bfa
+SIZE (cabal/network-2.6.2.1.tar.gz) = 118092
diff --git a/net/hs-pcap/Makefile b/net/hs-pcap/Makefile
index dd45e7a1aac7..fcf980bf1e6e 100644
--- a/net/hs-pcap/Makefile
+++ b/net/hs-pcap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pcap
PORTVERSION= 0.4.5.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-publicsuffixlist/Makefile b/net/hs-publicsuffixlist/Makefile
index 27d50f98e8c7..e59804cf6026 100644
--- a/net/hs-publicsuffixlist/Makefile
+++ b/net/hs-publicsuffixlist/Makefile
@@ -2,7 +2,7 @@
PORTNAME= publicsuffixlist
PORTVERSION= 0.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-sendfile/Makefile b/net/hs-sendfile/Makefile
index 02b58e2f7d0b..cfc4cd43ccf2 100644
--- a/net/hs-sendfile/Makefile
+++ b/net/hs-sendfile/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sendfile
PORTVERSION= 0.7.9
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/net/hs-simple-sendfile/Makefile b/net/hs-simple-sendfile/Makefile
index 1e50b24d48ea..90a2d0c51ac0 100644
--- a/net/hs-simple-sendfile/Makefile
+++ b/net/hs-simple-sendfile/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= simple-sendfile
-PORTVERSION= 0.2.15
-PORTREVISION= 1
+PORTVERSION= 0.2.21
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,7 +9,7 @@ COMMENT= Cross-platform library for the sendfile() system call
LICENSE= BSD3CLAUSE
-USE_CABAL= network resourcet
+USE_CABAL= conduit>=1.0 conduit-extra>=1.0 network resourcet
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/net/hs-simple-sendfile/distinfo b/net/hs-simple-sendfile/distinfo
index cc996f48dca6..f495e1140d4f 100644
--- a/net/hs-simple-sendfile/distinfo
+++ b/net/hs-simple-sendfile/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/simple-sendfile-0.2.15.tar.gz) = 49fa29f71239f59ee9a141f9c9ca0d3e2f3428b416a822cb6abc6ff6050442b9
-SIZE (cabal/simple-sendfile-0.2.15.tar.gz) = 7321
+SHA256 (cabal/simple-sendfile-0.2.21.tar.gz) = 61239d6c5e94ec76067d88d8a09589b53ca0a5d1806fd9f3e042d007cc67fd77
+SIZE (cabal/simple-sendfile-0.2.21.tar.gz) = 7469
diff --git a/net/hs-socks/Makefile b/net/hs-socks/Makefile
index 94eb21c1ca04..4b0b02db8278 100644
--- a/net/hs-socks/Makefile
+++ b/net/hs-socks/Makefile
@@ -2,7 +2,7 @@
PORTNAME= socks
PORTVERSION= 0.5.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net haskell
MAINTAINER= haskell@FreeBSD.org