aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile4
-rw-r--r--net/kdenetwork4-filesharing/Makefile17
-rw-r--r--net/kdenetwork4-filesharing/distinfo2
-rw-r--r--net/kdenetwork4-filesharing/pkg-descr1
-rw-r--r--net/kdenetwork4-filesharing/pkg-plist2
-rw-r--r--net/kdenetwork4-strigi-analyzers/Makefile19
-rw-r--r--net/kdenetwork4-strigi-analyzers/distinfo2
-rw-r--r--net/kdenetwork4-strigi-analyzers/pkg-descr3
-rw-r--r--net/kdenetwork4-strigi-analyzers/pkg-plist1
-rw-r--r--net/kdenetwork4/Makefile76
-rw-r--r--net/kdenetwork4/distinfo2
-rw-r--r--net/kdenetwork4/files/patch-CMakeLists.txt10
-rw-r--r--net/kdenetwork4/files/patch-kget__transfer-plugins__bittorrent__CMakeLists.txt10
-rw-r--r--net/kdenetwork4/pkg-descr2
-rw-r--r--net/kdnssd/Makefile17
-rw-r--r--net/kdnssd/distinfo2
-rw-r--r--net/kdnssd/pkg-descr1
-rw-r--r--net/kdnssd/pkg-plist6
-rw-r--r--net/kget/Makefile29
-rw-r--r--net/kget/distinfo2
-rw-r--r--net/kget/pkg-descr1
-rw-r--r--net/kget/pkg-plist (renamed from net/kdenetwork4/pkg-plist)33
-rw-r--r--net/krdc/Makefile17
-rw-r--r--net/krdc/distinfo2
-rw-r--r--net/krdc/pkg-plist4
-rw-r--r--net/krfb/Makefile17
-rw-r--r--net/krfb/distinfo2
-rw-r--r--net/krfb/pkg-plist2
28 files changed, 174 insertions, 112 deletions
diff --git a/net/Makefile b/net/Makefile
index 8c5ebd733f36..dd56423f6d4a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -279,6 +279,10 @@
SUBDIR += jumpgate
SUBDIR += jwhois
SUBDIR += kdenetwork4
+ SUBDIR += kdenetwork4-filesharing
+ SUBDIR += kdenetwork4-strigi-analyzers
+ SUBDIR += kdnssd
+ SUBDIR += kget
SUBDIR += kio-upnp-ms
SUBDIR += kippo
SUBDIR += kissd
diff --git a/net/kdenetwork4-filesharing/Makefile b/net/kdenetwork4-filesharing/Makefile
new file mode 100644
index 000000000000..59363fb70c6f
--- /dev/null
+++ b/net/kdenetwork4-filesharing/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= kdenetwork-filesharing
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= net kde
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE Filesharing via Samba
+
+USE_XZ= yes
+USE_KDE4= kdelibs kdeprefix kdehier automoc4
+USES= cmake:outsource
+USE_QT4= moc_build qmake_build rcc_build uic_build
+
+.include <bsd.port.mk>
diff --git a/net/kdenetwork4-filesharing/distinfo b/net/kdenetwork4-filesharing/distinfo
new file mode 100644
index 000000000000..4bb6d2e46ede
--- /dev/null
+++ b/net/kdenetwork4-filesharing/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.12.2/kdenetwork-filesharing-4.12.2.tar.xz) = b23733c30c3d246df3b84f9d0b00c2c3c59e53f310eed8a7789ed7da3fc5b13f
+SIZE (KDE/4.12.2/kdenetwork-filesharing-4.12.2.tar.xz) = 27632
diff --git a/net/kdenetwork4-filesharing/pkg-descr b/net/kdenetwork4-filesharing/pkg-descr
new file mode 100644
index 000000000000..52745e7ae0a3
--- /dev/null
+++ b/net/kdenetwork4-filesharing/pkg-descr
@@ -0,0 +1 @@
+Filesharing Interfaces.
diff --git a/net/kdenetwork4-filesharing/pkg-plist b/net/kdenetwork4-filesharing/pkg-plist
new file mode 100644
index 000000000000..3367b2ad241b
--- /dev/null
+++ b/net/kdenetwork4-filesharing/pkg-plist
@@ -0,0 +1,2 @@
+lib/kde4/sambausershareplugin.so
+share/kde4/services/sambausershareplugin.desktop
diff --git a/net/kdenetwork4-strigi-analyzers/Makefile b/net/kdenetwork4-strigi-analyzers/Makefile
new file mode 100644
index 000000000000..58ccfb3a6ba3
--- /dev/null
+++ b/net/kdenetwork4-strigi-analyzers/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= kdenetwork-strigi-analyzers
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= net kde
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Strigi analyzers for network-related file formats
+
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
+
+USE_XZ= yes
+USE_KDE4= kdelibs kdeprefix kdehier strigi automoc4
+USES= cmake:outsource
+USE_QT4= moc_build qmake_build rcc_build uic_build
+
+.include <bsd.port.mk>
diff --git a/net/kdenetwork4-strigi-analyzers/distinfo b/net/kdenetwork4-strigi-analyzers/distinfo
new file mode 100644
index 000000000000..b64851bb6bf7
--- /dev/null
+++ b/net/kdenetwork4-strigi-analyzers/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.12.2/kdenetwork-strigi-analyzers-4.12.2.tar.xz) = 011471687ab6fcfab410ec275dc47d84af426cd05a21a8bfad0d67f7f38b1ed1
+SIZE (KDE/4.12.2/kdenetwork-strigi-analyzers-4.12.2.tar.xz) = 14716
diff --git a/net/kdenetwork4-strigi-analyzers/pkg-descr b/net/kdenetwork4-strigi-analyzers/pkg-descr
new file mode 100644
index 000000000000..f69d770040ef
--- /dev/null
+++ b/net/kdenetwork4-strigi-analyzers/pkg-descr
@@ -0,0 +1,3 @@
+Strigi analyzers for network-related file formats.
+
+WWW: https://projects.kde.org/projects/kde/kdenetwork/kdenetwork-strigi-analyzers
diff --git a/net/kdenetwork4-strigi-analyzers/pkg-plist b/net/kdenetwork4-strigi-analyzers/pkg-plist
new file mode 100644
index 000000000000..61cbcd5ef000
--- /dev/null
+++ b/net/kdenetwork4-strigi-analyzers/pkg-plist
@@ -0,0 +1 @@
+lib/strigi/strigita_torrent_analyzer.so
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 9e47d2f3d71e..ff63a190dca5 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -1,62 +1,40 @@
-# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
PORTNAME= kdenetwork
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
-CATEGORIES= net kde ipv6
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE/${PORTVERSION}
+CATEGORIES= net kde
+DISTFILES= #
MAINTAINER= kde@FreeBSD.org
-COMMENT= KDE Network applications
-
-LIB_DEPENDS= libqca.so:${PORTSDIR}/devel/qca \
- libktorrent.so:${PORTSDIR}/net-p2p/libktorrent \
- libboost_thread.so:${PORTSDIR}/devel/boost-libs \
- libmms.so:${PORTSDIR}/net/libmms \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
-RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
-
-LATEST_LINK= ${PORTNAME}4
-
-USE_KDE4= kdehier kdelibs kdeprefix libkonq pimlibs workspace \
- automoc4 ontologies strigi
-USES= cmake:outsource
-USE_OPENSSL= yes
-USE_QT4= corelib gui sql \
- moc_build qmake_build rcc_build uic_build
-USE_SQLITE= yes
-USE_XORG= x11 xdamage xext xscrnsaver xtst
-USE_XZ= yes
-USE_LDCONFIG= yes
-CONFIGURE_ENV= XDG_CONFIG_HOME=/dev/null
-MAKE_ENV= XDG_CONFIG_HOME=/dev/null
-
-CMAKE_ARGS+= -DBUILD_kopete=off \
- -DBUILD_krdc=off \
- -DBUILD_krfb=off
-
-OPTIONS_DEFINE= KOPETE KRDC KRFB
+COMMENT= KDE Network applications (meta port)
+
+USE_KDE4= kdeprefix
+NO_BUILD= yes
+NO_INSTALL= yes
+NO_MTREE= yes
+
+OPTIONS_DEFINE= FILESHARING KDNSSD KGET KOPETE KRDC KRFB STRIGI
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-KOPETE_DESC= Multi-protocol instant messenger
-KRDC_DESC= RDP and VNC client for KDE
-KRFB_DESC= VNC server for KDE
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+FILESHARING_DESC= Network file sharing via Samba
+FILESHARING_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/sambausershareplugin.so:${PORTSDIR}/net/kdenetwork4-filesharing
+
+KDNSSD_DESC= Network monitor for DNS-SD services (Zeroconf)
+KDNSSD_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kded_dnssdwatcher.so:${PORTSDIR}/net/kdnssd
+
+KGET_DESC= Download manager
+KGET_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kget:${PORTSDIR}/net/kget
+
+KOPETE_DESC= Multi-protocol instant messenger
+KOPETE_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kopete:${PORTSDIR}/net-im/kopete-kde4
-.if ${PORT_OPTIONS:MKOPETE}
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kopete:${PORTSDIR}/net-im/kopete-kde4
-.endif
+KRDC_DESC= RDP and VNC client
+KRDC_RUN_DEPENDS= ${KDE4_PREFIX}/bin/krdc:${PORTSDIR}/net/krdc
-.if ${PORT_OPTIONS:MKRDC}
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/krdc:${PORTSDIR}/net/krdc
-.endif
+KRFB_DESC= Desktop Sharing (VNC server)
+KRFB_RUN_DEPENDS= ${KDE4_PREFIX}/bin/krfb:${PORTSDIR}/net/krfb
-.if ${PORT_OPTIONS:MKRFB}
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/krfb:${PORTSDIR}/net/krfb
-.endif
+STRIGI_DESC= Strigi analyzers for network-related file formats
+STRIGI_RUN_DEPENDS= ${KDE4_PREFIX}/lib/strigi/strigita_torrent_analyzer.so:${PORTSDIR}/net/kdenetwork4-strigi-analyzers
.include <bsd.port.mk>
diff --git a/net/kdenetwork4/distinfo b/net/kdenetwork4/distinfo
deleted file mode 100644
index 8e2b1f4f365b..000000000000
--- a/net/kdenetwork4/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (KDE/4.10.5/kdenetwork-4.10.5.tar.xz) = d308c7f4f14e5ca91d69e661538e051335de389ca1eb9a74c1cd92ad40092ad3
-SIZE (KDE/4.10.5/kdenetwork-4.10.5.tar.xz) = 9030076
diff --git a/net/kdenetwork4/files/patch-CMakeLists.txt b/net/kdenetwork4/files/patch-CMakeLists.txt
deleted file mode 100644
index d621defb19b2..000000000000
--- a/net/kdenetwork4/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- CMakeLists.txt~ 2013-07-03 17:37:37.959108794 +0300
-+++ CMakeLists.txt 2013-07-03 17:37:44.152442094 +0300
-@@ -19,7 +19,6 @@
-
- macro_optional_add_subdirectory( kdenetwork-strigi-analyzers )
- macro_optional_add_subdirectory( kdenetwork-filesharing )
--macro_optional_add_subdirectory( kppp )
- macro_optional_add_subdirectory( kdnssd )
- macro_optional_add_subdirectory( krdc )
- macro_optional_add_subdirectory( krfb )
diff --git a/net/kdenetwork4/files/patch-kget__transfer-plugins__bittorrent__CMakeLists.txt b/net/kdenetwork4/files/patch-kget__transfer-plugins__bittorrent__CMakeLists.txt
deleted file mode 100644
index 70aa2ce3ec6a..000000000000
--- a/net/kdenetwork4/files/patch-kget__transfer-plugins__bittorrent__CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./kget/transfer-plugins/bittorrent/CMakeLists.txt.orig 2010-05-17 00:04:17.000000000 +0400
-+++ ./kget/transfer-plugins/bittorrent/CMakeLists.txt 2010-09-03 23:11:25.423061403 +0400
-@@ -1,6 +1,6 @@
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}")
-
--include_directories(
-+include_directories(BEFORE
- ../../
- ${LIBKTORRENT_INCLUDE_DIR}
- )
diff --git a/net/kdenetwork4/pkg-descr b/net/kdenetwork4/pkg-descr
index 2c218fb7a253..a74871663977 100644
--- a/net/kdenetwork4/pkg-descr
+++ b/net/kdenetwork4/pkg-descr
@@ -1 +1 @@
-Network tools for KDE4.
+KDE Network Metapackage.
diff --git a/net/kdnssd/Makefile b/net/kdnssd/Makefile
new file mode 100644
index 000000000000..eb10d722cf9e
--- /dev/null
+++ b/net/kdnssd/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= kdnssd
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= net kde
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE Network monitor for DNS-SD services (Zeroconf)
+
+USE_XZ= yes
+USE_KDE4= kdelibs kdeprefix kdehier automoc4
+USES= cmake:outsource
+USE_QT4= moc_build qmake_build rcc_build uic_build
+
+.include <bsd.port.mk>
diff --git a/net/kdnssd/distinfo b/net/kdnssd/distinfo
new file mode 100644
index 000000000000..3949ff691da2
--- /dev/null
+++ b/net/kdnssd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.12.2/kdnssd-4.12.2.tar.xz) = 2ca955cf48b75b68799eae50f70f1975052b03813701a8b35ea01a3bcb40392e
+SIZE (KDE/4.12.2/kdnssd-4.12.2.tar.xz) = 25964
diff --git a/net/kdnssd/pkg-descr b/net/kdnssd/pkg-descr
new file mode 100644
index 000000000000..12d2640db9b1
--- /dev/null
+++ b/net/kdnssd/pkg-descr
@@ -0,0 +1 @@
+KDE Network monitor for DNS-SD services (Zeroconf).
diff --git a/net/kdnssd/pkg-plist b/net/kdnssd/pkg-plist
new file mode 100644
index 000000000000..aa7be73f25b4
--- /dev/null
+++ b/net/kdnssd/pkg-plist
@@ -0,0 +1,6 @@
+lib/kde4/kded_dnssdwatcher.so
+lib/kde4/kio_zeroconf.so
+share/apps/remoteview/zeroconf.desktop
+share/dbus-1/interfaces/org.kde.kdnssd.xml
+share/kde4/services/kded/dnssdwatcher.desktop
+share/kde4/services/zeroconf.protocol
diff --git a/net/kget/Makefile b/net/kget/Makefile
new file mode 100644
index 000000000000..aeb7526134fe
--- /dev/null
+++ b/net/kget/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= kget
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= net kde
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE download manager
+
+LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme \
+ libktorrent.so:${PORTSDIR}/net-p2p/libktorrent \
+ libmms.so:${PORTSDIR}/net/libmms \
+ libqca.so:${PORTSDIR}/devel/qca \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs
+
+USE_XZ= yes
+USE_SQLITE= yes
+USE_KDE4= kdelibs kdeprefix kdehier workspace libkonq \
+ nepomuk-core nepomuk-widgets automoc4 ontologies \
+ soprano
+USES= cmake:outsource
+USE_QT4= gui sql moc_build qmake_build rcc_build uic_build
+USE_LDCONFIG= yes
+MAKE_ENV= XDG_CONFIG_HOME=/dev/null
+CONFIGURE_ENV= XDG_CONFIG_HOME=/dev/null
+
+.include <bsd.port.mk>
diff --git a/net/kget/distinfo b/net/kget/distinfo
new file mode 100644
index 000000000000..2717ea59b672
--- /dev/null
+++ b/net/kget/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.12.2/kget-4.12.2.tar.xz) = 76b3d2f104507e367d4b04f91f91861b5ea0b2f4f9379b75fae514a8d34fa2c7
+SIZE (KDE/4.12.2/kget-4.12.2.tar.xz) = 1075684
diff --git a/net/kget/pkg-descr b/net/kget/pkg-descr
new file mode 100644
index 000000000000..cdf1c8ba336e
--- /dev/null
+++ b/net/kget/pkg-descr
@@ -0,0 +1 @@
+KGet is a versatile and user-friendly download manager.
diff --git a/net/kdenetwork4/pkg-plist b/net/kget/pkg-plist
index 52fa8b0cc68f..6393ca5cd779 100644
--- a/net/kdenetwork4/pkg-plist
+++ b/net/kget/pkg-plist
@@ -5,7 +5,6 @@ lib/kde4/kcm_kget_metalinkfactory.so
lib/kde4/kcm_kget_mirrorsearchfactory.so
lib/kde4/kcm_kget_mmsfactory.so
lib/kde4/kcm_kget_multisegkiofactory.so
-lib/kde4/kded_dnssdwatcher.so
lib/kde4/kget_bittorrentfactory.so
lib/kde4/kget_browser_integration.so
lib/kde4/kget_checksumsearchfactory.so
@@ -14,16 +13,13 @@ lib/kde4/kget_metalinkfactory.so
lib/kde4/kget_mirrorsearchfactory.so
lib/kde4/kget_mmsfactory.so
lib/kde4/kget_multisegkiofactory.so
-lib/kde4/kio_zeroconf.so
lib/kde4/krunner_kget.so
lib/kde4/plasma_engine_kget.so
lib/kde4/plasma_kget_barapplet.so
lib/kde4/plasma_kget_piechart.so
-lib/kde4/sambausershareplugin.so
lib/libkgetcore.so
-lib/libkgetcore.so.5
-lib/libkgetcore.so.5.0.1
-lib/strigi/strigita_torrent_analyzer.so
+lib/libkgetcore.so.4
+lib/libkgetcore.so.%%KDE4_GENERIC_LIB_VERSION%%
share/applications/kde4/kget.desktop
share/apps/dolphinpart/kpartplugins/kget_plug_in.desktop
share/apps/dolphinpart/kpartplugins/kget_plug_in.rc
@@ -51,14 +47,31 @@ share/apps/khtml/kpartplugins/kget_plug_in.desktop
share/apps/khtml/kpartplugins/kget_plug_in.rc
share/apps/kwebkitpart/kpartplugins/kget_plug_in.desktop
share/apps/kwebkitpart/kpartplugins/kget_plug_in.rc
-share/apps/remoteview/zeroconf.desktop
share/config.kcfg/kget.kcfg
share/config.kcfg/kget_checksumsearchfactory.kcfg
share/config.kcfg/kget_mirrorsearchfactory.kcfg
share/config.kcfg/kget_mmsfactory.kcfg
share/config.kcfg/kget_multisegkiofactory.kcfg
-share/dbus-1/interfaces/org.kde.kdnssd.xml
share/dbus-1/services/org.kde.kget.service
+share/doc/HTML/en/kget/common
+share/doc/HTML/en/kget/file.png
+share/doc/HTML/en/kget/import_link.png
+share/doc/HTML/en/kget/index.cache.bz2
+share/doc/HTML/en/kget/index.docbook
+share/doc/HTML/en/kget/kget_Advanced.png
+share/doc/HTML/en/kget/kget_Appearance.png
+share/doc/HTML/en/kget/kget_Network.png
+share/doc/HTML/en/kget/kget_Web_Interface.png
+share/doc/HTML/en/kget/kget_drop_target.png
+share/doc/HTML/en/kget/kget_group.png
+share/doc/HTML/en/kget/kget_groups.png
+share/doc/HTML/en/kget/kget_plugins.png
+share/doc/HTML/en/kget/kget_transfer_hostory.png
+share/doc/HTML/en/kget/kget_verification.png
+share/doc/HTML/en/kget/metalink0.png
+share/doc/HTML/en/kget/metalink1.png
+share/doc/HTML/en/kget/metalink2.png
+share/doc/HTML/en/kget/metalink3.png
share/icons/hicolor/128x128/apps/kget.png
share/icons/hicolor/16x16/apps/kget.png
share/icons/hicolor/22x22/apps/kget.png
@@ -67,7 +80,6 @@ share/icons/hicolor/48x48/apps/kget.png
share/icons/hicolor/64x64/apps/kget.png
share/icons/hicolor/scalable/apps/kget.svgz
share/kde4/services/ServiceMenus/kget_download.desktop
-share/kde4/services/kded/dnssdwatcher.desktop
share/kde4/services/kget_bittorrentfactory.desktop
share/kde4/services/kget_bittorrentfactory_config.desktop
share/kde4/services/kget_checksumsearchfactory.desktop
@@ -85,11 +97,10 @@ share/kde4/services/kgetbarapplet-default.desktop
share/kde4/services/kgetpiechartapplet-default.desktop
share/kde4/services/plasma-engine-kget.desktop
share/kde4/services/plasma-runner-kget.desktop
-share/kde4/services/sambausershareplugin.desktop
-share/kde4/services/zeroconf.protocol
share/kde4/servicetypes/kget_plugin.desktop
share/ontology/kde/kget_history.ontology
share/ontology/kde/kget_history.trig
+@dirrm share/doc/HTML/en/kget
@dirrmtry share/apps/kwebkitpart/kpartplugins
@dirrmtry share/apps/kwebkitpart
@dirrm share/apps/kget/www
diff --git a/net/krdc/Makefile b/net/krdc/Makefile
index 2db1a25e3526..5295db4f488b 100644
--- a/net/krdc/Makefile
+++ b/net/krdc/Makefile
@@ -2,21 +2,15 @@
PORTNAME= krdc
PORTVERSION= ${KDE4_VERSION}
-CATEGORIES= net kde ipv6
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DISTNAME= kdenetwork-${PORTVERSION}
+CATEGORIES= net kde
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= RDP and VNC client for KDE
-LIB_DEPENDS= vncserver.0:${PORTSDIR}/net/libvncserver \
- telepathy-qt4.2:${PORTSDIR}/net-im/telepathy-qt4
-
-DISTINFO_FILE= ${.CURDIR}/../../net/kdenetwork4/distinfo
-
-CONFLICTS_INSTALL= kdenetwork-4.[1-8].*
+LIB_DEPENDS= libvncserver.so:${PORTSDIR}/net/libvncserver \
+ libtelepathy-qt4.so:${PORTSDIR}/net-im/telepathy-qt4
USES= cmake:outsource
USE_KDE4= kdehier kdelibs kdeprefix automoc4
@@ -24,7 +18,4 @@ USE_QT4= moc_build qmake_build rcc_build uic_build
USE_XZ= yes
USE_LDCONFIG= yes
-CMAKE_SOURCE_PATH= ${WRKSRC}/${PORTNAME}
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/krdc/distinfo b/net/krdc/distinfo
new file mode 100644
index 000000000000..b85ec976c6d6
--- /dev/null
+++ b/net/krdc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.12.2/krdc-4.12.2.tar.xz) = 3e29e96cdf875bf4c5bfb298f67a0a6589e8a1c316b2ac9226815b1959a33536
+SIZE (KDE/4.12.2/krdc-4.12.2.tar.xz) = 398060
diff --git a/net/krdc/pkg-plist b/net/krdc/pkg-plist
index d07c65fec7c6..16547f8e850b 100644
--- a/net/krdc/pkg-plist
+++ b/net/krdc/pkg-plist
@@ -9,8 +9,8 @@ lib/kde4/krdc_rdpplugin.so
lib/kde4/krdc_testplugin.so
lib/kde4/krdc_vncplugin.so
lib/libkrdccore.so
-lib/libkrdccore.so.5
-lib/libkrdccore.so.5.0.1
+lib/libkrdccore.so.4
+lib/libkrdccore.so.%%KDE4_GENERIC_LIB_VERSION%%
share/applications/kde4/krdc.desktop
share/apps/krdc/krdcui.rc
share/apps/krdc/pics/pointcursor.png
diff --git a/net/krfb/Makefile b/net/krfb/Makefile
index 2f3b42f337df..54884d9a25ba 100644
--- a/net/krfb/Makefile
+++ b/net/krfb/Makefile
@@ -2,21 +2,15 @@
PORTNAME= krfb
PORTVERSION= ${KDE4_VERSION}
-CATEGORIES= net kde ipv6
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DISTNAME= kdenetwork-${PORTVERSION}
+CATEGORIES= net kde
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= VNC server for KDE
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- telepathy-qt4.2:${PORTSDIR}/net-im/telepathy-qt4
-
-DISTINFO_FILE= ${.CURDIR}/../../net/kdenetwork4/distinfo
-
-CONFLICTS_INSTALL= kdenetwork-4.[1-8].*
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libtelepathy-qt4.so:${PORTSDIR}/net-im/telepathy-qt4
USES= cmake:outsource
USE_KDE4= kdehier kdelibs kdeprefix automoc4
@@ -24,7 +18,4 @@ USE_QT4= corelib gui network \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-CMAKE_SOURCE_PATH= ${WRKSRC}/${PORTNAME}
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/krfb/distinfo b/net/krfb/distinfo
new file mode 100644
index 000000000000..294dfcce6fa6
--- /dev/null
+++ b/net/krfb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.12.2/krfb-4.12.2.tar.xz) = c84e7218f69320eb869a6e303301a21c61bd2b22514ee7d68314c105162fa1e8
+SIZE (KDE/4.12.2/krfb-4.12.2.tar.xz) = 467952
diff --git a/net/krfb/pkg-plist b/net/krfb/pkg-plist
index 441474aed320..69c8a59f7edc 100644
--- a/net/krfb/pkg-plist
+++ b/net/krfb/pkg-plist
@@ -1,7 +1,7 @@
bin/krfb
lib/kde4/krfb_framebuffer_qt.so
lib/kde4/krfb_framebuffer_x11.so
-lib/libkrfbprivate.so.5.0.1
+lib/libkrfbprivate.so.%%KDE4_GENERIC_LIB_VERSION%%
share/applications/kde4/krfb.desktop
share/apps/krfb/krfb.notifyrc
share/dbus-1/services/org.freedesktop.Telepathy.Client.krfb_rfb_handler.service