aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-netstring/Makefile20
-rw-r--r--net/py-netstring/distinfo3
-rw-r--r--net/py-netstring/pkg-descr3
-rw-r--r--net/py-netstring/pkg-plist3
5 files changed, 30 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 516870b86953..ec38de711d5b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -624,6 +624,7 @@
SUBDIR += py-mantissa
SUBDIR += py-medusa
SUBDIR += py-mp-random
+ SUBDIR += py-netstring
SUBDIR += py-pcap
SUBDIR += py-pcapy
SUBDIR += py-pypcap
diff --git a/net/py-netstring/Makefile b/net/py-netstring/Makefile
new file mode 100644
index 000000000000..2ba0ce23a1eb
--- /dev/null
+++ b/net/py-netstring/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: py-netstring
+# Date created: 04 Nov 2006
+# Whom: Alexander Botero-Lowry <alexbl@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= netstring
+PORTVERSION= 1.14
+CATEGORIES= net devel python
+MASTER_SITES= ftp://ftp.tummy.com/pub/tummy/Python/netstring/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= alexbl@FreeBSD.org
+COMMENT= Python module implenting the netstring protocol
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-netstring/distinfo b/net/py-netstring/distinfo
new file mode 100644
index 000000000000..a3011a2a092c
--- /dev/null
+++ b/net/py-netstring/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-netstring-1.14.tar.gz) = febfdfc8776f9b334418233d35db4b26
+SHA256 (python-netstring-1.14.tar.gz) = d8d9a8269a946de9ef7eb209322556f62ea479c637bf8322d4c462fa3d4e94aa
+SIZE (python-netstring-1.14.tar.gz) = 3459
diff --git a/net/py-netstring/pkg-descr b/net/py-netstring/pkg-descr
new file mode 100644
index 000000000000..3f1a6dc755a9
--- /dev/null
+++ b/net/py-netstring/pkg-descr
@@ -0,0 +1,3 @@
+An implementation of the netstrings protocol developed by D.J. Bernstein.
+netstrings transmits each string as the length followed by : followed by
+the string.
diff --git a/net/py-netstring/pkg-plist b/net/py-netstring/pkg-plist
new file mode 100644
index 000000000000..aff0984cfc0e
--- /dev/null
+++ b/net/py-netstring/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/netstring.py
+%%PYTHON_SITELIBDIR%%/netstring.pyc
+%%PYTHON_SITELIBDIR%%/netstring.pyo