aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile2
-rw-r--r--net/nstxd/Makefile44
-rw-r--r--net/nstxd/distinfo4
-rw-r--r--net/nstxd/files/nstxd.in65
-rw-r--r--net/nstxd/files/pkg-message.in2
-rw-r--r--net/nstxd/pkg-descr2
-rw-r--r--net/nstxd/pkg-plist3
-rw-r--r--net/sprinkle/Makefile29
-rw-r--r--net/sprinkle/distinfo2
-rw-r--r--net/sprinkle/pkg-descr3
-rw-r--r--net/sprinkle/pkg-plist7
11 files changed, 0 insertions, 163 deletions
diff --git a/net/Makefile b/net/Makefile
index 672419355910..077c7f5d4b4c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -456,7 +456,6 @@
SUBDIR += nss-pam-ldapd-sasl
SUBDIR += nss_ldap
SUBDIR += nsscache
- SUBDIR += nstxd
SUBDIR += ntimed
SUBDIR += ntlmaps
SUBDIR += ntop
@@ -1242,7 +1241,6 @@
SUBDIR += spread
SUBDIR += spread-j
SUBDIR += spread4
- SUBDIR += sprinkle
SUBDIR += sqtop
SUBDIR += srelay
SUBDIR += ss5
diff --git a/net/nstxd/Makefile b/net/nstxd/Makefile
deleted file mode 100644
index a41c06b768a4..000000000000
--- a/net/nstxd/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# Created by: nagilum
-# $FreeBSD$
-
-PORTNAME= nstxd
-PORTVERSION= 1.1b6
-CATEGORIES= net
-MASTER_SITES= http://www.nagilum.org/nstx/ \
- http://ftp.debian.org/debian/pool/main/n/nstx/
-DISTNAME= nstx_1.1-beta6.orig
-
-PATCH_SITES= http://www.nagilum.org/nstx/ \
- http://ftp.debian.org/debian/pool/main/n/nstx/
-PATCH_DIST_STRIP= -p1
-PATCHFILES= nstx_1.1-beta6-4.diff.gz
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= DNS tunnel server
-
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-USE_RC_SUBR= nstxd
-
-WRKSRC= ${WRKDIR}/nstx-1.1-beta6
-SUB_FILES= pkg-message
-
-ALL_TARGET= nstxd
-INSTALL_TARGET= nstxd
-
-OPTIONS_DEFINE= DOCS
-
-post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nstxd ${STAGEDIR}${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/nstxd.8 ${STAGEDIR}${MAN8PREFIX}/man/man8/
-
-post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
-
-.include <bsd.port.mk>
diff --git a/net/nstxd/distinfo b/net/nstxd/distinfo
deleted file mode 100644
index aa79a6c03e4a..000000000000
--- a/net/nstxd/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-SHA256 (nstx_1.1-beta6.orig.tar.gz) = 57a1962a66e9cb64fe70839d852c56cd253092260eab589a8173740b75b21450
-SIZE (nstx_1.1-beta6.orig.tar.gz) = 20458
-SHA256 (nstx_1.1-beta6-4.diff.gz) = f2fc046cc08831599f2a95c874b7a028238c73e1f2cd4964ee86aa4c4307b8a8
-SIZE (nstx_1.1-beta6-4.diff.gz) = 7743
diff --git a/net/nstxd/files/nstxd.in b/net/nstxd/files/nstxd.in
deleted file mode 100644
index e04142bc2d4f..000000000000
--- a/net/nstxd/files/nstxd.in
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: nstxd
-# REQUIRE: DAEMON
-
-#
-# Add the following lines to /etc/rc.conf to enable nstxd:
-#
-#nstxd_domain="<your nstx domain>"
-#
-# You can disable automatic startup specifying:
-#
-#nstxd_enable="NO"
-#
-# See nstxd(8) for flags.
-#
-# The default behavour of this script is to bind nstxd to the IP
-# of the interface with default route.
-# If you want it bind to the IP of a different interface you
-# specify this interface in /etc/rc.conf:
-#nstxd_interface="fxp0"
-# If you have static IPs or you want nstxd to listen only a
-# specific IP (e.g. 127.0.0.1) you can specify:
-#nstxd_ip="127.0.0.1"
-# in /etc/rc.conf
-#
-# This script can also take care of the tun interface configuration
-# you simply put something like
-#nstxd_ifconfig="172.16.1.1 172.16.1.2"
-# in /etc/rc.conf to have this script automatically run
-# ifconfig with the above parameter on the device opened by nstxd.
-#
-. /etc/rc.subr
-
-name=nstxd
-rcvar=nstxd_enable
-
-command=%%PREFIX%%/sbin/nstxd
-
-load_rc_config ${name}
-
-# set defaults
-nstxd_interface=${nstxd_interface:-$(route get default|grep interface|cut -d: -f2)}
-nstxd_ip=${nstxd_ip:-$(ifconfig ${nstxd_interface}|grep "inet "|xargs|cut -d' ' -f 2)}
-
-if [ -n "${nstxd_domain}" ]
-then nstxd_enable=${nstxd_enable:-"YES"}
-else nstxd_enable="NO"
-fi
-
-nstxd_flags=${nstxd_flags:-"-D -i ${nstxd_ip} ${nstxd_domain}"}
-
-tmpfile=$(mktemp /tmp/$(basename $0).XXXXXX) || exit 1
-run_rc_command "$1" 2>&1|tee ${tmpfile}
-nstx_if=$(grep "using device" ${tmpfile}|cut -d' ' -f5)
-rm -f ${tmpfile}
-
-if [ -n "${nstxd_ifconfig}" -a -n "${nstx_if}" ]
-then echo "Configuring nstx interface: ifconfig ${nstx_if} ${nstxd_ifconfig} up"
- ifconfig ${nstx_if} ${nstxd_ifconfig}
-fi
-
diff --git a/net/nstxd/files/pkg-message.in b/net/nstxd/files/pkg-message.in
deleted file mode 100644
index f4f6021349cd..000000000000
--- a/net/nstxd/files/pkg-message.in
+++ /dev/null
@@ -1,2 +0,0 @@
-You need to be able to specify this host in the NS record of a domainname to use this program.
-See %%PREFIX%%/share/doc/nstxd/README for details!
diff --git a/net/nstxd/pkg-descr b/net/nstxd/pkg-descr
deleted file mode 100644
index 19570f8e6bbe..000000000000
--- a/net/nstxd/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-nstxd allows a nstx client daemon to tunnel IP traffic through DNS requests
-to the machine running nstxd.
diff --git a/net/nstxd/pkg-plist b/net/nstxd/pkg-plist
deleted file mode 100644
index a9a9415f0cd8..000000000000
--- a/net/nstxd/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-man/man8/nstxd.8.gz
-sbin/nstxd
-%%PORTDOCS%%%%DOCSDIR%%/README
diff --git a/net/sprinkle/Makefile b/net/sprinkle/Makefile
deleted file mode 100644
index 0d38007e6caa..000000000000
--- a/net/sprinkle/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-# Created by: Gea-Suan Lin <gslin@gslin.org>
-# $FreeBSD$
-
-PORTNAME= sprinkle
-DISTVERSION= 2007-08-07
-CATEGORIES= net python
-MASTER_SITES= http://www.thuswise.org/sprinkle/pub/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Stomp messaging broker written in Python
-
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
-
-LICENSE= GPLv3
-
-NO_BUILD= yes
-USES= python
-WRKSRC= ${WRKDIR}/sprinkle-dist
-
-OPTIONS_DEFINE= DOCS
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/sprinkle.py ${STAGEDIR}${PREFIX}/sbin
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.* ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/net/sprinkle/distinfo b/net/sprinkle/distinfo
deleted file mode 100644
index ee7795698337..000000000000
--- a/net/sprinkle/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (sprinkle-2007-08-07.tar.gz) = 7d127768ea64e94e6b22292b70b5d3b51b090c60b21e5645b67b48ae7c8a9f49
-SIZE (sprinkle-2007-08-07.tar.gz) = 188017
diff --git a/net/sprinkle/pkg-descr b/net/sprinkle/pkg-descr
deleted file mode 100644
index 96e4c745bc53..000000000000
--- a/net/sprinkle/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Sprinkle is a broker which implements a simple messaging protocol called STOMP.
-
-WWW: http://www.thuswise.org/sprinkle/
diff --git a/net/sprinkle/pkg-plist b/net/sprinkle/pkg-plist
deleted file mode 100644
index 2d976a43e3d5..000000000000
--- a/net/sprinkle/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-%%PORTDOCS%%%%DOCSDIR%%/README.html
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/hackers.html
-%%PORTDOCS%%%%DOCSDIR%%/hackers.txt
-%%PORTDOCS%%%%DOCSDIR%%/users.html
-%%PORTDOCS%%%%DOCSDIR%%/users.txt
-sbin/sprinkle.py