aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile5
-rw-r--r--net/pecl-apn/Makefile24
-rw-r--r--net/pecl-apn/distinfo2
-rw-r--r--net/pecl-apn/files/patch-config.m431
-rw-r--r--net/pecl-apn/pkg-descr4
-rw-r--r--net/pecl-ip2location/Makefile22
-rw-r--r--net/pecl-ip2location/distinfo2
-rw-r--r--net/pecl-ip2location/pkg-descr8
-rw-r--r--net/pecl-mosquitto/Makefile23
-rw-r--r--net/pecl-mosquitto/distinfo2
-rw-r--r--net/pecl-mosquitto/pkg-descr4
-rw-r--r--net/pecl-oauth/Makefile29
-rw-r--r--net/pecl-oauth/distinfo3
-rw-r--r--net/pecl-oauth/pkg-descr6
-rw-r--r--net/pecl-yp/Makefile20
-rw-r--r--net/pecl-yp/distinfo2
-rw-r--r--net/pecl-yp/pkg-descr4
17 files changed, 0 insertions, 191 deletions
diff --git a/net/Makefile b/net/Makefile
index 82a82a98dd91..a98def1a67f5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -968,17 +968,12 @@
SUBDIR += pear-XML_RPC
SUBDIR += pear-XML_RPC2
SUBDIR += pecl-amqp
- SUBDIR += pecl-apn
SUBDIR += pecl-geoip
- SUBDIR += pecl-ip2location
- SUBDIR += pecl-mosquitto
- SUBDIR += pecl-oauth
SUBDIR += pecl-oauth2
SUBDIR += pecl-radius
SUBDIR += pecl-rdkafka
SUBDIR += pecl-smbclient
SUBDIR += pecl-yaz
- SUBDIR += pecl-yp
SUBDIR += pecl-zmq
SUBDIR += pen
SUBDIR += pfinger
diff --git a/net/pecl-apn/Makefile b/net/pecl-apn/Makefile
deleted file mode 100644
index 0ac1fd325a7e..000000000000
--- a/net/pecl-apn/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-# Created by: Gasol Wu <gasol.wu@gmail.com>
-# $FreeBSD$
-
-PORTNAME= apn
-PORTVERSION= 1.0.3
-PORTREVISION= 2
-CATEGORIES= net pear
-
-MAINTAINER= gasol.wu@gmail.com
-COMMENT= Extension to interact with Apple Push Notification Service
-
-DEPRECATED= Works only with EOL php 5.6
-EXPIRATION_DATE= 2018-12-30
-
-LICENSE= PHP301
-
-LIB_DEPENDS= libcapn.so:net/libcapn
-
-USES= php:pecl ssl:build,run
-CONFIGURE_ARGS= --with-apn=${LOCALBASE}
-CFLAGS+= -I${OPENSSLINC}
-IGNORE_WITH_PHP= 71 72 73
-
-.include <bsd.port.mk>
diff --git a/net/pecl-apn/distinfo b/net/pecl-apn/distinfo
deleted file mode 100644
index 8131466045f0..000000000000
--- a/net/pecl-apn/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (PECL/apn-1.0.3.tgz) = 1d554f1a79dbc86212e0abd97b380ae9ee66e073969deb522941bc7866a3c3ca
-SIZE (PECL/apn-1.0.3.tgz) = 14406
diff --git a/net/pecl-apn/files/patch-config.m4 b/net/pecl-apn/files/patch-config.m4
deleted file mode 100644
index 98c4a00f6b33..000000000000
--- a/net/pecl-apn/files/patch-config.m4
+++ /dev/null
@@ -1,31 +0,0 @@
---- ./config.m4.orig 2014-02-20 16:43:19.000000000 +0800
-+++ ./config.m4 2014-02-21 09:06:40.000000000 +0800
-@@ -37,16 +37,16 @@
- AC_MSG_ERROR([libcapn is not found. Please visit to http://www.libcapn.org/php-apn for more information])
- fi
-
-- APN_INCDIR=$APN_DIR/include/capn
-+ APN_INCDIR=$APN_DIR/include
-
- SEARCH_LIBS_PATH="/usr/local/lib /usr/lib /usr/lib64 /usr/local/lib64"
- SEARCH_LIB_FILE=libcapn.$SHLIB_SUFFIX_NAME
-- if test -r $PHP_APN/capn/$SEARCH_LIB_FILE; then
-+ if test -r $PHP_APN/$SEARCH_LIB_FILE; then
- APN_LIBDIR=$PHP_APN
- else
- AC_MSG_CHECKING([for $SEARCH_LIB_FILE in default path])
- for i in $SEARCH_LIBS_PATH; do
-- if test -r $i/capn/$SEARCH_LIB_FILE; then
-+ if test -r $i/$SEARCH_LIB_FILE; then
- APN_LIBDIR=$i
- AC_MSG_RESULT(found in $i)
- break
-@@ -59,7 +59,7 @@
- AC_MSG_ERROR([libcapn is not found. Please visit to http://www.libcapn.org/php-apn for more information])
- fi
-
-- APN_LIBDIR=$APN_LIBDIR/capn
-+ APN_LIBDIR=$APN_LIBDIR
-
- PHP_ADD_INCLUDE($APN_INCDIR)
- PHP_ADD_LIBRARY_WITH_PATH(capn, $APN_LIBDIR, APN_SHARED_LIBADD)
diff --git a/net/pecl-apn/pkg-descr b/net/pecl-apn/pkg-descr
deleted file mode 100644
index 074c09996f72..000000000000
--- a/net/pecl-apn/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-apn is a PHP extension to introduce simple yet powerful interface for sending
-push notifications to iOS and OS X devices from within your PHP code.
-
-WWW: http://libcapn.org/php-apn/
diff --git a/net/pecl-ip2location/Makefile b/net/pecl-ip2location/Makefile
deleted file mode 100644
index 8b01a160d76e..000000000000
--- a/net/pecl-ip2location/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-# Created by: Gasol Wu <gasol.wu@gmail.com>
-# $FreeBSD$
-
-PORTNAME= ip2location
-PORTVERSION= 6.0.4
-PORTREVISION= 1
-CATEGORIES= net pear
-
-MAINTAINER= gasol.wu@gmail.com
-COMMENT= Get geo location information of an IP address
-
-DEPRECATED= Works only with EOL php 5.6
-EXPIRATION_DATE= 2018-12-30
-
-LICENSE= PHP301
-
-LIB_DEPENDS= libIP2Location.so:net/ip2location
-
-USES= php:pecl
-IGNORE_WITH_PHP= 71 72 73
-
-.include <bsd.port.mk>
diff --git a/net/pecl-ip2location/distinfo b/net/pecl-ip2location/distinfo
deleted file mode 100644
index 8c585cd6d687..000000000000
--- a/net/pecl-ip2location/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (PECL/ip2location-6.0.4.tgz) = 88d2c3de597f66ed164aa7400a3f2f31567f2671e6e7604a4d20ae1c17aaad1f
-SIZE (PECL/ip2location-6.0.4.tgz) = 321275
diff --git a/net/pecl-ip2location/pkg-descr b/net/pecl-ip2location/pkg-descr
deleted file mode 100644
index 5fef4f9b5203..000000000000
--- a/net/pecl-ip2location/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-This PECL extension enables you to get the geo location information of an IP
-address, such as country, region or state, city, latitude and longitude, US
-ZIP code, time zone, Internet Service Provider (ISP) or company name, domain
-name, net speed, area code, weather station code, weather station name,
-mobile country code (MCC), mobile network code (MNC) and carrier brand,
-elevation, and usage type.
-
-WWW: https://pecl.php.net/package/ip2location
diff --git a/net/pecl-mosquitto/Makefile b/net/pecl-mosquitto/Makefile
deleted file mode 100644
index 77a494b74577..000000000000
--- a/net/pecl-mosquitto/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-# Created by: Gasol Wu <gasol.wu@gmail.com>
-# $FreeBSD$
-
-PORTNAME= mosquitto
-PORTVERSION= 0.3.0
-PORTREVISION= 1
-CATEGORIES= net pear
-DISTNAME= Mosquitto-${PORTVERSION}
-
-MAINTAINER= gasol.wu@gmail.com
-COMMENT= Extension for libmosquitto
-
-DEPRECATED= Works only with EOL php 5.6
-EXPIRATION_DATE= 2018-12-30
-
-LICENSE= BSD3CLAUSE
-
-BUILD_DEPENDS= mosquitto>=0:net/mosquitto
-
-USES= php:pecl
-IGNORE_WITH_PHP= 71 72 73
-
-.include <bsd.port.mk>
diff --git a/net/pecl-mosquitto/distinfo b/net/pecl-mosquitto/distinfo
deleted file mode 100644
index bfa8b561e635..000000000000
--- a/net/pecl-mosquitto/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (PECL/Mosquitto-0.3.0.tgz) = a8875474d6502dd1ffe119857f9b971110c194e8b761f19236e935afb7de8bfa
-SIZE (PECL/Mosquitto-0.3.0.tgz) = 25395
diff --git a/net/pecl-mosquitto/pkg-descr b/net/pecl-mosquitto/pkg-descr
deleted file mode 100644
index 0a46eba5858f..000000000000
--- a/net/pecl-mosquitto/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Mosquitto provides support for the MQTT protocol, including publishing,
-subscribing, and an event loop.
-
-WWW: https://pecl.php.net/package/Mosquitto
diff --git a/net/pecl-oauth/Makefile b/net/pecl-oauth/Makefile
deleted file mode 100644
index 3b211db96523..000000000000
--- a/net/pecl-oauth/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-# Created by: Wen Heping <wenheping@gmail.com>
-# $FreeBSD$
-
-PORTNAME= oauth
-PORTVERSION= 1.2.3
-PORTREVISION= 2
-CATEGORIES= net pear
-
-MAINTAINER= dbaio@FreeBSD.org
-COMMENT= Php Interface to the OAuth Protocol
-
-DEPRECATED= Works only with EOL php 5.6
-EXPIRATION_DATE= 2018-12-30
-
-LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-LIB_DEPENDS= libcurl.so:ftp/curl
-
-USES= php:pecl
-IGNORE_WITH_PHP= 71 72 73
-
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-
-PORTSCOUT= limit:^1.*
-
-.include <bsd.port.mk>
diff --git a/net/pecl-oauth/distinfo b/net/pecl-oauth/distinfo
deleted file mode 100644
index 39862d761d74..000000000000
--- a/net/pecl-oauth/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1474129351
-SHA256 (PECL/oauth-1.2.3.tgz) = 86bb5ee37afe672d4532ad784c7f711855c79f0dabf0acacafd5344ab6cf0195
-SIZE (PECL/oauth-1.2.3.tgz) = 45531
diff --git a/net/pecl-oauth/pkg-descr b/net/pecl-oauth/pkg-descr
deleted file mode 100644
index 1fe770ea5a29..000000000000
--- a/net/pecl-oauth/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-pecl-oauth is a php interface to the oauth protocol.
-Oauth is an authorization protocol built on top of
-HTTP which allows applications to securely access
-data without having to store usernames and passwords.
-
-WWW: https://pecl.php.net/package/oauth
diff --git a/net/pecl-yp/Makefile b/net/pecl-yp/Makefile
deleted file mode 100644
index 4f5e0aad9d5c..000000000000
--- a/net/pecl-yp/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# Created by: Gasol Wu <gasol.wu@gmail.com>
-# $FreeBSD$
-
-PORTNAME= yp
-PORTVERSION= 1.0.1
-PORTREVISION= 1
-CATEGORIES= net pear
-
-MAINTAINER= gasol.wu@gmail.com
-COMMENT= YP/NIS functions binding for PHP
-
-DEPRECATED= Works only with EOL php 5.6
-EXPIRATION_DATE= 2018-12-30
-
-LICENSE= PHP301
-
-USES= php:pecl
-IGNORE_WITH_PHP= 71 72 73
-
-.include <bsd.port.mk>
diff --git a/net/pecl-yp/distinfo b/net/pecl-yp/distinfo
deleted file mode 100644
index d83fc68b1eea..000000000000
--- a/net/pecl-yp/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (PECL/yp-1.0.1.tgz) = 097fc6953c8faaf748acb34bb0c11ca81672f46fc19cd48f8a6c7da6714fa468
-SIZE (PECL/yp-1.0.1.tgz) = 19263
diff --git a/net/pecl-yp/pkg-descr b/net/pecl-yp/pkg-descr
deleted file mode 100644
index e79b53eb4bc2..000000000000
--- a/net/pecl-yp/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-NIS (formerly called Yellow Pages) allows network management of important
-administrative files (e.g. the password file).
-
-WWW: https://pecl.php.net/package/yp