aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/dhcpd/Makefile12
-rw-r--r--net/dhcpd/distinfo6
-rw-r--r--net/dhcpd/files/extra-patch-dhcp.c18
-rw-r--r--net/dhcpd/files/extra-patch-dhcpd.c50
-rw-r--r--net/dhcpd/files/extra-patch-memory.c34
-rw-r--r--net/dhcpd/files/extra-patch-pfutils.c16
6 files changed, 7 insertions, 129 deletions
diff --git a/net/dhcpd/Makefile b/net/dhcpd/Makefile
index c2c04eba84fe..0d4803f1c7f1 100644
--- a/net/dhcpd/Makefile
+++ b/net/dhcpd/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= dhcpd
-PORTVERSION= 6.0.20170207
-PORTREVISION= 2
+PORTVERSION= 6.4.20181105
CATEGORIES= net
MAINTAINER= koue@chaosophia.net
@@ -10,6 +9,8 @@ COMMENT= OpenBSD dhcp daemon
LICENSE= BSD3CLAUSE
+USES= ssl uidfix
+
WRKSRC_SUBDIR= src/usr.sbin/${PORTNAME}
USE_GITHUB= yes
@@ -17,7 +18,6 @@ GH_ACCOUNT= koue
CONFLICTS= isc-dhcp4[1-3]-server*
-USES= ssl uidfix
USE_RC_SUBR= dhcpd
CFLAGS+= -Wall
@@ -30,11 +30,7 @@ NOPF_DESC= Disable PF support
OPTIONS_SUB= yes
-NOPF_CFLAGS= -DNO_PF=1
-NOPF_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-dhcp.c \
- ${PATCHDIR}/extra-patch-dhcpd.c \
- ${PATCHDIR}/extra-patch-memory.c \
- ${PATCHDIR}/extra-patch-pfutils.c
+NOPF_CFLAGS= -DNO_PF=1
post-patch:
@${REINPLACE_CMD} -e "s|/etc/dhcpd.conf|${PREFIX}/etc/dhcpd.conf|" \
diff --git a/net/dhcpd/distinfo b/net/dhcpd/distinfo
index 000fe94a353b..16a17bcacdd1 100644
--- a/net/dhcpd/distinfo
+++ b/net/dhcpd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1486490098
-SHA256 (koue-dhcpd-6.0.20170207_GH0.tar.gz) = 5a2371a28c1011e751a5100e330c8059e34a2f0e8de183ed63be93ca839ae43f
-SIZE (koue-dhcpd-6.0.20170207_GH0.tar.gz) = 106964
+TIMESTAMP = 1541427016
+SHA256 (koue-dhcpd-6.4.20181105_GH0.tar.gz) = 98c7118b8318d0d1b2804cfdb8a78a076161287ab8402c4ccbb98d2102d3fd1b
+SIZE (koue-dhcpd-6.4.20181105_GH0.tar.gz) = 128519
diff --git a/net/dhcpd/files/extra-patch-dhcp.c b/net/dhcpd/files/extra-patch-dhcp.c
deleted file mode 100644
index 0963847b3823..000000000000
--- a/net/dhcpd/files/extra-patch-dhcp.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- dhcp.c.orig 2018-06-06 09:10:04 UTC
-+++ dhcp.c
-@@ -154,6 +154,7 @@ dhcpdiscover(struct packet *packet)
- * If we can't find an unabandoned lease,
- * reclaim the abandoned lease.
- */
-+#ifndef NO_PF
- if ((lease->flags & ABANDONED_LEASE)) {
- warning("Reclaiming abandoned IP address %s.",
- piaddr(lease->ip_addr));
-@@ -161,6 +162,7 @@ dhcpdiscover(struct packet *packet)
-
- pfmsg('L', lease); /* unabandon address */
- }
-+#endif /* NO_PF */
- }
-
- /* Try to find a host_decl that matches the client
diff --git a/net/dhcpd/files/extra-patch-dhcpd.c b/net/dhcpd/files/extra-patch-dhcpd.c
deleted file mode 100644
index 427f384bc951..000000000000
--- a/net/dhcpd/files/extra-patch-dhcpd.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- dhcpd.c.orig 2018-06-06 09:12:11 UTC
-+++ dhcpd.c
-@@ -74,11 +74,15 @@ u_int16_t client_port;
- struct passwd *pw;
- int log_priority;
- int log_perror = 0;
-+#ifndef NO_PF
- int pfpipe[2];
-+#endif /* NO_PF */
- int gotpipe = 0;
- int syncrecv;
- int syncsend;
-+#ifndef NO_PF
- pid_t pfproc_pid = -1;
-+#endif /* NO_PF */
- char *path_dhcpd_conf = _PATH_DHCPD_CONF;
- char *path_dhcpd_db = _PATH_DHCPD_DB;
- char *abandoned_tab = NULL;
-@@ -225,6 +229,7 @@ main(int argc, char *argv[])
- if ((pw = getpwnam("_dhcp")) == NULL)
- error("user \"_dhcp\" not found");
-
-+#ifndef NO_PF
- /* don't go near /dev/pf unless we actually intend to use it */
- if ((abandoned_tab != NULL) ||
- (changedmac_tab != NULL) ||
-@@ -248,6 +253,7 @@ main(int argc, char *argv[])
- break;
- }
- }
-+#endif /* NO_PF */
-
- if (udpsockmode)
- udpsock_startup(udpaddr);
-@@ -386,6 +392,7 @@ periodic_scan(void *p)
- if (y < 1)
- y = 1;
-
-+#ifndef NO_PF
- /* walk across all leases to find the exired ones */
- for (n = subnets; n; n = n->next_subnet)
- for (g = n->group; g; g = g->next)
-@@ -394,6 +401,7 @@ periodic_scan(void *p)
- if (cur_time >= l->ends)
- if (l->ends > last_scan)
- pfmsg('R', l);
-+#endif /* NO_PF */
-
- last_scan = cur_time;
- add_timeout(cur_time + y, periodic_scan, NULL);
diff --git a/net/dhcpd/files/extra-patch-memory.c b/net/dhcpd/files/extra-patch-memory.c
deleted file mode 100644
index 8acd0cf6e4f1..000000000000
--- a/net/dhcpd/files/extra-patch-memory.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- memory.c.orig 2018-06-06 09:14:19 UTC
-+++ memory.c
-@@ -619,9 +619,11 @@ supersede_lease(struct lease *comp, stru
- comp->ends = lease->ends;
- }
-
-+#ifndef NO_PF
- pfmsg('L', lease); /* address is leased. remove from purgatory */
- if (do_pftable) /* address changed hwaddr. remove from overload */
- pfmsg('C', lease);
-+#endif /* NO_PF */
-
- /* Return zero if we didn't commit the lease to permanent storage;
- nonzero if we did. */
-@@ -641,7 +643,9 @@ release_lease(struct lease *lease)
- supersede_lease(lease, &lt, 1);
- note("Released lease for IP address %s",
- piaddr(lease->ip_addr));
-+#ifndef NO_PF
- pfmsg('R', lease);
-+#endif /* NO_PF */
- }
- }
-
-@@ -669,7 +673,9 @@ abandon_lease(struct lease *lease, char
- lt.uid_len = 0;
- supersede_lease(lease, &lt, 1);
-
-+#ifndef NO_PF
- pfmsg('A', lease); /* address is abandoned. send to purgatory */
-+#endif /* NO_PF */
- return;
- }
-
diff --git a/net/dhcpd/files/extra-patch-pfutils.c b/net/dhcpd/files/extra-patch-pfutils.c
deleted file mode 100644
index ab32fc5c9464..000000000000
--- a/net/dhcpd/files/extra-patch-pfutils.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- pfutils.c.orig 2018-06-06 08:53:18 UTC
-+++ pfutils.c
-@@ -15,6 +15,8 @@
- * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- */
-
-+#ifndef NO_PF /* No need of PF support */
-+
- #include <sys/types.h>
- #include <sys/ioctl.h>
- #include <sys/socket.h>
-@@ -254,3 +256,4 @@ pfmsg(char c, struct lease *lp)
- break;
- }
- }
-+#endif /* NO_PF */