aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/openldap21-server/Makefile4
-rw-r--r--net/openldap22-server/Makefile4
-rw-r--r--net/openldap23-server/Makefile4
-rw-r--r--net/openldap24-server/Makefile4
4 files changed, 16 insertions, 0 deletions
diff --git a/net/openldap21-server/Makefile b/net/openldap21-server/Makefile
index 94bb4100c491..6b91444d18da 100644
--- a/net/openldap21-server/Makefile
+++ b/net/openldap21-server/Makefile
@@ -245,6 +245,10 @@ post-patch:
${WRKSRC}/servers/slapd/slapd.conf
pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
@${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
${WRKSRC}/configure
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index cea180c9f2df..321e79b4704a 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -255,6 +255,10 @@ post-patch:
${WRKSRC}/servers/slapd/slapd.conf
pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
@${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
${WRKSRC}/configure
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index cea180c9f2df..321e79b4704a 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -255,6 +255,10 @@ post-patch:
${WRKSRC}/servers/slapd/slapd.conf
pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
@${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
${WRKSRC}/configure
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index cea180c9f2df..321e79b4704a 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -255,6 +255,10 @@ post-patch:
${WRKSRC}/servers/slapd/slapd.conf
pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
@${REINPLACE_CMD} -e '/^LIBTOOL=/s,\$$(top_builddir)/libtool,${LIBTOOL},g' \
${WRKSRC}/configure