aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/avahi-app/Makefile16
-rw-r--r--net/avahi-app/distinfo6
-rw-r--r--net/avahi-app/pkg-plist7
-rw-r--r--net/avahi/Makefile4
-rw-r--r--net/ekiga/Makefile2
-rw-r--r--net/ekiga3/files/patch-configure20
-rw-r--r--net/ekiga3/files/patch-lib_engine_components_libnotify_libnotify-main.cpp10
-rw-r--r--net/gnome-netstatus/Makefile5
-rw-r--r--net/gnome-netstatus/distinfo6
-rw-r--r--net/gnome-netstatus/pkg-plist1
-rw-r--r--net/gnome-nettool/Makefile6
-rw-r--r--net/gnome-nettool/distinfo6
-rw-r--r--net/gnome-nettool/pkg-plist4
-rw-r--r--net/libgweather/Makefile5
-rw-r--r--net/libgweather/distinfo6
-rw-r--r--net/libgweather/pkg-plist1
-rw-r--r--net/liferea/Makefile3
-rw-r--r--net/vinagre/Makefile5
-rw-r--r--net/vinagre/distinfo6
-rw-r--r--net/vinagre/pkg-plist4
-rw-r--r--net/vino/Makefile8
-rw-r--r--net/vino/distinfo6
-rw-r--r--net/vino/files/patch-configure12
-rw-r--r--net/vino/pkg-plist9
24 files changed, 105 insertions, 53 deletions
diff --git a/net/avahi-app/Makefile b/net/avahi-app/Makefile
index 67550fe0d980..79bf8139da9f 100644
--- a/net/avahi-app/Makefile
+++ b/net/avahi-app/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/net/avahi-app/Makefile,v 1.1 2009/04/20 23:42:18 marcus Exp $
+# $MCom: ports/net/avahi-app/Makefile,v 1.14 2010/10/23 20:58:29 marcus Exp $
#
PORTNAME= avahi
-PORTVERSION= 0.6.27
-PORTREVISION?= 2
+PORTVERSION= 0.6.28
+PORTREVISION?= 0
CATEGORIES?= net dns
MASTER_SITES= http://www.avahi.org/download/
PKGNAMESUFFIX?= -app
@@ -36,8 +36,7 @@ CONFIGURE_ARGS?=--with-distro=freebsd \
--disable-doxygen-doc \
--disable-doxygen-dot \
--localstatedir=/var \
- --enable-compat-howl \
- --disable-gtk3
+ --enable-compat-howl
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_KQUEUE" \
LDFLAGS="-L${LOCALBASE}/lib" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
@@ -73,6 +72,11 @@ CONFIGURE_ARGS+=--enable-gtk
.else
CONFIGURE_ARGS+=--disable-gtk
.endif
+.if ${AVAHI_SLAVE}=="gtk3"
+CONFIGURE_ARGS+=--enable-gtk3
+.else
+CONFIGURE_ARGS+=--disable-gtk3
+.endif
.if ${AVAHI_SLAVE}=="libdns"
CONFIGURE_ARGS+=--enable-compat-libdns_sd
.else
@@ -161,7 +165,7 @@ avahi-post-install:
fi
.endfor
${INSTALL_DATA} ${FILESDIR}/org.freedesktop.Avahi.service \
- ${LOCALBASE}/share/dbus-1/system-services
+ ${LOCALBASE}/share/dbus-1/system-services
.if !defined(PACKAGE_BUILDING) && (${AVAHI_SLAVE}=="no" || ${AVAHI_SLAVE}=="autoipd")
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
diff --git a/net/avahi-app/distinfo b/net/avahi-app/distinfo
index 9a4d7d82c031..0ca2bc46b28b 100644
--- a/net/avahi-app/distinfo
+++ b/net/avahi-app/distinfo
@@ -1,3 +1,3 @@
-MD5 (avahi-0.6.27.tar.gz) = 74b40f87aeab07fc77af25f725b32f04
-SHA256 (avahi-0.6.27.tar.gz) = c22df5e0b0d695bfe3cc52545bf0affc1c52060818a5a65d70055e320bc45e84
-SIZE (avahi-0.6.27.tar.gz) = 1217974
+MD5 (avahi-0.6.28.tar.gz) = d0143a5aa3265019072e53ab497818d0
+SHA256 (avahi-0.6.28.tar.gz) = a0d80aac88212b9f9d5331c248091d3c9c9209f0e41985421636ebd14230fc91
+SIZE (avahi-0.6.28.tar.gz) = 1238660
diff --git a/net/avahi-app/pkg-plist b/net/avahi-app/pkg-plist
index 1edb8825ad2f..a30b159102ae 100644
--- a/net/avahi-app/pkg-plist
+++ b/net/avahi-app/pkg-plist
@@ -121,6 +121,7 @@ share/gir-1.0/AvahiCore-0.6.gir
share/locale/bg/LC_MESSAGES/avahi.mo
share/locale/ca/LC_MESSAGES/avahi.mo
share/locale/cs/LC_MESSAGES/avahi.mo
+share/locale/da/LC_MESSAGES/avahi.mo
share/locale/de/LC_MESSAGES/avahi.mo
share/locale/el/LC_MESSAGES/avahi.mo
share/locale/en_AU/LC_MESSAGES/avahi.mo
@@ -129,9 +130,12 @@ share/locale/en_GB/LC_MESSAGES/avahi.mo
share/locale/en_NZ/LC_MESSAGES/avahi.mo
share/locale/es/LC_MESSAGES/avahi.mo
share/locale/fi/LC_MESSAGES/avahi.mo
+share/locale/fo/LC_MESSAGES/avahi.mo
share/locale/fr/LC_MESSAGES/avahi.mo
share/locale/gl/LC_MESSAGES/avahi.mo
+share/locale/he/LC_MESSAGES/avahi.mo
share/locale/hu/LC_MESSAGES/avahi.mo
+share/locale/id/LC_MESSAGES/avahi.mo
share/locale/it/LC_MESSAGES/avahi.mo
share/locale/ja/LC_MESSAGES/avahi.mo
share/locale/ms/LC_MESSAGES/avahi.mo
@@ -140,6 +144,7 @@ share/locale/pl/LC_MESSAGES/avahi.mo
share/locale/pt_BR/LC_MESSAGES/avahi.mo
share/locale/ro/LC_MESSAGES/avahi.mo
share/locale/ru/LC_MESSAGES/avahi.mo
+share/locale/sl/LC_MESSAGES/avahi.mo
share/locale/sr/LC_MESSAGES/avahi.mo
share/locale/sv/LC_MESSAGES/avahi.mo
share/locale/sr@latin/LC_MESSAGES/avahi.mo
@@ -148,6 +153,8 @@ share/locale/zh_CN/LC_MESSAGES/avahi.mo
share/locale/zh_TW/LC_MESSAGES/avahi.mo
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/fo/LC_MESSAGES
+@dirrmtry share/locale/fo
@dirrmtry share/locale/en_NZ/LC_MESSAGES
@dirrmtry share/locale/en_NZ
@dirrm %%DATADIR%%
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 508c244fb9b4..b69cc5256f55 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/avahi/Makefile,v 1.26 2007/09/09 22:45:27 mezz Exp $
+# $MCom: ports/net/avahi/Makefile,v 1.28 2010/10/23 20:58:28 marcus Exp $
#
PORTNAME= avahi
-PORTVERSION= 0.6.27
+PORTVERSION= 0.6.28
PORTREVISION?= 0
CATEGORIES?= net dns
MASTER_SITES= # empty
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
index e95e478a80f0..e1d5e19f892b 100644
--- a/net/ekiga/Makefile
+++ b/net/ekiga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ekiga
PORTVERSION= 2.0.11
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= net gnome
MASTER_SITES= GNOME
diff --git a/net/ekiga3/files/patch-configure b/net/ekiga3/files/patch-configure
new file mode 100644
index 000000000000..79bfbea51ed0
--- /dev/null
+++ b/net/ekiga3/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2010-08-28 15:04:35.000000000 -0400
++++ configure 2010-08-28 15:05:31.000000000 -0400
+@@ -17255,7 +17255,7 @@ if test -n "$PKG_CONFIG"; then
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_NOTIFY_CFLAGS=`$PKG_CONFIG --cflags "libnotify" 2>/dev/null`
++ pkg_cv_NOTIFY_CFLAGS=`$PKG_CONFIG --cflags "libnotify" "gtk+-2.0" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -17273,7 +17273,7 @@ if test -n "$PKG_CONFIG"; then
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_NOTIFY_LIBS=`$PKG_CONFIG --libs "libnotify" 2>/dev/null`
++ pkg_cv_NOTIFY_LIBS=`$PKG_CONFIG --libs "libnotify" "gtk+-2.0" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
diff --git a/net/ekiga3/files/patch-lib_engine_components_libnotify_libnotify-main.cpp b/net/ekiga3/files/patch-lib_engine_components_libnotify_libnotify-main.cpp
new file mode 100644
index 000000000000..a6ac603c4ef4
--- /dev/null
+++ b/net/ekiga3/files/patch-lib_engine_components_libnotify_libnotify-main.cpp
@@ -0,0 +1,10 @@
+--- lib/engine/components/libnotify/libnotify-main.cpp.orig 2010-08-28 15:04:11.000000000 -0400
++++ lib/engine/components/libnotify/libnotify-main.cpp 2010-08-28 15:01:22.000000000 -0400
+@@ -38,6 +38,7 @@
+ #include <map>
+ #include <tr1/memory>
+
++#include <gtk/gtk.h>
+ #include <libnotify/notify.h>
+
+ #include "services.h"
diff --git a/net/gnome-netstatus/Makefile b/net/gnome-netstatus/Makefile
index 8670bbc40347..1a67a2f3b5e1 100644
--- a/net/gnome-netstatus/Makefile
+++ b/net/gnome-netstatus/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/gnome-netstatus/Makefile,v 1.56 2010/04/01 16:16:57 kwm Exp $
+# $MCom: ports/net/gnome-netstatus/Makefile,v 1.58 2010/09/29 12:35:14 kwm Exp $
#
PORTNAME= gnome-netstatus
-PORTVERSION= 2.28.1
-PORTREVISION= 1
+PORTVERSION= 2.28.2
CATEGORIES= net gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/net/gnome-netstatus/distinfo b/net/gnome-netstatus/distinfo
index f2ab01fcae52..4ddfb1c00fd6 100644
--- a/net/gnome-netstatus/distinfo
+++ b/net/gnome-netstatus/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-netstatus-2.28.1.tar.bz2) = 8ecc95396c9d1c7d963a7f232ca370f8
-SHA256 (gnome2/gnome-netstatus-2.28.1.tar.bz2) = 9e6bb618283d2c96afd7365f998b415a7ee9539957fcf8bd4cd58cf8e877a335
-SIZE (gnome2/gnome-netstatus-2.28.1.tar.bz2) = 572012
+MD5 (gnome2/gnome-netstatus-2.28.2.tar.bz2) = 9ce64074ed64e2c94a9ea4499749508c
+SHA256 (gnome2/gnome-netstatus-2.28.2.tar.bz2) = d1ad0a668a1344898d4f47b5591adddc7791edb6c2e92136ebcf8d278d959119
+SIZE (gnome2/gnome-netstatus-2.28.2.tar.bz2) = 585336
diff --git a/net/gnome-netstatus/pkg-plist b/net/gnome-netstatus/pkg-plist
index 874acacb75f2..72e45c2b3ffa 100644
--- a/net/gnome-netstatus/pkg-plist
+++ b/net/gnome-netstatus/pkg-plist
@@ -215,6 +215,7 @@ share/locale/el/LC_MESSAGES/gnome-netstatus.mo
share/locale/en@shaw/LC_MESSAGES/gnome-netstatus.mo
share/locale/en_CA/LC_MESSAGES/gnome-netstatus.mo
share/locale/en_GB/LC_MESSAGES/gnome-netstatus.mo
+share/locale/eo/LC_MESSAGES/gnome-netstatus.mo
share/locale/es/LC_MESSAGES/gnome-netstatus.mo
share/locale/et/LC_MESSAGES/gnome-netstatus.mo
share/locale/eu/LC_MESSAGES/gnome-netstatus.mo
diff --git a/net/gnome-nettool/Makefile b/net/gnome-nettool/Makefile
index 601aa0eb2a4e..54dacf22cd79 100644
--- a/net/gnome-nettool/Makefile
+++ b/net/gnome-nettool/Makefile
@@ -3,12 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/gnome-nettool/Makefile,v 1.55 2010/04/01 16:28:19 kwm Exp $
+# $MCom: ports/net/gnome-nettool/Makefile,v 1.58 2010/09/28 09:03:44 kwm Exp $
#
PORTNAME= gnome-nettool
-PORTVERSION= 2.30.0
-PORTREVISION= 1
+PORTVERSION= 2.32.0
PORTEPOCH= 1
CATEGORIES= net gnome
MASTER_SITES= GNOME
@@ -21,6 +20,7 @@ LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop
USE_BZIP2= yes
USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2 gnomedocutils
+GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
USE_GETTEXT= yes
INSTALLS_OMF= yes
diff --git a/net/gnome-nettool/distinfo b/net/gnome-nettool/distinfo
index e008c15021a6..ba2a3d9fdba0 100644
--- a/net/gnome-nettool/distinfo
+++ b/net/gnome-nettool/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-nettool-2.30.0.tar.bz2) = 2087259219cf16d434c52b4a5710b4c7
-SHA256 (gnome2/gnome-nettool-2.30.0.tar.bz2) = 42fdc867d26b31145986fd99e06509229b118430f2d666070c5dac7cff1dd000
-SIZE (gnome2/gnome-nettool-2.30.0.tar.bz2) = 651732
+MD5 (gnome2/gnome-nettool-2.32.0.tar.bz2) = af5436deb30ccfb3f6a1f8ea5602c40d
+SHA256 (gnome2/gnome-nettool-2.32.0.tar.bz2) = 8c70f85952760170114b2fa4be3ccaa3fc6298f802bacda2503ed482b8a0539c
+SIZE (gnome2/gnome-nettool-2.32.0.tar.bz2) = 647036
diff --git a/net/gnome-nettool/pkg-plist b/net/gnome-nettool/pkg-plist
index c0c67a307737..f358bc3f8dd7 100644
--- a/net/gnome-nettool/pkg-plist
+++ b/net/gnome-nettool/pkg-plist
@@ -1,6 +1,5 @@
bin/gnome-nettool
share/applications/gnome-nettool.desktop
-%%DATADIR%%/dialogs/gnome-nettool.ui
%%DATADIR%%/pixmaps/16_ethernet.xpm
%%DATADIR%%/pixmaps/16_loopback.xpm
%%DATADIR%%/pixmaps/16_plip.xpm
@@ -9,6 +8,7 @@ share/applications/gnome-nettool.desktop
%%DATADIR%%/pixmaps/irda-16.png
%%DATADIR%%/pixmaps/network.png
%%DATADIR%%/pixmaps/wavelan-16.png
+%%DATADIR%%/ui/gnome-nettool.ui
share/gnome/help/gnome-nettool/C/gnome-nettool.xml
share/gnome/help/gnome-nettool/C/legal.xml
share/gnome/help/gnome-nettool/ca/gnome-nettool.xml
@@ -153,8 +153,8 @@ share/pixmaps/gnome-nettool.png
@dirrm share/gnome/help/gnome-nettool/ca
@dirrm share/gnome/help/gnome-nettool/C
@dirrm share/gnome/help/gnome-nettool
+@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%/pixmaps
-@dirrm %%DATADIR%%/dialogs
@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
diff --git a/net/libgweather/Makefile b/net/libgweather/Makefile
index a26f98cb2717..7f34d5fb50ab 100644
--- a/net/libgweather/Makefile
+++ b/net/libgweather/Makefile
@@ -3,12 +3,11 @@
# Whom: Koop Mast <kwm@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/net/libgweather/Makefile,v 1.3 2010/06/24 07:55:55 kwm Exp $
+# $MCom: ports/net/libgweather/Makefile,v 1.42 2010/09/27 14:03:30 kwm Exp $
#
PORTNAME= libgweather
-PORTVERSION= 2.30.2
-PORTREVISION= 1
+PORTVERSION= 2.30.3
CATEGORIES= net gnome
MASTER_SITES= GNOME
diff --git a/net/libgweather/distinfo b/net/libgweather/distinfo
index c81de304d034..a69597ad04c8 100644
--- a/net/libgweather/distinfo
+++ b/net/libgweather/distinfo
@@ -1,3 +1,3 @@
-MD5 (libgweather-2.30.2.tar.bz2) = 050f4ed212261c2a147c89012d5daa90
-SHA256 (libgweather-2.30.2.tar.bz2) = dd98545cd4aaa2a856e62c9cc7822baf8d5f54bd277fd56ed8de6728dd61e312
-SIZE (libgweather-2.30.2.tar.bz2) = 7452039
+MD5 (libgweather-2.30.3.tar.bz2) = bf6a0a05051341ecb250f332e3edfb88
+SHA256 (libgweather-2.30.3.tar.bz2) = b835374661423f37c46aa8e37368ae24a68856f117b7c21e475a21efdba5264c
+SIZE (libgweather-2.30.3.tar.bz2) = 7449487
diff --git a/net/libgweather/pkg-plist b/net/libgweather/pkg-plist
index 29fa4ba9bbb4..9fe57249803a 100644
--- a/net/libgweather/pkg-plist
+++ b/net/libgweather/pkg-plist
@@ -460,6 +460,7 @@ share/icons/gnome/scalable/status/weather-few-clouds-night-350.svg
%%DATADIR%%/Locations.te.xml
%%DATADIR%%/Locations.th.xml
%%DATADIR%%/Locations.tr.xml
+%%DATADIR%%/Locations.ug.xml
%%DATADIR%%/Locations.uk.xml
%%DATADIR%%/Locations.vi.xml
%%DATADIR%%/Locations.xml
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 6de36777f183..00a132f3fc9b 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -7,6 +7,7 @@
PORTNAME= liferea
PORTVERSION= 1.6.5
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= SF/${PORTNAME}/Liferea%20Stable/${PORTVERSION}
@@ -16,7 +17,7 @@ COMMENT= Simple RSS/RDF feed reader
LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3 \
webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
-USE_GNOME= gnomeprefix gnomehack libglade2
+USE_GNOME= gnomeprefix gnomehack libglade2 gconf2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
diff --git a/net/vinagre/Makefile b/net/vinagre/Makefile
index 154ce5ca56e5..8ba7c7c58a31 100644
--- a/net/vinagre/Makefile
+++ b/net/vinagre/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/net/vinagre/Makefile,v 1.5 2010/07/25 00:14:30 marcus Exp $
+# $MCom: ports/net/vinagre/Makefile,v 1.42 2010/09/29 14:23:36 kwm Exp $
#
PORTNAME= vinagre
-PORTVERSION= 2.30.2
-PORTREVISION= 3
+PORTVERSION= 2.30.3
CATEGORIES= net gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/net/vinagre/distinfo b/net/vinagre/distinfo
index c34d4e90f159..bfc51c2974dc 100644
--- a/net/vinagre/distinfo
+++ b/net/vinagre/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/vinagre-2.30.2.tar.bz2) = 2483369947e7914b5ac2aae8200f6452
-SHA256 (gnome2/vinagre-2.30.2.tar.bz2) = 478b58ad9eb4a02fad45134bdddc29dc986d8c14e203a47b88aa7f3e6d1bf388
-SIZE (gnome2/vinagre-2.30.2.tar.bz2) = 2424224
+MD5 (gnome2/vinagre-2.30.3.tar.bz2) = adfa70f0fab9171d01f4c4cd4ede9e90
+SHA256 (gnome2/vinagre-2.30.3.tar.bz2) = 28bfc70a816bc3f1e71ada82e260c39ee2dac693cb7859323b06c8b1452a39f4
+SIZE (gnome2/vinagre-2.30.3.tar.bz2) = 2447388
diff --git a/net/vinagre/pkg-plist b/net/vinagre/pkg-plist
index 4dcdd7cc677e..e104951d7936 100644
--- a/net/vinagre/pkg-plist
+++ b/net/vinagre/pkg-plist
@@ -214,6 +214,7 @@ share/locale/hu/LC_MESSAGES/vinagre.mo
share/locale/id/LC_MESSAGES/vinagre.mo
share/locale/it/LC_MESSAGES/vinagre.mo
share/locale/ja/LC_MESSAGES/vinagre.mo
+share/locale/kk/LC_MESSAGES/vinagre.mo
share/locale/kn/LC_MESSAGES/vinagre.mo
share/locale/ko/LC_MESSAGES/vinagre.mo
share/locale/ku/LC_MESSAGES/vinagre.mo
@@ -223,6 +224,7 @@ share/locale/mai/LC_MESSAGES/vinagre.mo
share/locale/mk/LC_MESSAGES/vinagre.mo
share/locale/ml/LC_MESSAGES/vinagre.mo
share/locale/mr/LC_MESSAGES/vinagre.mo
+share/locale/ms/LC_MESSAGES/vinagre.mo
share/locale/nb/LC_MESSAGES/vinagre.mo
share/locale/nl/LC_MESSAGES/vinagre.mo
share/locale/nn/LC_MESSAGES/vinagre.mo
@@ -345,6 +347,8 @@ share/vinagre-1/plugins/vnc/vnc.ui
@dirrmtry share/locale/mai
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
@dirrmtry share/locale/en@shaw/LC_MESSAGES
@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/ca@valencia/LC_MESSAGES
diff --git a/net/vino/Makefile b/net/vino/Makefile
index 5ce473bc91d5..09a045e0ea62 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -3,12 +3,11 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $MCom: ports/net/vino/Makefile,v 1.78 2010/04/01 15:02:57 kwm Exp $
+# $MCom: ports/net/vino/Makefile,v 1.81 2010/09/27 13:51:24 kwm Exp $
#
PORTNAME= vino
-PORTVERSION= 2.28.2
-PORTREVISION= 2
+PORTVERSION= 2.32.0
CATEGORIES= net gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,7 +16,8 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= VNC server that allows for remote access to your GNOME desktop
LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
+ telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib \
+ unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
USE_BZIP2= yes
USE_GETTEXT= yes
diff --git a/net/vino/distinfo b/net/vino/distinfo
index 80e7fccad5ae..008989d14fd2 100644
--- a/net/vino/distinfo
+++ b/net/vino/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/vino-2.28.2.tar.bz2) = 7b7fcd23925efb628da2d2f12d73b485
-SHA256 (gnome2/vino-2.28.2.tar.bz2) = f2a0b7c77fe58f3918b202a9f0f4ae3295518ac43eeceade0875b096038a72e0
-SIZE (gnome2/vino-2.28.2.tar.bz2) = 795208
+MD5 (gnome2/vino-2.32.0.tar.bz2) = e43a40dc3a1ad81ce6d417c237b68875
+SHA256 (gnome2/vino-2.32.0.tar.bz2) = 00446f52eb03893be9d69dadbb3899b58676c122f33db670f46dc19e4a7d3d6d
+SIZE (gnome2/vino-2.32.0.tar.bz2) = 855538
diff --git a/net/vino/files/patch-configure b/net/vino/files/patch-configure
index 7d5508317db8..9d64aa9f6476 100644
--- a/net/vino/files/patch-configure
+++ b/net/vino/files/patch-configure
@@ -1,11 +1,11 @@
--- configure.orig 2010-04-01 16:50:38.000000000 +0200
+++ configure 2010-04-01 16:50:38.000000000 +0200
-@@ -15144,6 +15144,8 @@
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+@@ -15991,6 +15991,8 @@ if test "x$ac_cv_header_ifaddrs_h" = "xy
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-+ #include <sys/types.h>
-+ #include <sys/socket.h>
- #include <ifaddrs.h>
++ #include <sys/types.h>
++ #include <sys/socket.h>
+ #include <ifaddrs.h>
+ #include <net/if.h>
- int
diff --git a/net/vino/pkg-plist b/net/vino/pkg-plist
index 524f06d7884d..88337ff4a238 100644
--- a/net/vino/pkg-plist
+++ b/net/vino/pkg-plist
@@ -3,7 +3,7 @@ bin/vino-preferences
etc/xdg/autostart/vino-server.desktop
libexec/vino-server
share/applications/vino-preferences.desktop
-share/dbus-1/services/org.gnome.Vino.service
+share/dbus-1/services/org.freedesktop.Telepathy.Client.Vino.service
share/locale/ar/LC_MESSAGES/vino.mo
share/locale/as/LC_MESSAGES/vino.mo
share/locale/ast/LC_MESSAGES/vino.mo
@@ -25,6 +25,7 @@ share/locale/el/LC_MESSAGES/vino.mo
share/locale/en@shaw/LC_MESSAGES/vino.mo
share/locale/en_CA/LC_MESSAGES/vino.mo
share/locale/en_GB/LC_MESSAGES/vino.mo
+share/locale/eo/LC_MESSAGES/vino.mo
share/locale/es/LC_MESSAGES/vino.mo
share/locale/et/LC_MESSAGES/vino.mo
share/locale/eu/LC_MESSAGES/vino.mo
@@ -42,6 +43,7 @@ share/locale/id/LC_MESSAGES/vino.mo
share/locale/it/LC_MESSAGES/vino.mo
share/locale/ja/LC_MESSAGES/vino.mo
share/locale/ka/LC_MESSAGES/vino.mo
+share/locale/kk/LC_MESSAGES/vino.mo
share/locale/kn/LC_MESSAGES/vino.mo
share/locale/ko/LC_MESSAGES/vino.mo
share/locale/ku/LC_MESSAGES/vino.mo
@@ -85,10 +87,13 @@ share/locale/xh/LC_MESSAGES/vino.mo
share/locale/zh_CN/LC_MESSAGES/vino.mo
share/locale/zh_HK/LC_MESSAGES/vino.mo
share/locale/zh_TW/LC_MESSAGES/vino.mo
+share/telepathy/clients/Vino.client
%%DATADIR%%/vino-preferences.ui
%%DATADIR%%/vino-prompt.ui
%%DATADIR%%/webservices
@dirrm %%DATADIR%%
+@dirrmtry share/telepathy/clients
+@dirrmtry share/telepathy
@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@@ -112,6 +117,8 @@ share/locale/zh_TW/LC_MESSAGES/vino.mo
@dirrmtry share/locale/mai
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
@dirrmtry share/locale/en@shaw/LC_MESSAGES
@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/dz/LC_MESSAGES