aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/ayttm/Makefile4
-rw-r--r--net/dictd/Makefile3
-rw-r--r--net/everybuddy/Makefile4
-rw-r--r--net/gale/Makefile2
-rw-r--r--net/libicq2000/Makefile2
-rw-r--r--net/libsocket++/Makefile3
-rw-r--r--net/net-snmp/Makefile4
-rw-r--r--net/net-snmp/files/patch-aclocal.m48
-rw-r--r--net/net-snmp4/Makefile6
-rw-r--r--net/net-snmp4/files/patch-aclocal.m48
-rw-r--r--net/netdude/Makefile6
-rw-r--r--net/silc-client/Makefile2
-rw-r--r--net/silc-server/Makefile2
13 files changed, 32 insertions, 22 deletions
diff --git a/net/ayttm/Makefile b/net/ayttm/Makefile
index 537e9349c5ef..c33b4d0fe796 100644
--- a/net/ayttm/Makefile
+++ b/net/ayttm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= everybuddy
PORTVERSION= 0.4.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.everybuddy.com/files/
@@ -14,7 +15,8 @@ MAINTAINER= jim@FreeBSD.org
COMMENT= A "chat" program that combines AIM, ICQ, and Yahoo! Chat into one
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
- iconv.3:${PORTSDIR}/converters/libiconv
+ iconv.3:${PORTSDIR}/converters/libiconv \
+ ltdl.4:${PORTSDIR}/devel/libltdl
USE_X_PREFIX= yes
WANT_GNOME= yes
diff --git a/net/dictd/Makefile b/net/dictd/Makefile
index 52f539464924..c0d9a3e5d369 100644
--- a/net/dictd/Makefile
+++ b/net/dictd/Makefile
@@ -8,6 +8,7 @@
PORTNAME= dictd
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES+= net textproc
MASTER_SITES= ftp://ftp.dict.org/pub/dict/ \
${MASTER_SITE_SOURCEFORGE}
@@ -16,6 +17,8 @@ MASTER_SITE_SUBDIR= dict
MAINTAINER?= dd@FreeBSD.org
COMMENT= Dict protocol (RFC 2229) server
+LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl
+
MAN1= dictzip.1
MAN8= dictd.8
diff --git a/net/everybuddy/Makefile b/net/everybuddy/Makefile
index 537e9349c5ef..c33b4d0fe796 100644
--- a/net/everybuddy/Makefile
+++ b/net/everybuddy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= everybuddy
PORTVERSION= 0.4.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.everybuddy.com/files/
@@ -14,7 +15,8 @@ MAINTAINER= jim@FreeBSD.org
COMMENT= A "chat" program that combines AIM, ICQ, and Yahoo! Chat into one
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
- iconv.3:${PORTSDIR}/converters/libiconv
+ iconv.3:${PORTSDIR}/converters/libiconv \
+ ltdl.4:${PORTSDIR}/devel/libltdl
USE_X_PREFIX= yes
WANT_GNOME= yes
diff --git a/net/gale/Makefile b/net/gale/Makefile
index 6b99f0126982..854cd062ffc9 100644
--- a/net/gale/Makefile
+++ b/net/gale/Makefile
@@ -31,7 +31,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
pre-configure:
- cd ${WRKSRC} && ${ACLOCAL} -I ${LOCALBASE}/share/libtool/libltdl
+ cd ${WRKSRC} && ${ACLOCAL} -I ${LIBTOOL_SHAREDIR}/libltdl
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/net/libicq2000/Makefile b/net/libicq2000/Makefile
index 134e86083f2b..8f545ac37237 100644
--- a/net/libicq2000/Makefile
+++ b/net/libicq2000/Makefile
@@ -34,7 +34,7 @@ post-patch:
${WRKSRC}/libicq2000-config.in
post-configure:
- @${CP} ${LOCALBASE}/bin/libtool ${WRKSRC}
+ @${CP} ${LIBTOOL} ${WRKSRC}
@${REINPLACE_CMD} -E -e 's|^(install_ltlibs=).+$$|\1no|' \
${WRKSRC}/libtool
diff --git a/net/libsocket++/Makefile b/net/libsocket++/Makefile
index 4c24e0360b1f..05d3b9fa0b50 100644
--- a/net/libsocket++/Makefile
+++ b/net/libsocket++/Makefile
@@ -17,12 +17,11 @@ COMMENT= A C++ wrapper library to the sockets
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-USE_AUTOMAKE= yes
USE_AUTOMAKE_VER= 15
USE_LIBTOOL= yes
post-patch:
- cd ${WRKSRC}; ./autogen
+ @(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./autogen)
post-install:
.if !defined(NOPORTDOCS)
diff --git a/net/net-snmp/Makefile b/net/net-snmp/Makefile
index cd631c8b6a3a..b9570ee4d32c 100644
--- a/net/net-snmp/Makefile
+++ b/net/net-snmp/Makefile
@@ -101,7 +101,9 @@ SHLIB_VERSION= 5
PLIST_SUB+= shlib=${SHLIB_VERSION}
post-patch:
- @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ @${REINPLACE_CMD} \
+ -e 's|%%LTCONFIG%%|${LIBTOOL_SHAREDIR}/ltconfig${LIBTOOL_VERSION}|g' \
+ -e 's|%%LTMAIN%%|${LIBTOOL_SHAREDIR}/ltmain.sh|g' \
${WRKSRC}/aclocal.m4
post-configure:
diff --git a/net/net-snmp/files/patch-aclocal.m4 b/net/net-snmp/files/patch-aclocal.m4
index c466d9e1f68c..eb2e519aa7f0 100644
--- a/net/net-snmp/files/patch-aclocal.m4
+++ b/net/net-snmp/files/patch-aclocal.m4
@@ -12,8 +12,8 @@
+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
+LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
+DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-+${CONFIG_SHELL-/bin/sh} %%LOCALBASE%%/share/libtool/ltconfig --no-reexec \
-+$libtool_flags --no-verify --disable-ltlibs --release-ignore %%LOCALBASE%%/share/libtool/ltmain.sh $lt_target \
++${CONFIG_SHELL-/bin/sh} %%LTCONFIG%% --no-reexec \
++$libtool_flags --no-verify --disable-ltlibs --release-ignore %%LTMAIN%% $lt_target \
+|| AC_MSG_ERROR([libtool configure failed])
+
+# Reload cache, that may have been modified by ltconfig
@@ -21,7 +21,7 @@
+
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="--disable-ltlibs --release-ignore %%LOCALBASE%%/share/libtool/ltmain.sh"
++LIBTOOL_DEPS="--disable-ltlibs --release-ignore %%LTMAIN%%"
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -42,7 +42,7 @@
# which needs '.lib').
libext=a
-ltmain="$ac_aux_dir/ltmain.sh"
-+ltmain="--disable-ltlibs --release-ignore %%LOCALBASE%%/share/libtool/ltmain.sh"
++ltmain="--disable-ltlibs --release-ignore %%LTMAIN%%"
ofile="$default_ofile"
with_gnu_ld="$lt_cv_prog_gnu_ld"
need_locks="$enable_libtool_lock"
diff --git a/net/net-snmp4/Makefile b/net/net-snmp4/Makefile
index f9f900a73eed..8aca1d7a88c2 100644
--- a/net/net-snmp4/Makefile
+++ b/net/net-snmp4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ucd-snmp
PORTVERSION= 4.2.6
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ucd-snmp.ucdavis.edu/ \
@@ -87,7 +87,9 @@ pre-everything::
@${ECHO} ""
post-patch:
- @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ @${REINPLACE_CMD} \
+ -e 's|%%LTCONFIG%%|${LIBTOOL_SHAREDIR}/ltconfig${LIBTOOL_VERSION}|g' \
+ -e 's|%%LTMAIN%%|${LIBTOOL_SHAREDIR}/ltmain.sh|g' \
${WRKSRC}/aclocal.m4
post-install:
diff --git a/net/net-snmp4/files/patch-aclocal.m4 b/net/net-snmp4/files/patch-aclocal.m4
index c466d9e1f68c..eb2e519aa7f0 100644
--- a/net/net-snmp4/files/patch-aclocal.m4
+++ b/net/net-snmp4/files/patch-aclocal.m4
@@ -12,8 +12,8 @@
+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
+LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
+DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-+${CONFIG_SHELL-/bin/sh} %%LOCALBASE%%/share/libtool/ltconfig --no-reexec \
-+$libtool_flags --no-verify --disable-ltlibs --release-ignore %%LOCALBASE%%/share/libtool/ltmain.sh $lt_target \
++${CONFIG_SHELL-/bin/sh} %%LTCONFIG%% --no-reexec \
++$libtool_flags --no-verify --disable-ltlibs --release-ignore %%LTMAIN%% $lt_target \
+|| AC_MSG_ERROR([libtool configure failed])
+
+# Reload cache, that may have been modified by ltconfig
@@ -21,7 +21,7 @@
+
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="--disable-ltlibs --release-ignore %%LOCALBASE%%/share/libtool/ltmain.sh"
++LIBTOOL_DEPS="--disable-ltlibs --release-ignore %%LTMAIN%%"
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -42,7 +42,7 @@
# which needs '.lib').
libext=a
-ltmain="$ac_aux_dir/ltmain.sh"
-+ltmain="--disable-ltlibs --release-ignore %%LOCALBASE%%/share/libtool/ltmain.sh"
++ltmain="--disable-ltlibs --release-ignore %%LTMAIN%%"
ofile="$default_ofile"
with_gnu_ld="$lt_cv_prog_gnu_ld"
need_locks="$enable_libtool_lock"
diff --git a/net/netdude/Makefile b/net/netdude/Makefile
index e2a6afb4a1ba..536d42df4631 100644
--- a/net/netdude/Makefile
+++ b/net/netdude/Makefile
@@ -16,9 +16,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= NETwork DUmp data Displayer and Editor for tcpdump tracefiles
-LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
- iconv:${PORTSDIR}/converters/libiconv \
- ltdl:${PORTSDIR}/devel/libtool
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv \
+ ltdl.4:${PORTSDIR}/devel/libltdl
USE_REINPLACE= yes
USE_GNOME= glib12 gtk12
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index 731172e6b677..1e9c961806a8 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -84,7 +84,7 @@ post-patch:
${WRKSRC}/lib/silccrypt/Makefile.in
post-configure:
- @${CP} ${LOCALBASE}/bin/libtool ${WRKSRC}
+ @${CP} ${LIBTOOL} ${WRKSRC}
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
diff --git a/net/silc-server/Makefile b/net/silc-server/Makefile
index fd9921c25d6b..b19b938710be 100644
--- a/net/silc-server/Makefile
+++ b/net/silc-server/Makefile
@@ -82,7 +82,7 @@ post-patch:
${WRKSRC}/lib/silccrypt/Makefile.in
post-configure:
- @${CP} ${LOCALBASE}/bin/libtool ${WRKSRC}
+ @${CP} ${LIBTOOL} ${WRKSRC}
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \