aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/openldap2/Makefile5
-rw-r--r--net/openldap20-server/Makefile5
-rw-r--r--net/openldap20/Makefile5
-rw-r--r--net/openldap21-server/Makefile5
-rw-r--r--net/openldap21/Makefile5
-rw-r--r--net/openldap22-server/Makefile5
-rw-r--r--net/openldap22/Makefile5
-rw-r--r--net/openldap23-server/Makefile5
-rw-r--r--net/openldap24-server/Makefile5
9 files changed, 45 insertions, 0 deletions
diff --git a/net/openldap2/Makefile b/net/openldap2/Makefile
index 9acd4c66a24e..d866fecb29dd 100644
--- a/net/openldap2/Makefile
+++ b/net/openldap2/Makefile
@@ -50,6 +50,11 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
+.if defined(WITH_ODBC)
+LIB_DEPENDS+= iodbc.2:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+=--enable-sql
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
diff --git a/net/openldap20-server/Makefile b/net/openldap20-server/Makefile
index 9acd4c66a24e..d866fecb29dd 100644
--- a/net/openldap20-server/Makefile
+++ b/net/openldap20-server/Makefile
@@ -50,6 +50,11 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
+.if defined(WITH_ODBC)
+LIB_DEPENDS+= iodbc.2:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+=--enable-sql
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
diff --git a/net/openldap20/Makefile b/net/openldap20/Makefile
index 9acd4c66a24e..d866fecb29dd 100644
--- a/net/openldap20/Makefile
+++ b/net/openldap20/Makefile
@@ -50,6 +50,11 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
+.if defined(WITH_ODBC)
+LIB_DEPENDS+= iodbc.2:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+=--enable-sql
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
diff --git a/net/openldap21-server/Makefile b/net/openldap21-server/Makefile
index 9acd4c66a24e..d866fecb29dd 100644
--- a/net/openldap21-server/Makefile
+++ b/net/openldap21-server/Makefile
@@ -50,6 +50,11 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
+.if defined(WITH_ODBC)
+LIB_DEPENDS+= iodbc.2:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+=--enable-sql
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
diff --git a/net/openldap21/Makefile b/net/openldap21/Makefile
index 9acd4c66a24e..d866fecb29dd 100644
--- a/net/openldap21/Makefile
+++ b/net/openldap21/Makefile
@@ -50,6 +50,11 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
+.if defined(WITH_ODBC)
+LIB_DEPENDS+= iodbc.2:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+=--enable-sql
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index 9acd4c66a24e..d866fecb29dd 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -50,6 +50,11 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
+.if defined(WITH_ODBC)
+LIB_DEPENDS+= iodbc.2:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+=--enable-sql
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
diff --git a/net/openldap22/Makefile b/net/openldap22/Makefile
index 9acd4c66a24e..d866fecb29dd 100644
--- a/net/openldap22/Makefile
+++ b/net/openldap22/Makefile
@@ -50,6 +50,11 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
+.if defined(WITH_ODBC)
+LIB_DEPENDS+= iodbc.2:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+=--enable-sql
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 9acd4c66a24e..d866fecb29dd 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -50,6 +50,11 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
+.if defined(WITH_ODBC)
+LIB_DEPENDS+= iodbc.2:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+=--enable-sql
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 9acd4c66a24e..d866fecb29dd 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -50,6 +50,11 @@ LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
+.if defined(WITH_ODBC)
+LIB_DEPENDS+= iodbc.2:${PORTSDIR}/databases/libiodbc
+CONFIGURE_ARGS+=--enable-sql
+.endif
+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"