aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/tryst/Makefile29
-rw-r--r--net/tryst/distinfo3
-rw-r--r--net/tryst/pkg-descr9
-rw-r--r--net/tryst/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 79ebbd67a39b..b6970967e385 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -811,6 +811,7 @@
SUBDIR += tramp
SUBDIR += trickle
SUBDIR += tridiavnc
+ SUBDIR += tryst
SUBDIR += tsclient
SUBDIR += tshark
SUBDIR += tshark-lite
diff --git a/net/tryst/Makefile b/net/tryst/Makefile
new file mode 100644
index 000000000000..c05ffdb8be41
--- /dev/null
+++ b/net/tryst/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: tryst
+# Date created: 18 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tryst
+PORTVERSION= 1.0.8
+CATEGORIES= net
+MASTER_SITES= http://gnustep.dyndns.org/Downloads/
+DISTNAME= tryst-108pl4
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Implementation of Apples Bonjour for GNUstep
+
+LIB_DEPENDS= dns_sd:${PORTSDIR}/net/mDNSResponder
+
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+
+WRKSRC= ${WRKDIR}/Tryst-108.pl4
+
+.include <bsd.port.mk>
diff --git a/net/tryst/distinfo b/net/tryst/distinfo
new file mode 100644
index 000000000000..9d4a1e8138c9
--- /dev/null
+++ b/net/tryst/distinfo
@@ -0,0 +1,3 @@
+MD5 (tryst-108pl4.tgz) = 864837db718c20c9931f4e17e14182d4
+SHA256 (tryst-108pl4.tgz) = 3a54428cde6fea3b49f097f31baaa6bb7c6183ae5c8dda49e30bad5cd5925a67
+SIZE (tryst-108pl4.tgz) = 55465
diff --git a/net/tryst/pkg-descr b/net/tryst/pkg-descr
new file mode 100644
index 000000000000..25a9ffd1665c
--- /dev/null
+++ b/net/tryst/pkg-descr
@@ -0,0 +1,9 @@
+Using Tryst, applications can discover what services are available on the
+network, along with all necessary access information such as name, IP
+address, and port number for a given service.
+
+Bonjour allows you to register a network service, such as a printer or file
+server, so that it can be found by name or browsed for by service type and
+domain.
+
+WWW: http://gnustep.dyndns.org/
diff --git a/net/tryst/pkg-plist b/net/tryst/pkg-plist
new file mode 100644
index 000000000000..33ddb1bbff35
--- /dev/null
+++ b/net/tryst/pkg-plist
@@ -0,0 +1,5 @@
+Local/Library/Headers/Tryst/NSNetServices.h
+Local/Library/Libraries/libTryst.so
+Local/Library/Libraries/libTryst.so.%%MAJORVERSION%%
+Local/Library/Libraries/libTryst.so.%%VERSION%%
+@dirrm Local/Library/Headers/Tryst