aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/avahi-qt4/Makefile3
-rw-r--r--net/cagibi/Makefile3
-rw-r--r--net/ekiga3/Makefile2
-rw-r--r--net/hupnp/Makefile3
-rw-r--r--net/kdenetwork4/Makefile3
-rw-r--r--net/kio-upnp-ms/Makefile3
-rw-r--r--net/knemo-kde4/Makefile3
-rw-r--r--net/kwooty/Makefile3
-rw-r--r--net/libproxy-kde/Makefile3
-rw-r--r--net/pcbsd-netmanager/Makefile3
-rw-r--r--net/py-qt4-network/Makefile3
-rw-r--r--net/qoauth/Makefile3
-rw-r--r--net/qt4-network/Makefile3
-rw-r--r--net/rsplib/Makefile3
-rw-r--r--net/smb4k-kde4/Makefile3
-rw-r--r--net/wpa_gui/Makefile3
-rw-r--r--net/x2goclient/Makefile3
17 files changed, 17 insertions, 33 deletions
diff --git a/net/avahi-qt4/Makefile b/net/avahi-qt4/Makefile
index a13acdc6a5ef..d03a7e4c50fe 100644
--- a/net/avahi-qt4/Makefile
+++ b/net/avahi-qt4/Makefile
@@ -22,8 +22,7 @@ PLIST= ${.CURDIR}/pkg-plist
AVAHI_SLAVE= qt4
USE_GNOME= gnomehack ltverhack intltool
-USE_QT_VER= 4
-QT_COMPONENTS= corelib moc_build
+USE_QT4= corelib moc_build
AVAHI_PKGCONFIG= avahi-qt4.pc
.include "${MASTERDIR}/Makefile"
diff --git a/net/cagibi/Makefile b/net/cagibi/Makefile
index 5718d3b7b9f1..ffd194ed8ad4 100644
--- a/net/cagibi/Makefile
+++ b/net/cagibi/Makefile
@@ -16,8 +16,7 @@ COMMENT= KDE SSDP/uPNP proxy
USE_BZIP2= yes
USE_CMAKE= yes
USE_KDE4= automoc4
-USE_QT_VER= 4
-QT_COMPONENTS= corelib network xml dbus \
+USE_QT4= corelib network xml dbus \
qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/net/ekiga3/Makefile b/net/ekiga3/Makefile
index 056276a01011..9f0ef2e28284 100644
--- a/net/ekiga3/Makefile
+++ b/net/ekiga3/Makefile
@@ -56,7 +56,7 @@ OPTIONS= LDAP "Enable LDAP support" off \
BROKEN= Please set WITH_DBUS or remove WITH_KDE4!
. endif
USE_KDE4= kdehier kdelibs
-USE_QT_VER= 4
+USE_QT4= yes
CONFIGURE_ARGS+= --enable-kde
.else
CONFIGURE_ARGS+= --disable-kde
diff --git a/net/hupnp/Makefile b/net/hupnp/Makefile
index 4f9951541c65..c53ad0f1d846 100644
--- a/net/hupnp/Makefile
+++ b/net/hupnp/Makefile
@@ -16,8 +16,7 @@ COMMENT= A library for building UPnP devices and control points
USE_ZIP= yes
USE_GMAKE= yes
-USE_QT_VER= 4
-QT_COMPONENTS= corelib network xml dbus gui \
+USE_QT4= corelib network xml dbus gui \
qmake_build moc_build rcc_build uic_build
QMAKE_ARGS= PREFIX=${PREFIX} herqq.pro
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 2fae3386aa1a..98f8f993e9a2 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -46,8 +46,7 @@ USE_KDE4= kdehier kdelibs kdeprefix libkonq pimlibs workspace \
automoc4 ontologies qimageblitz soprano strigi
KDE4_BUILDENV= yes
USE_OPENSSL= yes
-USE_QT_VER= 4
-QT_COMPONENTS= dbus gui network qt3support sql xml \
+USE_QT4= dbus gui network qt3support sql xml \
moc_build qmake_build rcc_build uic_build uic3_build
USE_SQLITE= yes
USE_XORG= x11 xdamage xext xscrnsaver xtst
diff --git a/net/kio-upnp-ms/Makefile b/net/kio-upnp-ms/Makefile
index 66f1a65ebb1a..9e52b76927e0 100644
--- a/net/kio-upnp-ms/Makefile
+++ b/net/kio-upnp-ms/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= HUpnp.1:${PORTSDIR}/net/hupnp
USE_BZIP2= yes
USE_CMAKE= yes
USE_KDE4= automoc4 kdehier kdeprefix kdelibs
-USE_QT_VER= 4
-QT_COMPONENTS= corelib network xml dbus gui \
+USE_QT4= corelib network xml dbus gui \
qmake_build moc_build rcc_build uic_build
WRKSRC= ${WRKDIR}/${DISTNAME:C/.[^.]*$//}
diff --git a/net/knemo-kde4/Makefile b/net/knemo-kde4/Makefile
index 181954dc315a..5017e96b07e5 100644
--- a/net/knemo-kde4/Makefile
+++ b/net/knemo-kde4/Makefile
@@ -18,8 +18,7 @@ LATEST_LINK= ${PORTNAME}-kde4
USE_BZIP2= yes
USE_CMAKE= yes
-USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build uic_build rcc_build
+USE_QT4= qmake_build moc_build uic_build rcc_build
USE_KDE4= kdeprefix kdelibs automoc4
MAKE_JOBS_SAFE= yes
diff --git a/net/kwooty/Makefile b/net/kwooty/Makefile
index bdd54692bec1..78d12b9d2fcb 100644
--- a/net/kwooty/Makefile
+++ b/net/kwooty/Makefile
@@ -19,8 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/unrar:${PORTSDIR}/archivers/unrar \
${LOCALBASE}/bin/7z:${PORTSDIR}/archivers/p7zip
USE_KDE4= kdelibs kdehier kdeprefix automoc4 workspace
-USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build rcc_build uic_build
+USE_QT4= qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
USE_LDCONFIG= yes
diff --git a/net/libproxy-kde/Makefile b/net/libproxy-kde/Makefile
index 3458c2394650..07c667afcd23 100644
--- a/net/libproxy-kde/Makefile
+++ b/net/libproxy-kde/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= proxy.1:${PORTSDIR}/net/libproxy
MASTERDIR= ${.CURDIR}/../libproxy
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
-USE_QT_VER= 4
-QT_COMPONENTS= corelib moc_build qmake_build uic_build rcc_build
+USE_QT4= corelib moc_build qmake_build uic_build rcc_build
USE_KDE4= automoc4 kdelibs
LIBPROXY_SLAVE= kde
diff --git a/net/pcbsd-netmanager/Makefile b/net/pcbsd-netmanager/Makefile
index 5d5cad413c9c..2c848961f769 100644
--- a/net/pcbsd-netmanager/Makefile
+++ b/net/pcbsd-netmanager/Makefile
@@ -21,8 +21,7 @@ WRKSRC= ${WRKDIR}/pcbsd-netmanager
USE_KDE4= automoc4 kdehier kdeprefix kdelibs workspace
USE_LDCONFIG= yes
-USE_QT_VER= 4
-QT_COMPONENTS= corelib qmake_build moc_build rcc_build uic_build linguist
+USE_QT4= corelib qmake_build moc_build rcc_build uic_build linguist
HAS_CONFIGURE= yes
MAKE_ARGS= INSTALL_ROOT=${DESTDIR}
diff --git a/net/py-qt4-network/Makefile b/net/py-qt4-network/Makefile
index 54bf09b2303a..517676efcaa4 100644
--- a/net/py-qt4-network/Makefile
+++ b/net/py-qt4-network/Makefile
@@ -22,8 +22,7 @@ RUN_DEPENDS= ${PKGNAMEPREFIX}core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-cor
DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
HAS_CONFIGURE= yes
USE_PYTHON= 2.5+
-USE_QT_VER= 4
-QT_COMPONENTS= network qmake_build
+USE_QT4= network qmake_build
OPTIONS= API "Install QtNetwork API for QScintilla2" on \
DEBUG "Enable debugging in generated code" off \
diff --git a/net/qoauth/Makefile b/net/qoauth/Makefile
index d275d3967f2d..f1c4206928a2 100644
--- a/net/qoauth/Makefile
+++ b/net/qoauth/Makefile
@@ -20,8 +20,7 @@ RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
USE_LDCONFIG= yes
USE_BZIP2= yes
-USE_QT_VER= 4
-QT_COMPONENTS= corelib qtestlib network qmake_build moc_build
+USE_QT4= corelib qtestlib network qmake_build moc_build
HAS_CONFIGURE= yes
USE_OPENSSL= yes
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index 083e3bad88f9..3ed7837d2266 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -16,8 +16,7 @@ COMMENT= Qt network library
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build rcc_build corelib
+USE_QT4= qmake_build moc_build rcc_build corelib
QT_NONSTANDARD= yes
QT_DIST= yes
MAKE_JOBS_SAFE= yes
diff --git a/net/rsplib/Makefile b/net/rsplib/Makefile
index 88aa64a5cdbf..8ac40145b98f 100644
--- a/net/rsplib/Makefile
+++ b/net/rsplib/Makefile
@@ -14,8 +14,7 @@ MASTER_SITES= http://www.tdr.wiwi.uni-due.de/fileadmin/fileupload/I-TDR/Reliable
MAINTAINER= dreibh@iem.uni-due.de
COMMENT= RSerPool Framework and Example Applications
-USE_QT_VER= 4
-QT_COMPONENTS= gui xml moc_build
+USE_QT4= gui xml moc_build
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-maintainer-mode \
diff --git a/net/smb4k-kde4/Makefile b/net/smb4k-kde4/Makefile
index e35db20fa57b..d30111701e1c 100644
--- a/net/smb4k-kde4/Makefile
+++ b/net/smb4k-kde4/Makefile
@@ -26,8 +26,7 @@ USE_GETTEXT= yes
USE_BZIP2= yes
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/kde4
USE_KDE4= kdehier kdeprefix kdelibs automoc4 runtime
-USE_QT_VER= 4
-QT_COMPONENTS= corelib gui network opengl script svg webkit \
+USE_QT4= corelib gui network opengl script svg webkit \
qmake_build moc_build rcc_build uic_build phonon
DOCSDIR= ${PREFIX}/share/doc/HTML/en/smb4k
SUB_FILES= pkg-message
diff --git a/net/wpa_gui/Makefile b/net/wpa_gui/Makefile
index c444e7dd0ffa..b4c28f008107 100644
--- a/net/wpa_gui/Makefile
+++ b/net/wpa_gui/Makefile
@@ -17,8 +17,7 @@ COMMENT= QT GUI for wpa_supplicant
PLIST_FILES= sbin/${PORTNAME}
WRKSRC= ${WRKDIR}/${DISTNAME}/wpa_gui-qt4
-USE_QT_VER= 4
-QT_COMPONENTS= gui qt3support qmake_build moc_build uic_build
+USE_QT4= gui qt3support qmake_build moc_build uic_build
HAS_CONFIGURE= yes
diff --git a/net/x2goclient/Makefile b/net/x2goclient/Makefile
index 76b6029d439a..af2911c5d7c5 100644
--- a/net/x2goclient/Makefile
+++ b/net/x2goclient/Makefile
@@ -23,8 +23,7 @@ RUN_DEPENDS= nxproxy:${PORTSDIR}/net/nxproxy \
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S,-5,,}
-USE_QT_VER= 4
-QT_COMPONENTS= gui network svg qmake_build moc_build uic_build rcc_build
+USE_QT4= gui network svg qmake_build moc_build uic_build rcc_build
USE_OPENLDAP= yes
MAKE_JOBS_SAFE= yes