aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/nfsshell/Makefile17
-rw-r--r--net/nfsshell/distinfo4
-rw-r--r--net/nfsshell/files/patch-nfs.c7
-rw-r--r--net/nfsshell/files/patch-nfs_prot_xdr.c10
4 files changed, 26 insertions, 12 deletions
diff --git a/net/nfsshell/Makefile b/net/nfsshell/Makefile
index 454a119a27e6..1a0ed35c5718 100644
--- a/net/nfsshell/Makefile
+++ b/net/nfsshell/Makefile
@@ -2,22 +2,25 @@
# $FreeBSD$
PORTNAME= nfsshell
-PORTVERSION= 19980519
+PORTVERSION= 20130510
CATEGORIES= net
-MASTER_SITES= http://www.cs.vu.nl/pub/leendert/
+#MASTER_SITES= http://www.cs.vu.nl/pub/leendert/
DISTNAME= ${PORTNAME}
MAINTAINER= johans@FreeBSD.org
COMMENT= Userland NFS command tool
-WRKSRC= ${WRKDIR}/nfs
-ALL_TARGET= nfs
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DREADLINE" LIBS="-lreadline"
+USE_GITHUB= yes
+GH_ACCOUNT= NetDirect
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 09cdd52
+
+ALL_TARGET= nfsshell
+MAKE_ARGS= CC="${CC}" LIBS="-lreadline"
PLIST_FILES= bin/nfsshell
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/nfs ${PREFIX}/bin/nfsshell
+ ${INSTALL_PROGRAM} ${WRKSRC}/nfsshell ${STAGEDIR}${PREFIX}/bin/nfsshell
.include <bsd.port.mk>
diff --git a/net/nfsshell/distinfo b/net/nfsshell/distinfo
index e822e658d887..4fdfc2172466 100644
--- a/net/nfsshell/distinfo
+++ b/net/nfsshell/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nfsshell.tar.gz) = 900056f591e3a4f7ac9a7ea8d89464e9addc16ca4fe991a703ed61c98af38e2a
-SIZE (nfsshell.tar.gz) = 29213
+SHA256 (nfsshell.tar.gz) = f5df3ce7c313b11f0b0d7b7d6a2ecbb1c23761e6a4226cf6d5556ddceb37b25e
+SIZE (nfsshell.tar.gz) = 40129
diff --git a/net/nfsshell/files/patch-nfs.c b/net/nfsshell/files/patch-nfs.c
index 148e8cc399ef..ae0b0eae60e4 100644
--- a/net/nfsshell/files/patch-nfs.c
+++ b/net/nfsshell/files/patch-nfs.c
@@ -1,10 +1,11 @@
---- nfs.c.orig Sat Feb 5 23:17:18 2005
-+++ nfs.c Sat Feb 5 23:17:09 2005
-@@ -50,7 +50,6 @@
+--- nfsshell.c.orig 2013-05-10 23:40:04.000000000 +0200
++++ nfsshell.c 2013-12-28 16:34:53.000000000 +0100
+@@ -70,7 +70,7 @@
#include <netinet/in.h>
#include <arpa/inet.h>
#include <sys/time.h>
-#include <sys/sysmacros.h>
++#include <sys/param.h>
#include "mount.h"
#include "nfs_prot.h"
#include <netinet/in_systm.h>
diff --git a/net/nfsshell/files/patch-nfs_prot_xdr.c b/net/nfsshell/files/patch-nfs_prot_xdr.c
new file mode 100644
index 000000000000..552ce916f12e
--- /dev/null
+++ b/net/nfsshell/files/patch-nfs_prot_xdr.c
@@ -0,0 +1,10 @@
+--- nfs_prot_xdr.c.orig 2013-12-28 16:36:09.000000000 +0100
++++ nfs_prot_xdr.c 2013-12-28 16:36:34.000000000 +0100
+@@ -4,6 +4,7 @@
+ */
+
+ #include "nfs_prot.h"
++#define xdr_u_quad_t xdr_u_int64_t
+
+ bool_t
+ xdr_cookieverf3 (XDR *xdrs, cookieverf3 objp)