aboutsummaryrefslogtreecommitdiff
path: root/news/bgrab/files
diff options
context:
space:
mode:
Diffstat (limited to 'news/bgrab/files')
-rw-r--r--news/bgrab/files/Makefile.dist19
-rw-r--r--news/bgrab/files/patch-ab33
-rw-r--r--news/bgrab/files/patch-ac22
3 files changed, 48 insertions, 26 deletions
diff --git a/news/bgrab/files/Makefile.dist b/news/bgrab/files/Makefile.dist
new file mode 100644
index 000000000000..b2ff953b05fd
--- /dev/null
+++ b/news/bgrab/files/Makefile.dist
@@ -0,0 +1,19 @@
+OBJ = main.o server.o screen.o tree.o multipart.o grouplist.o \
+ findfile.o
+CXX ?= g++
+CXXFLAGS ?= -O6
+LIBS = -lncurses
+PREFIX ?= /usr/local
+DEST = $(PREFIX)/bin
+INSTALL ?= install
+
+bgrab: $(OBJ) Makefile common.h
+ $(CXX) $(LIBS) -o bgrab $(OBJ)
+
+clean:
+ rm -f $(OBJ) bgrab
+
+install: bgrab
+ $(INSTALL) bgrab $(DEST)/bgrab
+
+all: bgrab
diff --git a/news/bgrab/files/patch-ab b/news/bgrab/files/patch-ab
index 86f8d9b16c3e..be0366e63bf4 100644
--- a/news/bgrab/files/patch-ab
+++ b/news/bgrab/files/patch-ab
@@ -1,27 +1,26 @@
-diff -u -N ./main.cc ../bgrab/main.cc
---- ./main.cc Mon Feb 1 03:04:23 1999
-+++ ../bgrab/main.cc Tue Jul 27 10:38:26 1999
-@@ -9,7 +9,6 @@
+--- main.cc.orig Thu Sep 30 09:20:30 1999
++++ main.cc Thu Sep 30 09:22:51 1999
+@@ -7,7 +7,6 @@
#include <sys/types.h>
#include <sys/wait.h>
#include <stdlib.h>
-#include <curses.h>
- }
-
- extern "C++" {
-@@ -19,7 +18,7 @@
- #include "multipart.h"
- }
+ #include "server.h"
+ #include "screen.h"
+ #include "tree.h"
+@@ -15,7 +14,7 @@
+ #include "grouplist.h"
+ #include "findfile.h"
-#define NNTP_PORT 119
+unsigned NNTP_PORT = 119;
char *NNTP_SERVER = NULL;
- char *NNTP_GROUP = NULL;
-@@ -194,6 +193,10 @@
- fprintf(stderr, "groupname newsgroup to read\n");
- fprintf(stderr," -n don't output to stdout\n");
- fprintf(stderr," -f fork to background. use only with -n\n");
+ groupListPointer NNTP_GROUP = new groupList();
+@@ -249,6 +248,10 @@
+ fprintf(stderr," -a user pass Authenticate the login to the server with\n");
+ fprintf(stderr," 'user' as username and 'pass' as password.\n");
+ fprintf(stderr," Both username and password must be present.\n");
+ fprintf(stderr,"\nThe hostname or IP address of the news server can be\n");
+ fprintf(stderr,"specified by the NNTPSERVER environment variable, or defaults\n");
+ fprintf(stderr,"to \"news\". The port to connect to can be specified by the\n");
@@ -29,8 +28,8 @@ diff -u -N ./main.cc ../bgrab/main.cc
exit(-1);
}
-@@ -225,6 +228,8 @@
- void main(int argc, char **argv) {
+@@ -301,6 +304,8 @@
+
if (getenv("NNTPSERVER")) NNTP_SERVER = strdup(getenv("NNTPSERVER"));
else NNTP_SERVER = strdup("news");
+
diff --git a/news/bgrab/files/patch-ac b/news/bgrab/files/patch-ac
index 4fce47a9dab3..18db787f7ad9 100644
--- a/news/bgrab/files/patch-ac
+++ b/news/bgrab/files/patch-ac
@@ -1,10 +1,14 @@
-diff -u -N ./screen.h ../bgrab/screen.h
---- ./screen.h Sun Jan 24 03:24:50 1999
-+++ ../bgrab/screen.h Tue Jul 27 10:38:40 1999
-@@ -1,5 +1,5 @@
- extern "C" {
--#include <curses.h>
-+#include <ncurses.h>
- #include <stdio.h>
+--- server.cc.orig Thu Sep 16 16:50:51 1999
++++ server.cc Thu Sep 16 17:00:39 1999
+@@ -8,7 +8,10 @@
+ server::server(char *host, unsigned long port) {
+ inbuf = 0;
+ bzero(buf,BUFSIZE+1);
+- soc = connectto(host,port);
++ if((soc = connectto(host,port)) == -1) {
++ fprintf(stderr, "Cannot connect to host \"%s\"\n", host);
++ exit(1);
++ }
}
-
+
+ int server::sockfd() {