aboutsummaryrefslogtreecommitdiff
path: root/news/cnews/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/cnews/Makefile')
-rw-r--r--news/cnews/Makefile39
1 files changed, 32 insertions, 7 deletions
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index ca6b7b23f090..039675cf07d5 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 September 1994
# Whom: adam
#
-# $Id: Makefile,v 1.18 1998/08/30 15:45:29 steve Exp $
+# $Id: Makefile,v 1.19 1998/12/17 21:54:51 jseger Exp $
#
DISTNAME= c-news
@@ -13,12 +13,27 @@ MASTER_SITES= ftp://ftp.cs.toronto.edu/pub/c-news/ \
ftp://ftp.funet.fi/pub/unix/news/cnews/ \
ftp://ftp.win.or.jp/pub/network/news/cnews/ \
ftp://ftp.redcom.ru/pub/unix/usenet/c-news/ \
- ftp://ftp.mc.hik.se/pub/unix/news/c-news/
+ ftp://ftp.mc.hik.se/pub/unix/news/c-news/ \
+ ftp://ftp.dinoex.org/pub/c-news/
EXTRACT_SUFX= .tar.Z
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ pgpverify-1.11
-MAINTAINER= ports@FreeBSD.ORG
+PATCH_SITES= ftp://ftp.dinoex.org/pub/c-news/
+PATCHFILES= c-news-patch-fileart.c c-news-patch-namecheck.awk \
+ c-news-patch-newsrun c-news-patch-sendbatches \
+ c-news-patch-ctl-pgp3 c-news-patch-ctl-more \
+ c-news-patch-ctl-regexp \
+ c-news-patch-doexpire c-news-patch-queuelen.tay \
+ c-news-patch-bunzip2 \
+ c-news-patch-ctl-underscore \
+ c-news-patch-pgpverify-1.11
+MAINTAINER= dirk.meyer@dinoex.sub.org
+
+DIST_SUBDIR= c-news
NO_WRKSUBDIR= yes
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAKEFILE= makefile
MAN1= checknews.1cn inews.1cn postnews.1cn readnews.1cn
MAN5= controlperm.5 news.5 newsctl.5 newsdb.5 newsoverview.5 \
@@ -31,7 +46,10 @@ MAN8= cnewsdo.8cn expire.8cn explode.8cn mergeactive.8 \
NEWSSPOOL= ${PREFIX}/newsspool
NEWSBIN= ${PREFIX}/news/cnewsbin
NEWSLIB= ${PREFIX}/news/lib
-MANDIR= ${PREFIX}/man
+PGPVERIFY= pgpverify-1.11
+
+pre-patch:
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${PGPVERIFY} ${WRKSRC}/${PGPVERIFY}
do-install:
${RM} -f ${PREFIX}/bin/inews
@@ -41,6 +59,7 @@ do-install:
-ln -s ${NEWSSPOOL} /var/news
chown news.news ${NEWSSPOOL} ${NEWSLIB}
chown bin.bin ${NEWSBIN}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PGPVERIFY} ${NEWSBIN}/pgpverify
cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install
cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} setup
cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ui readpostcheck
@@ -49,9 +68,15 @@ do-install:
.endfor
chown news.news ${NEWSBIN}/input/newsspool
chmod 6755 ${NEWSBIN}/input/newsspool
- ${INSTALL_MAN} ${WRKSRC}/man/*.1* ${MANDIR}/man1
- ${INSTALL_MAN} ${WRKSRC}/man/*.5* ${MANDIR}/man5
- ${INSTALL_MAN} ${WRKSRC}/man/*.8* ${MANDIR}/man8
+.for i in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man1
+.endfor
+.for i in ${MAN5}
+ ${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man5
+.endfor
+.for i in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man8
+.endfor
@${ECHO} ""
@${ECHO} "!!!!!!!!"
@${ECHO} "you MUST change the configuration of this news setup:"