aboutsummaryrefslogtreecommitdiff
path: root/news/fidogate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/fidogate/Makefile')
-rw-r--r--news/fidogate/Makefile34
1 files changed, 33 insertions, 1 deletions
diff --git a/news/fidogate/Makefile b/news/fidogate/Makefile
index 4acd3f40c8ad..31592679d3a1 100644
--- a/news/fidogate/Makefile
+++ b/news/fidogate/Makefile
@@ -3,7 +3,7 @@
# Date created: 02 Dez 1997
# Whom: dirk.meyer@dinoex.sub.org
#
-# $Id: Makefile,v 1.1.1.1 1998/12/12 03:40:04 jseger Exp $
+# $Id: Makefile,v 1.2 1998/12/24 13:03:50 flathill Exp $
#
DISTNAME= fidogate-4.2.9
@@ -21,9 +21,41 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/fidogate
+pre-configure:
+ @${MV} ${WRKSRC}/config.make ${WRKSRC}/config.make.sed
+ @${SED} -e 's/\$${PREFIX}/${PREFIX:S/\//\\\//g}/g' \
+ < ${WRKSRC}/config.make.sed > ${WRKSRC}/config.make
+
pre-install:
${MKDIR} ${PREFIX}/libexec/fidogate
${MKDIR} ${PREFIX}/share/doc/fidogate/html
${MKDIR} ${PREFIX}/share/doc/fidogate/info
+ ${MKDIR} ${PREFIX}/share/doc/fidogate/fido
+ ${MKDIR} ${PREFIX}/share/doc/fidogate/howto
+ ${MKDIR} ${PREFIX}/share/doc/fidogate/misc
+ ${MKDIR} ${PREFIX}/share/doc/fidogate/gatebau
+
+DOCLIST = \
+ Fido-Point-HOWTO Fido-Point-eng-HOWTO \
+ fidogate.texi fidogate.txt \
+ gatebau94.txt kludge-rfc.doc msgid.doc \
+ qmail.txt texinfo.tex \
+ fido \
+ howto \
+ misc \
+ rfc \
+ gatebau/msgid.sgml \
+ gatebau/msgid.tex \
+ gatebau/msgid.txt
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/fidogate
+ @cd ${WRKSRC}/doc; tar cf - ${DOCLIST} |\
+ (cd ${PREFIX}/share/doc/fidogate; tar xf -)
+ ${MKDIR} ${PREFIX}/share/examples/fidogate
+ @cd ${WRKSRC}/examples; tar cf - . |\
+ (cd ${PREFIX}/share/examples/fidogate; tar xf -)
+.endif
.include <bsd.port.mk>