aboutsummaryrefslogtreecommitdiff
path: root/news/grn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/grn/Makefile')
-rw-r--r--news/grn/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/news/grn/Makefile b/news/grn/Makefile
new file mode 100644
index 000000000000..28fd2f40f434
--- /dev/null
+++ b/news/grn/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: grm
+# Date created: 20 July 2000
+# Whom: Maxim Sobolev
+#
+# $FreeBSD$
+#
+
+PORTNAME= grn
+PORTVERSION= 0.0.26
+CATEGORIES= news gnome
+MASTER_SITES= ftp://ivvs.ul.ru/pub/unix/grn/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ xml.5:${PORTSDIR}/textproc/libxml
+RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+LIBTOOLFILES= configure libmutt/configure
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+CONFIGURE_ENV= glibpath="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>