aboutsummaryrefslogtreecommitdiff
path: root/news/grn
diff options
context:
space:
mode:
Diffstat (limited to 'news/grn')
-rw-r--r--news/grn/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/news/grn/Makefile b/news/grn/Makefile
index aa5a3cf28126..851aba83c2ec 100644
--- a/news/grn/Makefile
+++ b/news/grn/Makefile
@@ -23,6 +23,12 @@ CONFIGURE_ENV= glibpath="${GLIB_CONFIG}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
@@ -32,4 +38,4 @@ pre-patch:
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>