aboutsummaryrefslogtreecommitdiff
path: root/news/gup/files
diff options
context:
space:
mode:
Diffstat (limited to 'news/gup/files')
-rw-r--r--news/gup/files/freebsd1
-rw-r--r--news/gup/files/patch-aa36
-rw-r--r--news/gup/files/patch-ab10
-rw-r--r--news/gup/files/patch-ac11
4 files changed, 58 insertions, 0 deletions
diff --git a/news/gup/files/freebsd b/news/gup/files/freebsd
new file mode 100644
index 000000000000..083aa901f6df
--- /dev/null
+++ b/news/gup/files/freebsd
@@ -0,0 +1 @@
+P_NO_FLAGS = -DNO_MALLOC_H
diff --git a/news/gup/files/patch-aa b/news/gup/files/patch-aa
new file mode 100644
index 000000000000..7a743430900b
--- /dev/null
+++ b/news/gup/files/patch-aa
@@ -0,0 +1,36 @@
+--- Makefile.orig Sun Nov 22 13:15:39 1998
++++ Makefile Sun Nov 22 13:18:46 1998
+@@ -8,7 +8,7 @@
+ # a working version for your system, please mail a copy back to the
+ # author so that others may benefit from your effort.
+
+-CONFIG = vanilla
++CONFIG = freebsd
+
+ # Destination directories for the executable and man page. Note that
+ # the executable is only used in a .forward so /usr/local/bin may
+@@ -28,20 +28,20 @@
+
+ # ACTIVE_PATH is the full pathname for your news active file. This
+ # file is used to validate newgroup names.
+-ACTIVE_PATH =
++ACTIVE_PATH = /var/db/news/active
+
+
+ # NEWSGROUPS_PATH is the fill pathname for your newsgroups file. This
+ # file is used to provide descriptions for each newsgroup.
+-NEWSGROUPS_PATH =
++NEWSGROUPS_PATH = /var/db/news/newsgroups
+
+ # BACKSTOP_MAILID is used if gup cannot find a FROM: or a REPLY-TO: or
+ # a valid site command, this is where the mail goes to.
+-BACKSTOP_MAILID = news
++BACKSTOP_MAILID = usenet
+
+ # MAIL_COMMAND is the mailer that accepts a mail with rfc822 headers and
+ # body from stdin.
+-MAIL_COMMAND = "/usr/lib/sendmail -t"
++MAIL_COMMAND = "/usr/sbin/sendmail -oi -t"
+
+ # With a command like "include alt.*" the resultant list is, long.
+ # LOG_MATCH_LIMIT, defines the upper bound on the number of pattern
diff --git a/news/gup/files/patch-ab b/news/gup/files/patch-ab
new file mode 100644
index 000000000000..4da3b19ed584
--- /dev/null
+++ b/news/gup/files/patch-ab
@@ -0,0 +1,10 @@
+--- rfc822.h.orig Sun May 9 12:53:24 1999
++++ rfc822.h Sun May 9 12:53:58 1999
+@@ -246,7 +246,6 @@
+ extern int errno;
+ extern int sys_nerr;
+ extern int optind;
+-extern char *sys_errlist[];
+ extern char **environ;
+ extern char *optarg;
+
diff --git a/news/gup/files/patch-ac b/news/gup/files/patch-ac
new file mode 100644
index 000000000000..a451304f8fcd
--- /dev/null
+++ b/news/gup/files/patch-ac
@@ -0,0 +1,11 @@
+--- main.mk.orig Mon Jun 7 23:37:43 1999
++++ main.mk Mon Jun 7 23:38:19 1999
+@@ -17,7 +17,7 @@
+ -DBACKSTOP_MAILID='"$(BACKSTOP_MAILID)"' \
+ -DLOG_MATCH_LIMIT=$(LOG_MATCH_LIMIT) -DUMASK=$(UMASK)
+
+-CFLAGS = $(P_CFLAGS) $(P_NO_FLAGS) $(P_USE_FLAGS) $(P_INCLUDES) \
++CFLAGS += $(P_CFLAGS) $(P_NO_FLAGS) $(P_USE_FLAGS) $(P_INCLUDES) \
+ $(DEFS) -DMAIL_COMMAND='"$(MAIL_COMMAND)"'
+
+ LDFLAGS = $(P_LDFLAGS) $(P_LIBS)