aboutsummaryrefslogtreecommitdiff
path: root/news/husky-hpt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/husky-hpt/Makefile')
-rw-r--r--news/husky-hpt/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/news/husky-hpt/Makefile b/news/husky-hpt/Makefile
new file mode 100644
index 000000000000..2945ed8acab7
--- /dev/null
+++ b/news/husky-hpt/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= husky-hpt
+CATEGORIES= news mail
+
+MAINTAINER= osharoiko@gmail.com
+COMMENT= Husky FTN tosser
+
+LIB_DEPENDS= libfidoconfig.so:${PORTSDIR}/news/husky-fidoconf \
+ libareafix.so:${PORTSDIR}/news/husky-areafix
+
+ALL_TARGET= all doc
+INSTALL_TARGET= install install-doc
+INFO= hpt
+
+MASTERDIR= ${.CURDIR}/../husky
+COMPONENT_SUBDIR= hpt
+
+post-patch:
+ ${REINPLACE_CMD} -e 's^/path/to/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/hptlink.1
+ ${REINPLACE_CMD} -e 's^/some/path/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/hpttree.1
+ ${REINPLACE_CMD} -e 's^/fido/etc/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/txt2pkt.1
+
+.include <bsd.port.mk>