aboutsummaryrefslogtreecommitdiff
path: root/news/husky/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/husky/Makefile')
-rw-r--r--news/husky/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/news/husky/Makefile b/news/husky/Makefile
index 90479bb7a3cc..733fb3de1c80 100644
--- a/news/husky/Makefile
+++ b/news/husky/Makefile
@@ -1,17 +1,15 @@
# $FreeBSD$
PORTNAME?= husky
-PORTVERSION= 1.9.20140519
-PORTREVISION?= 3
+PORTVERSION= 1.9.20191207
PORTEPOCH?= 0
CATEGORIES?= news mail
-MASTER_SITES= SF/husky/husky/1.9-current/2014.05.19
+MASTER_SITES= http://download.huskyproject.org/sources/
+DISTNAME= husky-all-1.9-source-20191207
MAINTAINER?= osharoiko@gmail.com
COMMENT?= Husky full featured highly portable FTN Tosser
-DISTNAME= husky-all-1.9-source-20140519
-
.if ${PORTNAME} == "husky"
RUN_DEPENDS= hpt:news/husky-hpt \
htick:news/husky-htick
@@ -20,19 +18,19 @@ NO_BUILD= yes
NO_INSTALL= yes
.endif
-USES+= alias gmake tar:tgz
+USES+= alias dos2unix gmake zip
-HUSKY_ROOTDIR= ${WRKDIR}/husky
-PATCH_WRKSRC= ${HUSKY_ROOTDIR}
-WRKSRC= ${HUSKY_ROOTDIR}/${COMPONENT_SUBDIR}
+NO_WRKSUBDIR= yes
+BUILD_WRKSRC= ${WRKSRC}/${COMPONENT_SUBDIR}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
PKGDIR= ${.CURDIR}
USERS= fido
GROUPS= fido
pre-build:
- ${LN} -sf ${HUSKY_ROOTDIR}/huskybse/huskymak.cfg ${HUSKY_ROOTDIR}
+ ${LN} -sf ${WRKSRC}/huskybse/huskymak.cfg ${WRKSRC}
@${REINPLACE_CMD} -e 's|gcc|${CC}|; s|g++|${CXX}|' \
- ${HUSKY_ROOTDIR}/huskybse/huskymak.cfg
+ ${WRKSRC}/huskybse/huskymak.cfg
.include <bsd.port.mk>