aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
Diffstat (limited to 'news')
-rw-r--r--news/newsx/Makefile8
-rw-r--r--news/newsx/files/patch-configure11
-rw-r--r--news/newsx/pkg-plist13
3 files changed, 10 insertions, 22 deletions
diff --git a/news/newsx/Makefile b/news/newsx/Makefile
index 986eaa578b24..e41a2e1d7364 100644
--- a/news/newsx/Makefile
+++ b/news/newsx/Makefile
@@ -34,7 +34,7 @@ CPPFLAGS+= -I${LOCALBASE}/news/include
CONFIGURE_ARGS+= --without-history
.endif
-DOCS= AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
+PORTDOCS= AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
.include <bsd.port.options.mk>
@@ -52,12 +52,10 @@ post-build:
${STRIP_CMD} ${WRKSRC}/src/newsx
.endif
-post-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/news/spool/inhosts
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for FILE in ${DOCS}
+.for FILE in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
- @${ECHO} "Documentation installed in ${DOCSDIR}."
.include <bsd.port.mk>
diff --git a/news/newsx/files/patch-configure b/news/newsx/files/patch-configure
index 945040469c6e..86ad1086213b 100644
--- a/news/newsx/files/patch-configure
+++ b/news/newsx/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2003-05-18 19:25:34.000000000 +0200
-+++ configure 2013-11-27 17:22:07.000000000 +0100
-@@ -253,7 +253,7 @@
+--- configure.orig 2003-05-18 17:25:34 UTC
++++ configure
+@@ -253,7 +253,7 @@ exec 6>&1
#
# Initializations.
#
@@ -9,7 +9,7 @@
ac_config_libobj_dir=.
cross_compiling=no
subdirs=
-@@ -1712,15 +1712,15 @@
+@@ -1712,15 +1712,15 @@ PACKAGE_DATE=`date | sed 's/^[^ ]* \([^
VISIT="/usr/lib/news /var/news/etc /usr/spool/news /usr/share/news \
@@ -29,13 +29,14 @@
# Check whether --with-newshome or --without-newshome was given.
-@@ -1890,7 +1890,11 @@
+@@ -1890,7 +1890,12 @@ echo $ECHO_N "checking and found INN...
# it has been reported that some INN 2.1 had its own VERSION
VERSION_save="$VERSION"
VERSION=
+ prefix_orig="${prefix}"
+ exec_prefix_orig="${exec_prefix}"
. $NEWSCONFIG
++ unset TMPDIR
+ prefix="${prefix_orig}"
+ exec_prefix="${exec_prefix_orig}"
INN_VERSION="$VERSION"
diff --git a/news/newsx/pkg-plist b/news/newsx/pkg-plist
index 75d5ea001746..9c3f4e252e1e 100644
--- a/news/newsx/pkg-plist
+++ b/news/newsx/pkg-plist
@@ -4,15 +4,4 @@ man/man1/newsq.1.gz
man/man5/in.hosts.5.gz
man/man5/newsx.conf.5.gz
man/man8/newsx.8.gz
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrmtry news/spool/inhosts
-@dirrmtry news/spool
-@dirrmtry news
+@dir(news,news,) news/spool/inhosts