aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
Diffstat (limited to 'news')
-rw-r--r--news/newscache/Makefile1
-rw-r--r--news/newscache/files/patch-NewsCache.cc17
2 files changed, 14 insertions, 4 deletions
diff --git a/news/newscache/Makefile b/news/newscache/Makefile
index 3cbb78988034..5ba05609db03 100644
--- a/news/newscache/Makefile
+++ b/news/newscache/Makefile
@@ -7,6 +7,7 @@
PORTNAME= newscache
PORTVERSION= 1.1.90
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= http://www.hstraub.at/linux/downloads/src/ \
http://www.infosys.tuwien.ac.at/NewsCache/download/
diff --git a/news/newscache/files/patch-NewsCache.cc b/news/newscache/files/patch-NewsCache.cc
index 445cffccb6be..74195c7dcff5 100644
--- a/news/newscache/files/patch-NewsCache.cc
+++ b/news/newscache/files/patch-NewsCache.cc
@@ -1,10 +1,19 @@
---- src/NewsCache.cc.orig Sat Feb 23 18:06:38 2002
-+++ src/NewsCache.cc Sat Feb 23 18:06:48 2002
-@@ -18,7 +18,6 @@
+--- src/NewsCache.cc.orig Fri Oct 24 12:12:20 2003
++++ src/NewsCache.cc Wed Dec 10 15:47:46 2003
+@@ -24,7 +24,6 @@
*/
#include "config.h"
-
+
-#include <crypt.h>
#include <ctype.h>
#include <unistd.h>
#include <string.h>
+@@ -2024,7 +2023,7 @@
+ }
+
+ cmdp = clt.client_command_map.find(argv[0]);
+- if (cmdp == end || !cmdp->second->func) {
++ if (cmdp == clt.client_command_map.end() || !cmdp->second->func) {
+ slog.p(Logger::Notice) << clt.client_logname
+ << " unrecognized " << oreq << "\n";
+ (*clt.co) << "500 What?\r\n";