aboutsummaryrefslogtreecommitdiff
path: root/palm/bibelot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'palm/bibelot/Makefile')
-rw-r--r--palm/bibelot/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/palm/bibelot/Makefile b/palm/bibelot/Makefile
index b0c41d7ba652..1ffb9db8154e 100644
--- a/palm/bibelot/Makefile
+++ b/palm/bibelot/Makefile
@@ -9,14 +9,16 @@ MASTER_SITES= SF/${PORTNAME}/Bibelot/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Formats and converts text documents into compressed PalmDoc .pdb files
-PLIST_FILES= bin/bibelot
-USES= perl5
+USES= perl5 shebangfix
+NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_BUILD= yes
-NO_STAGE= yes
+PLIST_FILES= bin/bibelot
+SHEBANG_FILES= bibelot.pl
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>