aboutsummaryrefslogtreecommitdiff
path: root/palm/jpilot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'palm/jpilot/Makefile')
-rw-r--r--palm/jpilot/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/palm/jpilot/Makefile b/palm/jpilot/Makefile
index 520dfbfd2aaf..328f08cfaa19 100644
--- a/palm/jpilot/Makefile
+++ b/palm/jpilot/Makefile
@@ -17,7 +17,9 @@ COMMENT= Desktop Organizer Software for the Palm Pilot
LIB_DEPENDS= pisock.8:${PORTSDIR}/palm/pilot-link
CONFIGURE_ARGS+= --with-pilot-prefix=${PREFIX}
+.if (!defined(WITHOUT_NLS))
USE_GETTEXT= yes
+.endif
.if defined(WITH_GTK2)
USE_GNOME= gtk20
CONFIGURE_ARGS+= --enable-gtk2=yes
@@ -25,6 +27,14 @@ CONFIGURE_ARGS+= --enable-gtk2=yes
USE_GNOME= gtk12
.endif
+.if !defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/jpilot/plugins