aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
Diffstat (limited to 'palm')
-rw-r--r--palm/ppmtoTbmp/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/palm/ppmtoTbmp/Makefile b/palm/ppmtoTbmp/Makefile
index 7a02c7e69e0d..0826c3881d52 100644
--- a/palm/ppmtoTbmp/Makefile
+++ b/palm/ppmtoTbmp/Makefile
@@ -15,9 +15,12 @@ COMMENT= PPM to Pilot bitmap converter
LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm
+USE_REINPLACE= yes
+
post-patch:
- ${PERL} -pi -e "s|^CFLAGS.+|CFLAGS += -I${LOCALBASE}/include|g; \
+ @${REINPLACE_CMD} -e "s|^CFLAGS =.*|CFLAGS += -I${LOCALBASE}/include|g; \
s|^LDLIBS =|LDLIBS = -L${LOCALBASE}/lib|g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^#include "ppmcmap.h"/d' ${WRKSRC}/ppmtoTbmp.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ppmtoTbmp ${WRKSRC}/Tbmptopnm \