aboutsummaryrefslogtreecommitdiff
path: root/palm
diff options
context:
space:
mode:
Diffstat (limited to 'palm')
-rw-r--r--palm/Makefile1
-rw-r--r--palm/rapip/Makefile27
-rw-r--r--palm/rapip/distinfo1
-rw-r--r--palm/rapip/pkg-descr6
-rw-r--r--palm/rapip/pkg-plist29
-rw-r--r--palm/synce-kde/Makefile27
-rw-r--r--palm/synce-kde/distinfo1
-rw-r--r--palm/synce-kde/pkg-descr6
-rw-r--r--palm/synce-kde/pkg-plist29
9 files changed, 127 insertions, 0 deletions
diff --git a/palm/Makefile b/palm/Makefile
index e3a38df92135..743c9e8aee5c 100644
--- a/palm/Makefile
+++ b/palm/Makefile
@@ -27,6 +27,7 @@
SUBDIR += pose
SUBDIR += ppmtoTbmp
SUBDIR += prc-tools
+ SUBDIR += rapip
SUBDIR += romeo
SUBDIR += sitescooper
SUBDIR += syncal
diff --git a/palm/rapip/Makefile b/palm/rapip/Makefile
new file mode 100644
index 000000000000..6cfe90818fcd
--- /dev/null
+++ b/palm/rapip/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rapip
+# Date created: 15 June 2003
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+
+PORTNAME= rapip
+PORTVERSION= 0.4.1
+CATEGORIES= palm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= KIO-slave and trayapp for access to WinCE devices
+
+LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce \
+ rapi.2:${PORTSDIR}/palm/synce-librapi2
+RUN_DEPENDS+= synce-serial-start:${PORTSDIR}/palm/synce-serial \
+ dccm:${PORTSDIR}/palm/synce-dccm
+
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/palm/rapip/distinfo b/palm/rapip/distinfo
new file mode 100644
index 000000000000..450ccdec2b2d
--- /dev/null
+++ b/palm/rapip/distinfo
@@ -0,0 +1 @@
+MD5 (rapip-0.4.1.tar.gz) = 49730187d3c6ca246147593e5133d6ef
diff --git a/palm/rapip/pkg-descr b/palm/rapip/pkg-descr
new file mode 100644
index 000000000000..89ef4536beb1
--- /dev/null
+++ b/palm/rapip/pkg-descr
@@ -0,0 +1,6 @@
+SynCE is a project for connecting to devices running Windows CE or Pocket PC.
+Rapip is a KIO-slave giving KDE users transparent access to the files and
+information on their Windows CE device as if it were a local folder. Raki
+is a tray application giving instant access to these functions.
+
+WWW: http://synce.sourceforge.net/
diff --git a/palm/rapip/pkg-plist b/palm/rapip/pkg-plist
new file mode 100644
index 000000000000..8ffed8718c94
--- /dev/null
+++ b/palm/rapip/pkg-plist
@@ -0,0 +1,29 @@
+bin/raki
+lib/kde3/kio_rapip.la
+lib/kde3/kio_rapip.so
+share/applnk/Utilities/raki.desktop
+share/doc/HTML/en/raki/index.cache.bz2
+share/doc/HTML/en/raki/index.docbook
+share/icons/hicolor/16x16/apps/raki.png
+share/icons/hicolor/16x16/apps/raki_bw.png
+share/icons/hicolor/16x16/apps/rapip.png
+share/icons/hicolor/16x16/apps/rapip_bw.png
+share/icons/hicolor/22x22/apps/raki.png
+share/icons/hicolor/22x22/apps/raki_bw.png
+share/icons/hicolor/22x22/apps/rapip.png
+share/icons/hicolor/22x22/apps/rapip_bw.png
+share/icons/hicolor/32x32/apps/raki.png
+share/icons/hicolor/32x32/apps/raki_bw.png
+share/icons/hicolor/32x32/apps/rapip.png
+share/icons/hicolor/32x32/apps/rapip_bw.png
+share/icons/hicolor/48x48/apps/raki.png
+share/icons/hicolor/48x48/apps/raki_bw.png
+share/icons/hicolor/48x48/apps/rapip.png
+share/icons/hicolor/48x48/apps/rapip_bw.png
+share/icons/hicolor/64x64/apps/raki.png
+share/icons/hicolor/64x64/apps/raki_bw.png
+share/icons/hicolor/64x64/apps/rapip.png
+share/icons/hicolor/64x64/apps/rapip_bw.png
+share/services/rapip.protocol
+@dirrm share/doc/HTML/en/raki/common
+@dirrm share/doc/HTML/en/raki
diff --git a/palm/synce-kde/Makefile b/palm/synce-kde/Makefile
new file mode 100644
index 000000000000..6cfe90818fcd
--- /dev/null
+++ b/palm/synce-kde/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: rapip
+# Date created: 15 June 2003
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+
+PORTNAME= rapip
+PORTVERSION= 0.4.1
+CATEGORIES= palm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= KIO-slave and trayapp for access to WinCE devices
+
+LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce \
+ rapi.2:${PORTSDIR}/palm/synce-librapi2
+RUN_DEPENDS+= synce-serial-start:${PORTSDIR}/palm/synce-serial \
+ dccm:${PORTSDIR}/palm/synce-dccm
+
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/palm/synce-kde/distinfo b/palm/synce-kde/distinfo
new file mode 100644
index 000000000000..450ccdec2b2d
--- /dev/null
+++ b/palm/synce-kde/distinfo
@@ -0,0 +1 @@
+MD5 (rapip-0.4.1.tar.gz) = 49730187d3c6ca246147593e5133d6ef
diff --git a/palm/synce-kde/pkg-descr b/palm/synce-kde/pkg-descr
new file mode 100644
index 000000000000..89ef4536beb1
--- /dev/null
+++ b/palm/synce-kde/pkg-descr
@@ -0,0 +1,6 @@
+SynCE is a project for connecting to devices running Windows CE or Pocket PC.
+Rapip is a KIO-slave giving KDE users transparent access to the files and
+information on their Windows CE device as if it were a local folder. Raki
+is a tray application giving instant access to these functions.
+
+WWW: http://synce.sourceforge.net/
diff --git a/palm/synce-kde/pkg-plist b/palm/synce-kde/pkg-plist
new file mode 100644
index 000000000000..8ffed8718c94
--- /dev/null
+++ b/palm/synce-kde/pkg-plist
@@ -0,0 +1,29 @@
+bin/raki
+lib/kde3/kio_rapip.la
+lib/kde3/kio_rapip.so
+share/applnk/Utilities/raki.desktop
+share/doc/HTML/en/raki/index.cache.bz2
+share/doc/HTML/en/raki/index.docbook
+share/icons/hicolor/16x16/apps/raki.png
+share/icons/hicolor/16x16/apps/raki_bw.png
+share/icons/hicolor/16x16/apps/rapip.png
+share/icons/hicolor/16x16/apps/rapip_bw.png
+share/icons/hicolor/22x22/apps/raki.png
+share/icons/hicolor/22x22/apps/raki_bw.png
+share/icons/hicolor/22x22/apps/rapip.png
+share/icons/hicolor/22x22/apps/rapip_bw.png
+share/icons/hicolor/32x32/apps/raki.png
+share/icons/hicolor/32x32/apps/raki_bw.png
+share/icons/hicolor/32x32/apps/rapip.png
+share/icons/hicolor/32x32/apps/rapip_bw.png
+share/icons/hicolor/48x48/apps/raki.png
+share/icons/hicolor/48x48/apps/raki_bw.png
+share/icons/hicolor/48x48/apps/rapip.png
+share/icons/hicolor/48x48/apps/rapip_bw.png
+share/icons/hicolor/64x64/apps/raki.png
+share/icons/hicolor/64x64/apps/raki_bw.png
+share/icons/hicolor/64x64/apps/rapip.png
+share/icons/hicolor/64x64/apps/rapip_bw.png
+share/services/rapip.protocol
+@dirrm share/doc/HTML/en/raki/common
+@dirrm share/doc/HTML/en/raki