aboutsummaryrefslogtreecommitdiff
path: root/polish/ekg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'polish/ekg/Makefile')
-rw-r--r--polish/ekg/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/polish/ekg/Makefile b/polish/ekg/Makefile
index f45958607c37..585873b419a5 100644
--- a/polish/ekg/Makefile
+++ b/polish/ekg/Makefile
@@ -6,6 +6,7 @@
PORTNAME= ekg
PORTVERSION= 1.7.r3
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= polish net-im
MASTER_SITES= http://ekg.chmurka.net/
@@ -14,18 +15,23 @@ DISTNAME= ${PORTNAME}-1.7rc3
MAINTAINER= alex@bsdguru.org
COMMENT= Text-mode Gadu-Gadu client
-LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/libgadu
+LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
+ gadu.3:${PORTSDIR}/polish/libgadu
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack pkgconfig
CONFIGURE_ARGS+= --disable-shared \
--disable-static \
- --enable-dynamic
+ --enable-dynamic \
+ --without-openssl \
+ --disable-libgadu-openssl \
+ --without-libungif \
+ --without-libjpeg
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lexecinfo"
OPTIONS= ASPELL "Build with ASPELL support" off