aboutsummaryrefslogtreecommitdiff
path: root/polish/fortunepl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'polish/fortunepl/Makefile')
-rw-r--r--polish/fortunepl/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/polish/fortunepl/Makefile b/polish/fortunepl/Makefile
index 68fc0da69e68..73f56dec8170 100644
--- a/polish/fortunepl/Makefile
+++ b/polish/fortunepl/Makefile
@@ -12,7 +12,7 @@ PATCHFILES= fortunes-pl_${PORTVERSION}.freebsd.pl \
fortunes-pl_${PORTVERSION}.filozofia
MAINTAINER= ports@FreeBSD.org
-COMMENT= A lot of funny Polish fortune files
+COMMENT= Lot of funny Polish fortune files
STRCMD= /usr/games/strfile
WRKSRC= ${WRKDIR}/fortunes-pl-${PORTVERSION}.orig
@@ -28,7 +28,6 @@ FORTUNES= 7thguard advocacy apcoh argante bajki bok cnp cows \
teleturnieje testnaosobowosc wierszyki wieza-pilot zen \
znaki_zodiaku
-NO_STAGE= yes
pre-everything::
.if !exists(${STRCMD})
IGNORE= need strfile command. Please install games distribution of base system
@@ -44,13 +43,12 @@ do-build:
.endfor
do-install:
- @${MKDIR} ${PREFIX}/share/games
- @${MKDIR} ${PREFIX}/share/games/fortune
- @${MKDIR} ${PREFIX}/share/games/fortune/pl
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/games/fortune/pl
.for FILE in ${FORTUNES}
- @${ECHO_CMD} "Installing ${FILE} into ${PREFIX}/share/games/fortune/pl/"
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${PREFIX}/share/games/fortune/pl
- @${INSTALL_DATA} ${WRKSRC}/${FILE}.dat ${PREFIX}/share/games/fortune/pl
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} \
+ ${STAGEDIR}${PREFIX}/share/games/fortune/pl
+ ${INSTALL_DATA} ${WRKSRC}/${FILE}.dat \
+ ${STAGEDIR}${PREFIX}/share/games/fortune/pl
.endfor
post-install: