aboutsummaryrefslogtreecommitdiff
path: root/polish/gnugadu2/scripts/configure.gg
diff options
context:
space:
mode:
Diffstat (limited to 'polish/gnugadu2/scripts/configure.gg')
-rw-r--r--polish/gnugadu2/scripts/configure.gg77
1 files changed, 77 insertions, 0 deletions
diff --git a/polish/gnugadu2/scripts/configure.gg b/polish/gnugadu2/scripts/configure.gg
new file mode 100644
index 000000000000..2a1949ef5284
--- /dev/null
+++ b/polish/gnugadu2/scripts/configure.gg
@@ -0,0 +1,77 @@
+#!/bin/sh
+# $FreeBSD$
+
+if [ -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc ]; then
+ exit
+fi
+
+tempfile=`/usr/bin/mktemp -t checklist`
+
+if [ "${BATCH}" ]; then
+ if [ "${GNUGADU_OPTIONS}" ]; then
+ set ${GNUGADU_OPTIONS}
+ else
+ set \"esd\"
+ fi
+else
+ /usr/bin/dialog --title "configuration options" --clear \
+ --checklist "\n\
+Please select desired options:" -1 -1 16 \
+esd "esd support" ON \
+arts "arts support" OFF \
+gnome "GNOME support" OFF \
+panel "GNOME applet support" OFF \
+2> $tempfile
+
+ retval=$?
+
+ if [ -s $tempfile ]; then
+ set `cat $tempfile`
+ fi
+ rm -f $tempfile
+
+ case $retval in
+ 0) if [ -z "$*" ]; then
+ echo "Nothing selected"
+ fi
+ ;;
+ 1) echo "Cancel pressed."
+ exit 1
+ ;;
+ esac
+fi
+
+${MKDIR} ${WRKDIRPREFIX}${REALCURDIR}
+exec > ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+
+while [ "$1" ]; do
+ case $1 in
+ \"esd\")
+ echo "USE_GNOME+= esound"
+ echo "CONFIGURE_ARGS+= --enable-esd"
+ esd="yes"
+ ;;
+ \"arts\")
+ echo "CONFIGURE_ARGS+= --enable-arts"
+ echo "LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts"
+ ;;
+ \"gnome\")
+ echo "USE_GNOME+= gnomelibs"
+ echo "CONFIGURE_ARGS+= --enable-gnome"
+ ;;
+ \"panel\")
+ echo "USE_GNOME+= gnomepanel"
+ echo "CONFIGURE_ARGS+= --enable-panel"
+ ;;
+ *)
+ echo "Invalid option(s): $1" >&2
+ rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+ exit 1
+ ;;
+ esac
+ shift
+done
+
+if [ -z "${esd}" ]; then
+ echo "CONFIGURE_ARGS+= --disable-esd --without-esd"
+fi