aboutsummaryrefslogtreecommitdiff
path: root/polish/kadu/files/patch-modules-encryption_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'polish/kadu/files/patch-modules-encryption_CMakeLists.txt')
-rw-r--r--polish/kadu/files/patch-modules-encryption_CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/polish/kadu/files/patch-modules-encryption_CMakeLists.txt b/polish/kadu/files/patch-modules-encryption_CMakeLists.txt
new file mode 100644
index 000000000000..ae4b35b7d179
--- /dev/null
+++ b/polish/kadu/files/patch-modules-encryption_CMakeLists.txt
@@ -0,0 +1,14 @@
+--- ./modules/encryption/CMakeLists.txt.orig 2008-10-25 13:29:59.000000000 +0400
++++ ./modules/encryption/CMakeLists.txt 2009-03-14 01:17:21.000000000 +0300
+@@ -38,9 +38,8 @@
+ cmake_policy(SET CMP0003 NEW)
+ endif (COMMAND cmake_policy)
+
+-pkg_search_module (OPENSSL REQUIRED openssl)
+-include_directories (${OPENSSL_INCLUDE_DIRS})
+-link_directories (${OPENSSL_INCLUDE_DIRS})
++find_package (OpenSSL)
++include_directories (${OPENSSL_INCLUDE_DIR})
+
+ add_library (encryption ${encryption} ${SOURCES} ${MOC_FILES})
+ target_link_libraries(encryption ${OPENSSL_LIBRARIES})