aboutsummaryrefslogtreecommitdiff
path: root/polish/sms2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'polish/sms2/Makefile')
-rw-r--r--polish/sms2/Makefile45
1 files changed, 10 insertions, 35 deletions
diff --git a/polish/sms2/Makefile b/polish/sms2/Makefile
index a6842d3bdb1d..d5bf5ce22b2c 100644
--- a/polish/sms2/Makefile
+++ b/polish/sms2/Makefile
@@ -1,48 +1,23 @@
-# Ports collection makefile for: sms
-# Date created: 23 dec 2001
-# Whom: Michal Pasternak <doc@lublin.t1.pl>
+# New ports collection makefile for: sms2
+# Date created: 04 sep 2004
+# Whom: Krzysztof Kowalewski <pyzmen@kam.pl>
#
# $FreeBSD$
#
PORTNAME= sms
-PORTVERSION= 1.9.2m
+PORTVERSION= 2.0.0
CATEGORIES= polish
-MASTER_SITES= http://www.ceti.pl/~miki/komputery/download/sms/
+MASTER_SITES= http://ceti.pl/~miki/komputery/download/sms/
MAINTAINER= ports@FreeBSD.org
COMMENT= Send SMS to cellular phones in Poland (Idea, ERA, Plus)
-WRKSRC= ${WRKDIR}/sms
-USE_GMAKE= yes
-USE_REINPLACE= yes
-REINPLACE_ARGS= -i ""
-MAKE_ARGS= CXX="${CXX}"
-
-.if defined(NOPORTDOCS)
-MAKE_ARGS+= NOPORTDOCS=1
-.endif
-
-.if defined(WITHOUT_ADDRESSBOOK)
-EXTRA_PATCHES+= ${FILESDIR}/noaddressbook.patch
-.else
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
-.endif
-
-MAN1= sms.1 smsaddr.1
-MAN5= smsrc.5
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
+ pcre.0:${PORTSDIR}/devel/pcre \
+ gdbm.3:${PORTSDIR}/databases/gdbm
+BUILD_DEPENDS= ${LOCALBASE}/include/pcre++.h:${PORTSDIR}/devel/pcre++
-post-extract:
- @${FIND} ${WRKSRC} -name CVS | ${XARGS} -n 1 ${RM} -r
-
-post-patch:
- @${REINPLACE_CMD} -e 's,/etc/smsrc,${PREFIX}/etc/smsrc,' \
- ${WRKSRC}/sms.h \
- ${WRKSRC}/README.smsrc
- @${REINPLACE_CMD} -e 's,bash,sh,' \
- ${WRKSRC}/contrib/sms-conf
-
-post-install:
- ${STRIP_CMD} ${PREFIX}/bin/sms
+USE_GMAKE= yes
.include <bsd.port.mk>