aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/barry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/barry/Makefile')
-rw-r--r--ports-mgmt/barry/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/ports-mgmt/barry/Makefile b/ports-mgmt/barry/Makefile
new file mode 100644
index 000000000000..098c01b156f6
--- /dev/null
+++ b/ports-mgmt/barry/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: barry
+# Date created: 19 September 2002
+# Whom: Brad Davis <so14k@so14k.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= barry
+PORTVERSION= 0.5.3
+CATEGORIES= sysutils kde
+MASTER_SITES= http://frerich.ath.cx/barry/
+
+MAINTAINER= so14k@so14k.com
+
+USE_BZIP2= yes
+USE_KDELIBS_VER=3
+MAKE_ENV= QTDIR="${X11BASE}" KDEDIR="${LOCALBASE}" PREFIX="${PREFIX}"
+USE_REINPLACE= yes
+
+pre-build:
+ ${REINPLACE_CMD} "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} .depend)
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS})
+
+.include <bsd.port.mk>