aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/bpm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/bpm/Makefile')
-rw-r--r--ports-mgmt/bpm/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/ports-mgmt/bpm/Makefile b/ports-mgmt/bpm/Makefile
deleted file mode 100644
index 461d08054bea..000000000000
--- a/ports-mgmt/bpm/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# New ports collection makefile for: bpm
-# Date created: 23 July 2004
-# Whom: sethk
-#
-# $FreeBSD$
-#
-
-PORTNAME= bpm
-PORTVERSION= 0.4.1b
-PORTREVISION= 9
-CATEGORIES= sysutils
-MASTER_SITES= http://www.meowfishies.com/code/bpm/
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= sethk@meowfishies.com
-COMMENT= A graphical BSD ports collection manager
-
-RUN_DEPENDS= portupgrade:${PORTSDIR}/sysutils/portupgrade
-
-USE_X_PREFIX= yes
-USE_GNOME= gtk20 desktopfileutils
-USE_REINPLACE= yes
-
-MAKE_ENV+= OSTYPE="${OPSYS}"
-
-SUB_FILES= bpm.desktop
-
-post-patch:
- @${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
- ${REINPLACE_CMD} -e "s|-lintl|-lintl -L${LOCALBASE}/lib|g"
-# GnomeVFS needs pthread; bpm may use GnomeVFS (via GtkFileChooser)
- @${REINPLACE_CMD} -e 's|^CFLAGS+=|& ${PTHREAD_CFLAGS}|; \
- s|^LDLIBS+=|& ${PTHREAD_LIBS}|' ${WRKSRC}/src/Makefile
-
-post-install:
- ${INSTALL_DATA} ${WRKDIR}/bpm.desktop ${PREFIX}/share/applications/bpm.desktop
- @-update-desktop-database
-
-.include <bsd.port.mk>