aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/p5-FreeBSD-Portindex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/p5-FreeBSD-Portindex/Makefile')
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/Makefile b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
index 845cbbdf4de9..338f61b9e8cd 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= FreeBSD-Portindex
-PORTVERSION= 3.2
-PORTREVISION= 1
+PORTVERSION= 3.3
CATEGORIES= ports-mgmt perl5
MASTER_SITES= http://www.infracaninophile.co.uk/portindex/
PKGNAMEPREFIX= p5-
@@ -11,7 +10,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= matthew@FreeBSD.org
COMMENT= Incremental FreeBSD ports INDEX file generation
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
BUILD_DEPENDS= p5-BerkeleyDB>0:${PORTSDIR}/databases/p5-BerkeleyDB
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -21,14 +20,12 @@ NO_ARCH= yes
# GraphViz not required for portindex to run or generate GraphViz
# format output: this is only needed to render the output on the same
# machine.
-OPTIONS_DEFINE= GRAPHVIZ
+OPTIONS_DEFINE= GRAPHVIZ
GRAPHVIS_DESCR= Add GraphViz run-time dependency
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGRAPHVIZ}
-RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
-.endif
+GRAPHVIZ_RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
USES+= perl5
USE_XZ= yes
@@ -45,8 +42,7 @@ SUB_FILES+= pkg-install
SUB_LIST+= CACHE_DIR=${CACHE_DIR} \
CACHE_OWNER=${CACHE_OWNER} \
CACHE_GROUP=${CACHE_GROUP} \
- CACHE_MODE=${CACHE_MODE} \
- CFG_FILE=${PREFIX}/etc/portindex.cfg
+ CACHE_MODE=${CACHE_MODE}
post-install: install-conf