aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg_replace/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/pkg_replace/Makefile')
-rw-r--r--ports-mgmt/pkg_replace/Makefile29
1 files changed, 25 insertions, 4 deletions
diff --git a/ports-mgmt/pkg_replace/Makefile b/ports-mgmt/pkg_replace/Makefile
index f7f60f5d5c57..492595df4876 100644
--- a/ports-mgmt/pkg_replace/Makefile
+++ b/ports-mgmt/pkg_replace/Makefile
@@ -3,16 +3,14 @@
PORTNAME= pkg_replace
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
MASTER_SITE_SUBDIR=portutil/22116
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kdeguchi@sz.tokoha-u.ac.jp
COMMENT= Utility for upgrading installed packages
-DEPRECATED= Abandoned upstream, does not support pkgng. Consider using ports-mgmt/portmaster, ports-mgmt/portupgrade or pkgng
-EXPIRATION_DATE= 2013-12-31
-
USE_BZIP2= YES
MAKE_ARGS= PREFIX="${PREFIX}" \
PORTSDIR="${PORTSDIR}" PKG_DBDIR="${PKG_DBDIR}"
@@ -20,4 +18,27 @@ MAKE_ARGS= PREFIX="${PREFIX}" \
MAN1= pkg_replace.1
MANCOMPRESSED= maybe
+OPTIONS_DEFINE= ZSH
+
+.if empty(WITH_PKGNG)
+OPTIONS_DEFINE+= PKGDB_FIX
+PKGDB_FIX_DESC= Fixing tool of installed package dependencies
+.endif
+
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPKGDB_FIX}
+MAN1+= pkgdb_fix.1
+.endif
+
+post-patch:
+.if ${PORT_OPTIONS:MPKGDB_FIX}
+ @${REINPLACE_CMD} -e 's/pkg_replace/pkg_replace pkgdb_fix/;' ${WRKSRC}/sbin/Makefile
+.endif
+.if !${PORT_OPTIONS:MZSH}
+ @${REINPLACE_CMD} -e 's/^ sbin \\$$/ sbin/;s/^ share$$//;' ${WRKSRC}/Makefile
+.endif
+
.include <bsd.port.mk>