aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/pkg_trackinst/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/pkg_trackinst/Makefile')
-rw-r--r--ports-mgmt/pkg_trackinst/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/ports-mgmt/pkg_trackinst/Makefile b/ports-mgmt/pkg_trackinst/Makefile
new file mode 100644
index 000000000000..ebb9a7f7e0df
--- /dev/null
+++ b/ports-mgmt/pkg_trackinst/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pkg_trackinst
+# Date created: 3 May 2005
+# Whom: Hye-Shik Chang <perky@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= pkg_trackinst
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://people.freebsd.org/~perky/distfiles/
+
+MAINTAINER= perky@FreeBSD.org
+COMMENT= PkgDB/pkg-plist generator by tracking installation
+
+RUN_DEPENDS= ${LOCALBASE}/lib/installwatch.so:${PORTSDIR}/sysutils/installwatch
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501105
+IGNORE= requires dynamically-linked base programs
+.endif
+
+.include <bsd.port.post.mk>