aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portaudit-db/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/portaudit-db/Makefile')
-rw-r--r--ports-mgmt/portaudit-db/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/ports-mgmt/portaudit-db/Makefile b/ports-mgmt/portaudit-db/Makefile
deleted file mode 100644
index 81c625ce651e..000000000000
--- a/ports-mgmt/portaudit-db/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# New ports collection makefile for: portaudit-db
-# Date created: 12 Jun 2004
-# Whom: Oliver Eikemeier
-#
-# $FreeBSD$
-#
-
-PORTNAME= portaudit-db
-PORTVERSION= 0.2.3
-CATEGORIES= security
-DISTFILES=
-
-MAINTAINER= eik@FreeBSD.org
-COMMENT= Creates a portaudit database from a current ports tree
-
-RUN_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-
-DEPENDS_ARGS+= WITHOUT_PYTHON=yes
-
-DATABASEDIR?= ${AUDITFILE:H}
-
-PLIST_SUB+= DATABASEDIR="${DATABASEDIR}"
-
-SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
- -e "s|%%DATADIR%%|${DATADIR}|g" \
- -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
- -e "s|%%PORTSDIR%%|${PORTSDIR}|g" \
- -e "s|%%PORTVERSION%%|${PORTVERSION}|g" \
- -e "s|%%DATABASEDIR%%|${DATABASEDIR}|g"
-
-do-build:
- @for f in packaudit.sh packaudit.conf; do \
- ${SED} ${SED_SCRIPT} "${FILESDIR}/$$f" > "${WRKDIR}/$$f"; \
- done
-
-do-install:
- @${INSTALL_SCRIPT} ${WRKDIR}/packaudit.sh ${PREFIX}/bin/packaudit
- @${INSTALL_DATA} ${WRKDIR}/packaudit.conf ${PREFIX}/etc/packaudit.conf.sample
- @${MKDIR} ${DATADIR}
- @${INSTALL_SCRIPT} ${FILESDIR}/portaudit2vuxml.awk ${DATADIR}
- @${INSTALL_DATA} ${FILESDIR}/vuxml2html.xslt ${FILESDIR}/vuxml2portaudit.xslt ${DATADIR}
- @${MKDIR} ${DATABASEDIR}
-
-.include <bsd.port.mk>