aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portmanager/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/portmanager/Makefile')
-rw-r--r--ports-mgmt/portmanager/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index e8f1ce188562..2b088d09a491 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portmanager
-PORTVERSION= 0.2.2
+PORTVERSION= 0.2.3
PORTREVISION= 0
#-----------------------------------------
#for local use, remove before submitting PR
@@ -14,8 +14,9 @@ CATEGORIES= sysutils
#CATEGORIES= local/sysutils
#VALID_CATEGORIES+= ${CATEGORIES} # for FreeBSD to accept our local category
#-----------------------------------------
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= portmanager
+#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+#MASTER_SITE_SUBDIR= portmanager
+MASTER_SITES= http://www.pkix.net/mirror/sf.net/
MAINTAINER= reso3w83@verizon.net
COMMENT= FreeBSD port management software
@@ -27,6 +28,11 @@ BUILD_DEPENDS= autoheader259:${PORTSDIR}/devel/autoconf259 \
.endif
MAN1= portmanager.1
+MAN3= libMG.3 \
+ MGdbCreate.3 \
+ MGdbGetRecordQty.3 \
+ MGdbGoTop.3 \
+ MGdbSeek.3
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -34,18 +40,14 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
# Need INSTALL_TARGET to install /usr/local/etc/portmanager/pm-020.conf.SAMPLE
-INSTALL_TARGET= install info
+INSTALL_TARGET= install info
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|0.2.2|${PORTVERSION}_${PORTREVISION}|g ; \
+ s|0.2.3|${PORTVERSION}_${PORTREVISION}|g ; \
s|%%PORTSDIR%%|${PORTSDIR}|g ; \
s|%%PKG_DBDIR%%|${PKG_DBDIR}|g' ${WRKSRC}/libPMGR/src/libPMGR.h
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|%%PORTSDIR%%|${PORTSDIR}|g ; \
- s|%%PKG_DBDIR%%|${PKG_DBDIR}|g' ${WRKSRC}/libPMGR/src/PMGRrMakeDescribe.c
-
# Only way to get WITH_DEBUG build dependencies handled prior to reconfiguring
# is to use post-configure <sigh>
post-configure: