aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portmanager/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/portmanager/Makefile')
-rw-r--r--ports-mgmt/portmanager/Makefile45
1 files changed, 22 insertions, 23 deletions
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index 2b088d09a491..85c6d6edfc01 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= portmanager
-PORTVERSION= 0.2.3
+PORTVERSION= 0.2.4
PORTREVISION= 0
#-----------------------------------------
#for local use, remove before submitting PR
@@ -14,9 +14,8 @@ CATEGORIES= sysutils
#CATEGORIES= local/sysutils
#VALID_CATEGORIES+= ${CATEGORIES} # for FreeBSD to accept our local category
#-----------------------------------------
-#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-#MASTER_SITE_SUBDIR= portmanager
-MASTER_SITES= http://www.pkix.net/mirror/sf.net/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= portmanager
MAINTAINER= reso3w83@verizon.net
COMMENT= FreeBSD port management software
@@ -30,6 +29,7 @@ BUILD_DEPENDS= autoheader259:${PORTSDIR}/devel/autoconf259 \
MAN1= portmanager.1
MAN3= libMG.3 \
MGdbCreate.3 \
+ MGdbDelete.3 \
MGdbGetRecordQty.3 \
MGdbGoTop.3 \
MGdbSeek.3
@@ -40,11 +40,11 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
# Need INSTALL_TARGET to install /usr/local/etc/portmanager/pm-020.conf.SAMPLE
-INSTALL_TARGET= install info
+INSTALL_TARGET= install info
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|0.2.3|${PORTVERSION}_${PORTREVISION}|g ; \
+ s|0.2.4|${PORTVERSION}_${PORTREVISION}|g ; \
s|%%PORTSDIR%%|${PORTSDIR}|g ; \
s|%%PKG_DBDIR%%|${PKG_DBDIR}|g' ${WRKSRC}/libPMGR/src/libPMGR.h
@@ -58,21 +58,20 @@ post-configure:
.endif
post-install:
- @${ECHO} "******************************************************"
- @${ECHO} "* to compile with debug support try: *"
- @${ECHO} "* make WITH_DEBUG=yes install clean *"
- @${ECHO} "* *"
- @${ECHO} "* portmanager commands: *"
- @${ECHO} "* *"
- @${ECHO} "* portmanager -h brief help screen *"
- @${ECHO} "* -s list status of installed ports *"
- @${ECHO} "* -u upgrade installed ports *"
- @${ECHO} "* *"
- @${ECHO} "* see man portmanager(1) or *"
- @${ECHO} "* /usr/local/etc/portmanager/pm-020.conf *"
- @${ECHO} "* for config options *"
- @${ECHO} "* *"
- @${ECHO} "* all feedback is welcome, send to: *"
- @${ECHO} "* Michael C. Shultz reso3w83@verizon.net *"
- @${ECHO} "******************************************************"
+ @${ECHO} "***********************************************************************"
+ @${ECHO} "* to compile with debug support try: *"
+ @${ECHO} "* *"
+ @${ECHO} "* make WITH_DEBUG=yes install clean *"
+ @${ECHO} "* *"
+ @${ECHO} "* to upgrade ports example: *"
+ @${ECHO} "* *"
+ @${ECHO} "* portmanager -u -ip editors/nedit editors/openoffice *"
+ @${ECHO} "* *"
+ @${ECHO} "* upgrades evrything except nedit, open office and their dependencies *"
+ @${ECHO} "* *"
+ @${ECHO} "* see man portmanager(1) for more information *"
+ @${ECHO} "* *"
+ @${ECHO} "* all feedback is welcome, send to: *"
+ @${ECHO} "* Michael C. Shultz reso3w83@verizon.net *"
+ @${ECHO} "***********************************************************************"
.include <bsd.port.mk>