aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portrac/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/portrac/Makefile')
-rw-r--r--ports-mgmt/portrac/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/ports-mgmt/portrac/Makefile b/ports-mgmt/portrac/Makefile
index e3ea27681b1e..33971eedac47 100644
--- a/ports-mgmt/portrac/Makefile
+++ b/ports-mgmt/portrac/Makefile
@@ -11,7 +11,6 @@ COMMENT= Simple GUI tool for tracking port updates
LICENSE= BSD2CLAUSE
-BROKEN_FreeBSD_9= does not build (lacking c++11 support)
BROKEN_sparc64= fails to compile: error in C++ code
PLIST_FILES= bin/portrac \
@@ -19,6 +18,9 @@ PLIST_FILES= bin/portrac \
share/portrac/up-to-date.png \
share/portrac/updates-available.png
+# Unhide std::to_string() to fix build with GCC (ports/193528)
+CXXFLAGS= -D_GLIBCXX_USE_C99
+
USES= compiler:c++11-lib qmake tar:bzip2
USE_CXXSTD= c++11
USE_QT5= widgets buildtools_build