aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/poudriere-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/poudriere-devel/Makefile')
-rw-r--r--ports-mgmt/poudriere-devel/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/ports-mgmt/poudriere-devel/Makefile b/ports-mgmt/poudriere-devel/Makefile
index 312eb22fac5e..485b4bb79539 100644
--- a/ports-mgmt/poudriere-devel/Makefile
+++ b/ports-mgmt/poudriere-devel/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= poudriere
-DISTVERSION= 3.2.99.20180129
+DISTVERSION= 3.2.99.20180202
PORTREVISION= 0
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/bdrewery/${PORTNAME}/ \
@@ -18,19 +18,22 @@ CONFLICTS_INSTALL= poudriere-[0-9]*
USE_GITHUB= yes
GH_ACCOUNT= freebsd
-GH_TAGNAME= 3.2.4-119-g0da10c68
+GH_TAGNAME= 3.2.4-148-g1f555127
#DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${GH_TAGNAME}
GNU_CONFIGURE= yes
ETCDIR= ${PREFIX}/etc/poudriere.d
-OPTIONS_DEFINE= ZSH QEMU EXAMPLES
-OPTIONS_DEFAULT=ZSH
+OPTIONS_DEFINE= DIALOG4PORTS EXAMPLES QEMU ZSH
+OPTIONS_DEFAULT=DIALOG4PORTS ZSH
OPTIONS_SUB= yes
RUN_DEPENDS+= ca_root_nss>=0:security/ca_root_nss
RUN_DEPENDS+= freebsd-release-manifests>0:misc/freebsd-release-manifests
+DIALOG4PORTS_DESC= Install dialog4ports (necessary for options command) as runtime dependency
+DIALOG4PORTS_RUN_DEPENDS= dialog4ports>0:ports-mgmt/dialog4ports
+
QEMU_DESC= Add qemu-user-static to compile ports for non-x86 architectures
QEMU_RUN_DEPENDS= qemu-user-static>0:emulators/qemu-user-static