aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/poudriere/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/poudriere/Makefile')
-rw-r--r--ports-mgmt/poudriere/Makefile47
1 files changed, 2 insertions, 45 deletions
diff --git a/ports-mgmt/poudriere/Makefile b/ports-mgmt/poudriere/Makefile
index f1f9d3845836..8115cd528349 100644
--- a/ports-mgmt/poudriere/Makefile
+++ b/ports-mgmt/poudriere/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= poudriere
-PORTVERSION= 3.0.15
+PORTVERSION= 3.0.16
CATEGORIES= ports-mgmt
MASTER_SITES= http://fossil.etoilebsd.net/poudriere/tarball/ \
LOCAL/bdrewery/${PORTNAME}/
@@ -13,57 +13,14 @@ COMMENT= Port build and test system
LICENSE= BSD2CLAUSE
OPTIONS_DEFINE= ZSH
+OPTIONS_SUB= yes
CONFLICTS_INSTALL= poudriere-devel
-PLIST_FILES= etc/poudriere.conf.sample \
- bin/poudriere \
- man/man8/poudriere.8.gz \
- libexec/poudriere/cpdup \
- libexec/poudriere/dirwatch \
- libexec/poudriere/dirempty \
- libexec/poudriere/make_index \
- share/poudriere/awk/dependency_loop.awk \
- share/poudriere/awk/humanize.awk \
- share/poudriere/awk/json.awk \
- share/poudriere/awk/make_index.awk \
- share/poudriere/awk/siginfo_buildtime.awk \
- share/poudriere/html/index.html \
- share/poudriere/html/jquery-1.9.1.min.js \
- share/poudriere/html/logo.jpg \
- share/poudriere/html/poudriere.css \
- share/poudriere/html/poudriere.js \
- share/poudriere/bulk.sh \
- share/poudriere/clean.sh \
- share/poudriere/common.sh \
- share/poudriere/daemon.sh \
- share/poudriere/distclean.sh \
- share/poudriere/jail.sh \
- share/poudriere/options.sh \
- share/poudriere/ports.sh \
- share/poudriere/queue.sh \
- share/poudriere/status.sh \
- share/poudriere/testport.sh
-
-PLIST_DIRS= libexec/poudriere \
- share/poudriere/awk \
- share/poudriere/html \
- share/poudriere
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MZSH}
-PLIST_FILES+= share/zsh/site-functions/_poudriere
-PLIST_DIRSTRY+= share/zsh/site-functions
-PLIST_DIRSTRY+= share/zsh/
-.endif
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/poudriere/*
-.if ${PORT_OPTIONS:MZSH}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
@${INSTALL_DATA} ${WRKSRC}/zsh-completions \
${STAGEDIR}${PREFIX}/share/zsh/site-functions/_poudriere
-.endif
.include <bsd.port.mk>