aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/py-pytoport/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/py-pytoport/Makefile')
-rw-r--r--ports-mgmt/py-pytoport/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/ports-mgmt/py-pytoport/Makefile b/ports-mgmt/py-pytoport/Makefile
new file mode 100644
index 000000000000..3ecd35845425
--- /dev/null
+++ b/ports-mgmt/py-pytoport/Makefile
@@ -0,0 +1,25 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+# $FreeBSD$
+
+PORTNAME= pytoport
+PORTVERSION= 0.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= ports-mgmt python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brendan+freebsd@bbqsrc.net
+COMMENT= Generate FreeBSD ports from Python modules on PyPI
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-licensee>0:${PORTSDIR}/devel/rubygem-licensee
+
+USE_GITHUB= yes
+GH_ACCOUNT= freebsd
+GH_PROJECT= pytoport
+
+USES= python:3.2+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>