aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/tinderbox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/tinderbox/Makefile')
-rw-r--r--ports-mgmt/tinderbox/Makefile63
1 files changed, 0 insertions, 63 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
deleted file mode 100644
index 6c2fc05b6588..000000000000
--- a/ports-mgmt/tinderbox/Makefile
+++ /dev/null
@@ -1,63 +0,0 @@
-# Ports collection makefile for: misc/tinderbox
-# Whom: Edwin Groothuis <edwin@mavetju.org>
-# Date created: 31 december 2005
-#
-# $FreeBSD$
-
-PORTNAME= tinderbox
-PORTVERSION= 2.3.0
-PORTREVISION= 1
-CATEGORIES= misc
-MASTER_SITES= http://tinderbox.marcuscom.com/
-
-MAINTAINER= andreas@syndrom23.de
-COMMENT= Port build tinderbox system
-
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
- cvsup:${PORTSDIR}/net/cvsup-without-gui
-
-OPTIONS= PGSQL "With pgsql" On \
- MYSQL "With mysql" Off
-
-NO_BUILD= yes
-USE_APACHE= yes
-SUB_FILES= pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITHOUT_PGSQL) && defined(WITHOUT_MYSQL)
-BROKEN= Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL
-.endif
-
-USE_PHP= session
-
-.if defined(WITH_PGSQL)
-USE_PGSQL= yes
-USE_PHP+= pgsql
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
-.endif
-
-.if defined(WITH_MYSQL)
-USE_PHP+= mysql
-USE_MYSQL= yes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
-.endif
-
-.include "${PORTSDIR}/Mk/bsd.php.mk"
-
-post-extract:
-.for f in inc_ds.php inc_tinderbox.php
- ${MV} ${WRKSRC}/www-exp/${f} ${WRKSRC}/www-exp/${f}-dist
-.endfor
-
-do-install:
- ${MKDIR} ${PREFIX}/tinderbox/scripts
- ${CP} -R ${WRKSRC}/* ${PREFIX}/tinderbox/scripts
-
-post-install:
- ${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>