aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile4
-rw-r--r--ports-mgmt/portupgrade/Makefile4
2 files changed, 2 insertions, 6 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 8131c536495b..4a6d28c65600 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -25,7 +25,6 @@ USE_RUBY= yes
USE_RUBY_FEATURES= optparse ruby18
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
-LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -55,7 +54,6 @@ INSTALL_TARGET+= install-doc
.endif
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
.if defined(WITH_BDB4)
# For PKG_DBDRIVER={bdb_btree,bdb_hash}
@@ -84,7 +82,7 @@ pre-extract:
@exit 1
.endif
-post-install: install-ldconfig-file
+post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
fi
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 549455c220ef..db0dfd945758 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -26,7 +26,6 @@ USE_RUBY= yes
USE_RUBY_FEATURES= optparse ruby18
USE_LDCONFIG= ${PREFIX}/lib/compat/pkg
-LDCONFIG_DIRS= %%PREFIX%%/lib/compat/pkg
MAKE_ARGS= PREFIX="${PREFIX}" RUBY="${RUBY}"
@@ -56,7 +55,6 @@ INSTALL_TARGET+= install-doc
.endif
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/misc/ldconfig_compat/bsd.ldconfig.mk"
.if defined(WITH_BDB4)
# For PKG_DBDRIVER={bdb_btree,bdb_hash}
@@ -85,7 +83,7 @@ pre-extract:
@exit 1
.endif
-post-install: install-ldconfig-file
+post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \
fi