aboutsummaryrefslogtreecommitdiff
path: root/print/a2ps43-letter
diff options
context:
space:
mode:
Diffstat (limited to 'print/a2ps43-letter')
-rw-r--r--print/a2ps43-letter/Makefile110
-rw-r--r--print/a2ps43-letter/distinfo2
-rw-r--r--print/a2ps43-letter/files/patch-aa32
-rw-r--r--print/a2ps43-letter/files/patch-ab78
-rw-r--r--print/a2ps43-letter/files/patch-ac12
-rw-r--r--print/a2ps43-letter/pkg-plist175
-rw-r--r--print/a2ps43-letter/scripts/configure11
7 files changed, 179 insertions, 241 deletions
diff --git a/print/a2ps43-letter/Makefile b/print/a2ps43-letter/Makefile
index a4dc7df13a93..18cc0f75736e 100644
--- a/print/a2ps43-letter/Makefile
+++ b/print/a2ps43-letter/Makefile
@@ -1,75 +1,75 @@
# New ports collection makefile for: a2ps
-# Version required: 4.9.7
-# Date created: 18 August 1997
-# Whom: Chuck Robey (chuckr@freebsd.org)
+# Version required: 4.3
+# Date created: 6 November 1994
+# Whom: jmz & David O'Brien (obrien@cs.ucdavis.edu)
#
-# $Id: Makefile,v 1.9 1997/08/19 03:43:55 chuckr Exp $
+# $Id: Makefile,v 1.8 1996/11/17 08:44:16 obrien Exp $
#
DISTNAME= a2ps
-PKGNAME= a2ps-${PAPERSIZE}-4.9.8
+PKGNAME= a2ps-${PAPERSIZE}-4.3
CATEGORIES= print
-MASTER_SITES= http://www-inf.enst.fr/~demaille/ftp/a2ps/
-DISTFILES= a2ps-4.9.8.tar.gz
+MASTER_SITES= ftp://ftp.imag.fr/archive/postscript/format.translators/
+DISTFILES= a2ps.V4.3.tar.gz
-MAINTAINER= chuckr@FreeBSD.org
+MAINTAINER= jmz@FreeBSD.org
-WRKSRC= $(WRKDIR)/$(DISTNAME)-4.9.8
-GNU_CONFIGURE= yes
-MAN1= a2ps.1 ogonkify.1
+MAKE_FLAGS?= WIDTH=${WIDTH} HEIGHT=${HEIGHT} A4_PAPERSIZE=${A4_PAPERSIZE} -f
+NO_WRKSUBDIR= yes
+MAN1= a2ps.1
-PAPERSIZE?=
-STRIP=
-CONFIGURE_ARGS= --with-medium=$(PAPERSIZE)
+letter::
+ ${MAKE} PAPERSIZE=letter
+letter-install::
+ ${MAKE} PAPERSIZE=letter install
-Letter::
- $(MAKE) PAPERSIZE=Letter
+a4::
+ ${MAKE} PAPERSIZE=a4
-letter::
- $(MAKE) PAPERSIZE=Letter
+a4-install::
+ ${MAKE} PAPERSIZE=a4 install
-Letterdj::
- $(MAKE) PAPERSIZE=Letterdj
-letterdj::
- $(MAKE) PAPERSIZE=Letterdj
+.if !defined(PAPERSIZE)
+PAPERSIZE=a4
+WIDTH=8.27
+HEIGHT=11.64
+A4_PAPERSIZE=1
+PAPERSIZE_UNSPECIFIED= yes
+.elif ${PAPERSIZE} == A4 || ${PAPERSIZE} == a4
+PAPERSIZE=a4
+WIDTH=8.27
+HEIGHT=11.64
+A4_PAPERSIZE=1
+.elif ${PAPERSIZE} == letter || ${PAPERSIZE} == LETTER
+PAPERSIZE=letter
+WIDTH=8.5
+HEIGHT=11.0
+A4_PAPERSIZE=0
+.else
+PAPERSIZE_INVALID= yes
+.endif # not defined PAPERSIZE
-A4::
- $(MAKE) PAPERSIZE=A4
-a4::
- $(MAKE) PAPERSIZE=A4
+pre-fetch:
+.if defined(PAPERSIZE_UNSPECIFIED)
+ @echo "Defaulting to ${PAPERSIZE} sized paper."
+ @echo ""
+ @echo "Set the environment variable PAPERSIZE if you want to use other sizes."
+ @echo "Possible values are: A4 (default) or letter"
+.elif defined(PAPERSIZE_INVALID)
+ @echo "Error: invalid value for PAPERSIZE: \"${PAPERSIZE}\""
+ @echo "Possible values are: A4 (default) or letter"
+ @/usr/bin/false
+.endif
-pre-build:
- /usr/bin/touch $(WRKSRC)/doc/*.info
- /usr/bin/touch $(WRKSRC)/doc/*.dvi
+pre-install:
+ @${MKDIR} ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/man/man1
+ @(cd ${WRKSRC}; make install.man)
-pre-configure:
-.if empty(PAPERSIZE)
- @echo
- @echo "PAPERSIZE not specified."
- @echo
- @echo "Must specify PAPERSIZE as one of A4, Letter, or Letterdj, either"
- @echo "using setenv, or via Makefile targets of the same name. Note"
- @echo "that each PAPERSIZE has a leading capital letter, and Letterdj"
- @echo "allows a slightly larger margins for DeskJets."
- @false
-.elif $(PAPERSIZE)!=A4 && $(PAPERSIZE)!=Letter && $(PAPERSIZE)!=Letterdj
- @echo
- @echo "PAPERSIZE incorrect value: $(PAPERSIZE)."
- @echo
- @echo "Must specify PAPERSIZE as one of A4, Letter, or Letterdj, either"
- @echo "using setenv, or via Makefile targets of the same name. Note"
- @echo "that each PAPERSIZE has a leading capital letter, and Letterdj"
- @echo "allows a slightly larger margins for DeskJets."
- @false
-.endif
- echo $(PAPERSIZE) > $(WRKDIR)/.media
+post-install:
+ strip ${PREFIX}/bin/a2ps
.include <bsd.port.mk>
-
-.if exists($(WRKDIR)/.media)
-PAPERSIZE=
-PAPERSIZE!= cat $(WRKDIR)/.media
-.endif
diff --git a/print/a2ps43-letter/distinfo b/print/a2ps43-letter/distinfo
index 60fe777a76fd..ae227f43edf0 100644
--- a/print/a2ps43-letter/distinfo
+++ b/print/a2ps43-letter/distinfo
@@ -1 +1 @@
-MD5 (a2ps-4.9.8.tar.gz) = f03cbe4ce07942974279be125b2b9e02
+MD5 (a2ps.V4.3.tar.gz) = d3ae591323f0ece28bf3f3bc35f5799f
diff --git a/print/a2ps43-letter/files/patch-aa b/print/a2ps43-letter/files/patch-aa
index 256b4c9e0870..6e66394132e1 100644
--- a/print/a2ps43-letter/files/patch-aa
+++ b/print/a2ps43-letter/files/patch-aa
@@ -1,11 +1,23 @@
---- doc/Makefile.in.orig Tue Sep 30 12:06:45 1997
-+++ doc/Makefile.in Fri Oct 10 19:19:27 1997
-@@ -147,7 +147,7 @@
- default: all
+--- Makefile.orig Mon Feb 14 07:09:33 1994
++++ Makefile Thu May 16 19:20:50 1996
+@@ -29,12 +29,16 @@
+ D =.
+ O =.
- .SUFFIXES:
--.SUFFIXES: .dvi .info .ps .texi .texinfo
-+#.SUFFIXES: .dvi .info .ps .texi .texinfo
- $(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
- cd $(top_srcdir) && $(AUTOMAKE) --gnu --include-deps doc/Makefile
-
+-BINDIR =/usr/local/bin
++##BINDIR =/usr/local/bin
++BINDIR = $(PREFIX)/bin
+
+-MANDIR =/usr/man/mann
+-MANEXT =n
++##MANDIR =/usr/man/mann
++##MANEXT =n
++MANEXT = 1
++MANDIR = $(PREFIX)/man/man$(MANEXT)
+
+-CFLAGS = -DBSD -O -DLPR_PRINT
++##CFLAGS = -DBSD -O -DLPR_PRINT
++CFLAGS = -DBSD -O -DWIDTH=$(WIDTH) -DHEIGHT=$(HEIGHT) -DA4_PAPERSIZE=$(A4_PAPERSIZE)
+ # Default values for HEIGHT, WIDTH, MARGIN and DIR_SEP (11.64, 8.27, 1.2, '/').
+ # Default values for LPR_COMMAND and LPR_OPT ("lpr", "-l")
+ # No values for TWOSIDED_DFLT, ONESIDED and TWOSIDED
diff --git a/print/a2ps43-letter/files/patch-ab b/print/a2ps43-letter/files/patch-ab
new file mode 100644
index 000000000000..22d4155b8b9b
--- /dev/null
+++ b/print/a2ps43-letter/files/patch-ab
@@ -0,0 +1,78 @@
+--- a2ps.c.orig Tue Feb 15 01:14:59 1994
++++ a2ps.c Thu May 16 19:04:15 1996
+@@ -164,12 +164,17 @@
+ /*
+ * Default page dimensions
+ */
++#define USA_WIDTH 8.5
++#define USA_HEIGHT 11.0
++#define A4_WIDTH 8.27
++#define A4_HEIGHT 11.64
++
+ #ifndef WIDTH
+-#define WIDTH 8.27
++#define WIDTH A4_WIDTH
+ #endif
+
+ #ifndef HEIGHT
+-#define HEIGHT 11.64
++#define HEIGHT A4_HEIGHT
+ #endif
+
+ #ifndef MARGIN
+@@ -362,6 +367,8 @@
+ /*
+ * Sheet dimensions
+ */
++double paper_height = HEIGHT; /* Paper height */
++double paper_width = WIDTH; /* Paper width */
+ double page_height = HEIGHT; /* Paper height */
+ double page_width = WIDTH; /* Paper width */
+
+@@ -382,6 +389,11 @@
+ fprintf(stderr,"pos. = -#num\t\tnumber of copies to print\n");
+ fprintf(stderr," -1\t\tone page per sheet\n");
+ fprintf(stderr," -2\t\tTWIN PAGES per sheet\n");
++#if A4_PAPERSIZE == 1
++ fprintf(stderr," -a\t\tUse USA paper size (8.5\" x 11\")\n");
++#else
++ fprintf(stderr," -a\t\tUse A4 paper size (21cm x 29.56cm (8.27\" x 11.64\"))\n");
++#endif
+ fprintf(stderr," -d\t-nd\tprint (DON'T PRINT) current date at the bottom\n");
+ fprintf(stderr," -Fnum\t\tfont size, num is a float number\n");
+ fprintf(stderr," -Hstr\t\tuse str like header title for subsequent files\n");
+@@ -464,6 +476,12 @@
+ usage(EXIT_FAILURE);
+ interpret = TRUE;
+ break;
++ case 'a': /* American paper sizes */
++#if defined(USA_HEIGHT) && defined(USA_WIDTH)
++ paper_height = USA_HEIGHT;
++ paper_width = USA_WIDTH;
++# endif
++ break;
+ case 'n':
+ if (arg[2] == NUL)
+ return;
+@@ -1471,8 +1489,8 @@
+ printf("\n%% Initialize page description variables.\n");
+ printf("/x0 0 def\n");
+ printf("/y0 0 def\n");
+- printf("/sh %g inch def\n", (double)HEIGHT);
+- printf("/sw %g inch def\n", (double)WIDTH);
++ printf("/sh %g inch def\n", (double)paper_height);
++ printf("/sw %g inch def\n", (double)paper_width);
+ printf("/margin %g inch def\n", (double)MARGIN);
+ printf("/rm margin 3 div def\n");
+ printf("/lm margin 2 mul 3 div def\n");
+@@ -1794,8 +1812,8 @@
+ /* Initialize variables not depending of positional options */
+ landscape = twinpages = -1; /* To force format switching */
+ fontsize = -1.0; /* To force fontsize switching */
+- page_height = (double)(HEIGHT - MARGIN) * PIXELS_INCH;
+- page_width = (double)(WIDTH - MARGIN) * PIXELS_INCH;
++ page_height = (double)(paper_height - MARGIN) * PIXELS_INCH;
++ page_width = (double)(paper_width - MARGIN) * PIXELS_INCH;
+
+ /* Postcript prologue printing */
+ print_prologue();
diff --git a/print/a2ps43-letter/files/patch-ac b/print/a2ps43-letter/files/patch-ac
new file mode 100644
index 000000000000..188afff0902b
--- /dev/null
+++ b/print/a2ps43-letter/files/patch-ac
@@ -0,0 +1,12 @@
+--- a2ps.1.orig Tue Feb 15 01:15:16 1994
++++ a2ps.1 Fri Apr 5 00:00:01 1996
+@@ -155,6 +155,9 @@
+ is the number of copies desired of each file named. By default, you get
+ only one copy.
+ .TP 0.6i
++.B -a
++Use the American paper size (8.5" x 11") as the basis for all calculations.
++.TP 0.6i
+ .B -d
+ Print the current date and time at the bottom of the page. This option
+ is affected by the no surrounding border and the no header options.
diff --git a/print/a2ps43-letter/pkg-plist b/print/a2ps43-letter/pkg-plist
index 7187e17c164d..89c69615c441 100644
--- a/print/a2ps43-letter/pkg-plist
+++ b/print/a2ps43-letter/pkg-plist
@@ -1,177 +1,2 @@
-share/a2ps/ps/base.ps
-share/a2ps/ps/bw.pro
-share/a2ps/ps/gray.pro
-share/a2ps/ps/color.pro
-share/a2ps/ps/gray2.pro
-share/a2ps/ps/ehandler.ps
-share/a2ps/ps/a2ps.hdr
-share/a2ps/ps/color.hdr
-share/a2ps/afm/Courier-Bold-Ogonki.afm
-share/a2ps/afm/Courier-BoldOblique-Ogonki.afm
-share/a2ps/afm/Courier-Oblique-Ogonki.afm
-share/a2ps/afm/Courier-Ogonki.afm
-share/a2ps/afm/Helvetica-Bold-Ogonki.afm
-share/a2ps/afm/Helvetica-BoldOblique-Ogonki.afm
-share/a2ps/afm/Helvetica-Oblique-Ogonki.afm
-share/a2ps/afm/Helvetica-Ogonki.afm
-share/a2ps/afm/Times-Bold-Ogonki.afm
-share/a2ps/afm/Times-BoldItalic-Ogonki.afm
-share/a2ps/afm/Times-Italic-Ogonki.afm
-share/a2ps/afm/Times-Roman-Ogonki.afm
-share/a2ps/afm/colle10.afm
-share/a2ps/afm/colle8.afm
-share/a2ps/afm/colle9.afm
-share/a2ps/afm/crr35__i.afm
-share/a2ps/afm/crr36__i.afm
-share/a2ps/afm/crr55__i.afm
-share/a2ps/afm/crr56__i.afm
-share/a2ps/afm/fonts.map
-share/a2ps/afm/make_fonts_map.sh
-share/a2ps/afm/pbkd.afm
-share/a2ps/afm/pbkdi.afm
-share/a2ps/afm/pbkl.afm
-share/a2ps/afm/pbkli.afm
-share/a2ps/afm/pcrb.afm
-share/a2ps/afm/pcrbo.afm
-share/a2ps/afm/pcrr.afm
-share/a2ps/afm/pcrro.afm
-share/a2ps/afm/phvb.afm
-share/a2ps/afm/phvbo.afm
-share/a2ps/afm/phvbon.afm
-share/a2ps/afm/phvbrn.afm
-share/a2ps/afm/phvr.afm
-share/a2ps/afm/phvro.afm
-share/a2ps/afm/phvron.afm
-share/a2ps/afm/phvrrn.afm
-share/a2ps/afm/pncb.afm
-share/a2ps/afm/pncbi.afm
-share/a2ps/afm/pncr.afm
-share/a2ps/afm/pncri.afm
-share/a2ps/afm/pplb.afm
-share/a2ps/afm/pplbi.afm
-share/a2ps/afm/pplr.afm
-share/a2ps/afm/pplri.afm
-share/a2ps/afm/psyr.afm
-share/a2ps/afm/ptmb.afm
-share/a2ps/afm/ptmbi.afm
-share/a2ps/afm/ptmi.afm
-share/a2ps/afm/ptmr.afm
-share/a2ps/afm/pzcmi.afm
-share/a2ps/afm/pzdr.afm
-share/a2ps/afm/textb18.afm
-share/a2ps/afm/textb19.afm
-share/a2ps/afm/textb20.afm
-share/a2ps/ps/Courier-Bold-Ogonki.pfa
-share/a2ps/ps/Courier-BoldOblique-Ogonki.pfa
-share/a2ps/ps/Courier-Oblique-Ogonki.pfa
-share/a2ps/ps/Courier-Ogonki.pfa
-share/a2ps/ps/Helvetica-Bold-Ogonki.pfa
-share/a2ps/ps/Helvetica-BoldOblique-Ogonki.pfa
-share/a2ps/ps/Helvetica-Oblique-Ogonki.pfa
-share/a2ps/ps/Helvetica-Ogonki.pfa
-share/a2ps/ps/Times-Bold-Ogonki.pfa
-share/a2ps/ps/Times-BoldItalic-Ogonki.pfa
-share/a2ps/ps/Times-Italic-Ogonki.pfa
-share/a2ps/ps/Times-Roman-Ogonki.pfa
-share/a2ps/ps/colle10.pfb
-share/a2ps/ps/colle8.pfb
-share/a2ps/ps/colle9.pfb
-share/a2ps/ps/crr35__i.pfb
-share/a2ps/ps/crr36__i.pfb
-share/a2ps/ps/crr55__i.pfb
-share/a2ps/ps/crr56__i.pfb
-share/a2ps/ps/textb18.pfb
-share/a2ps/ps/textb19.pfb
-share/a2ps/ps/textb20.pfb
-share/locale/ca/LC_MESSAGES/a2ps.mo
-share/locale/cs/LC_MESSAGES/a2ps.mo
-share/locale/de/LC_MESSAGES/a2ps.mo
-share/locale/es/LC_MESSAGES/a2ps.mo
-share/locale/fr/LC_MESSAGES/a2ps.mo
-share/locale/it/LC_MESSAGES/a2ps.mo
-share/locale/ko/LC_MESSAGES/a2ps.mo
-share/locale/nl/LC_MESSAGES/a2ps.mo
-share/locale/pl/LC_MESSAGES/a2ps.mo
-share/locale/tr/LC_MESSAGES/a2ps.mo
-share/a2ps/sheets/sheets.map
-share/a2ps/sheets/68000.ssh
-share/a2ps/sheets/a2psrc.ssh
-share/a2ps/sheets/ada.ssh
-share/a2ps/sheets/cpp.ssh
-share/a2ps/sheets/c.ssh
-share/a2ps/sheets/caml.ssh
-share/a2ps/sheets/chlog.ssh
-share/a2ps/sheets/claire.ssh
-share/a2ps/sheets/clisp.ssh
-share/a2ps/sheets/coqv.ssh
-share/a2ps/sheets/eiffel.ssh
-share/a2ps/sheets/fortran.ssh
-share/a2ps/sheets/initora.ssh
-share/a2ps/sheets/java.ssh
-share/a2ps/sheets/lace.ssh
-share/a2ps/sheets/lex.ssh
-share/a2ps/sheets/mail.ssh
-share/a2ps/sheets/modula3.ssh
-share/a2ps/sheets/o2c.ssh
-share/a2ps/sheets/oberon.ssh
-share/a2ps/sheets/objc.ssh
-share/a2ps/sheets/octave.ssh
-share/a2ps/sheets/oracle.ssh
-share/a2ps/sheets/pascal.ssh
-share/a2ps/sheets/perl.ssh
-share/a2ps/sheets/plsql.ssh
-share/a2ps/sheets/ps.ssh
-share/a2ps/sheets/pre.ssh
-share/a2ps/sheets/prolog.ssh
-share/a2ps/sheets/promela.ssh
-share/a2ps/sheets/python.ssh
-share/a2ps/sheets/sather.ssh
-share/a2ps/sheets/scheme.ssh
-share/a2ps/sheets/sdl88.ssh
-share/a2ps/sheets/sh.ssh
-share/a2ps/sheets/sql.ssh
-share/a2ps/sheets/sql92.ssh
-share/a2ps/sheets/ssh.ssh
-share/a2ps/sheets/tcl.ssh
-share/a2ps/sheets/tex.ssh
-share/a2ps/sheets/tk.ssh
-share/a2ps/sheets/unity.ssh
-share/a2ps/sheets/verilog.ssh
-share/a2ps/sheets/vhdl.ssh
-share/a2ps/sheets/vrml.ssh
-share/a2ps/sheets/yacc.ssh
-share/a2ps/sheets/zsh.ssh
-share/a2ps/encoding/ascii.edf
-share/a2ps/encoding/cp1250.edf
-share/a2ps/encoding/encoding.map
-share/a2ps/encoding/hp.edf
-share/a2ps/encoding/ibmpc.edf
-share/a2ps/encoding/iso5.edf
-share/a2ps/encoding/koi8r.edf
-share/a2ps/encoding/latin1.edf
-share/a2ps/encoding/latin2.edf
-share/a2ps/encoding/latin3.edf
-share/a2ps/encoding/latin4.edf
-share/a2ps/encoding/latin5.edf
-share/a2ps/encoding/latin6.edf
-share/a2ps/encoding/mac.edf
-share/emacs/site-lisp/make-regexp.el
-share/emacs/site-lisp/a2ps.el
-lib/liba2ps.so.0.2
-@exec /sbin/ldconfig -m %B
-lib/liba2ps.a
-etc/a2ps.cfg
-bin/ogonkify
bin/a2ps
-bin/composite
-info/a2ps.info
-info/ogonkify.info
-info/a2ps.info-1
-info/a2ps.info-2
-info/a2ps.info-3
-info/regex.info
-info/regex.info-1
-info/regex.info-2
-info/regex.info-3
man/man1/a2ps.1.gz
-man/man1/ogonkify.1.gz
diff --git a/print/a2ps43-letter/scripts/configure b/print/a2ps43-letter/scripts/configure
new file mode 100644
index 000000000000..b99a44d794f8
--- /dev/null
+++ b/print/a2ps43-letter/scripts/configure
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+cd $WRKSRC || exit 1;
+
+cat >> Makefile << END
+
+PREFIX= $PREFIX
+
+END
+exit 0;
+